MozillaFirefox/MozillaFirefox.spec
branchfirefox89
changeset 1158 00846b9a35cd
parent 1157 57fc0524b50c
child 1159 c4aba2fa0908
equal deleted inserted replaced
1157:57fc0524b50c 1158:00846b9a35cd
     1 #
     1 #
     2 # spec file for package MozillaFirefox
     2 # spec file
     3 #
     3 #
     4 # Copyright (c) 2021 SUSE LLC
     4 # Copyright (c) 2021 SUSE LLC
     5 #               2006-2021 Wolfgang Rosenauer <wr@rosenauer.org>
     5 #               2006-2021 Wolfgang Rosenauer <wr@rosenauer.org>
     6 #
     6 #
     7 # All modifications and additions to the file contributed by third parties
     7 # All modifications and additions to the file contributed by third parties
    30 # orig_version would be the upstream tar ball
    30 # orig_version would be the upstream tar ball
    31 # orig_version 70.0
    31 # orig_version 70.0
    32 # orig_suffix b3
    32 # orig_suffix b3
    33 # major 69
    33 # major 69
    34 # mainver %major.99
    34 # mainver %major.99
    35 %define major          88
    35 %define major          89
    36 %define mainver        %major.0.1
    36 %define mainver        %major.0.2
    37 %define orig_version   88.0.1
    37 %define orig_version   89.0.2
    38 %define orig_suffix    %{nil}
    38 %define orig_suffix    %{nil}
    39 %define update_channel release
    39 %define update_channel release
    40 %define branding       1
    40 %define branding       1
    41 %define devpkg         1
    41 %define devpkg         1
    42 
    42 
    43 # PGO builds do not work in TW currently (bmo#1680306)
    43 # PGO builds do not work in TW currently (bmo#1680306)
    44 %define do_profiling   0
    44 %define do_profiling   0
    45 
    45 
    46 # upstream default is clang (to use gcc for large parts set to 0)
    46 # upstream default is clang (to use gcc for large parts set to 0)
    47 %define clang_build    1
    47 %define clang_build    1
    48 %if 0%{?is_opensuse} && 0%{?suse_version} >= 1550
       
    49 %ifarch x86_64
       
    50 # on Tumbleweed/x86_64 this does not work due to undefined
       
    51 #  references to `__rust_probestack'
       
    52 %define clang_build    0
       
    53 %endif
       
    54 %endif
       
    55 
    48 
    56 # PIE, full relro
    49 # PIE, full relro
    57 %define build_hardened 1
    50 %define build_hardened 1
    58 
    51 
    59 %bcond_with only_print_mozconfig
    52 %bcond_with only_print_mozconfig
   116 BuildRequires:  libidl-devel
   109 BuildRequires:  libidl-devel
   117 BuildRequires:  libiw-devel
   110 BuildRequires:  libiw-devel
   118 BuildRequires:  libproxy-devel
   111 BuildRequires:  libproxy-devel
   119 BuildRequires:  makeinfo
   112 BuildRequires:  makeinfo
   120 BuildRequires:  mozilla-nspr-devel >= 4.30
   113 BuildRequires:  mozilla-nspr-devel >= 4.30
   121 BuildRequires:  mozilla-nss-devel >= 3.63.1
   114 BuildRequires:  mozilla-nss-devel >= 3.64
   122 BuildRequires:  nasm >= 2.14
   115 BuildRequires:  nasm >= 2.14
   123 BuildRequires:  nodejs >= 10.22.1
   116 BuildRequires:  nodejs >= 10.22.1
   124 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   117 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   125 BuildRequires:  python-libxml2
   118 BuildRequires:  python-libxml2
   126 BuildRequires:  python36
   119 BuildRequires:  python36
   127 %else
   120 %else
   128 BuildRequires:  python3 >= 3.5
   121 BuildRequires:  python3 >= 3.5
   129 BuildRequires:  python3-devel
   122 BuildRequires:  python3-devel
   130 %endif
   123 %endif
   131 BuildRequires:  rust >= 1.47
   124 BuildRequires:  rust >= 1.47
   132 BuildRequires:  rust-cbindgen >= 0.16.0
   125 BuildRequires:  rust-cbindgen >= 0.19.0
   133 BuildRequires:  unzip
   126 BuildRequires:  unzip
   134 BuildRequires:  update-desktop-files
   127 BuildRequires:  update-desktop-files
   135 BuildRequires:  xorg-x11-libXt-devel
   128 BuildRequires:  xorg-x11-libXt-devel
   136 %if 0%{?do_profiling}
   129 %if 0%{?do_profiling}
   137 BuildRequires:  xvfb-run
   130 BuildRequires:  xvfb-run
   510 %ifarch s390x
   503 %ifarch s390x
   511 ac_add_options --enable-optimize="-O1"
   504 ac_add_options --enable-optimize="-O1"
   512 %endif
   505 %endif
   513 %ifarch x86_64
   506 %ifarch x86_64
   514 # LTO needs newer toolchain stack only (at least GCC 8.2.1 (r268506)
   507 # LTO needs newer toolchain stack only (at least GCC 8.2.1 (r268506)
   515 %if 0%{?suse_version} > 1500
   508 %if 0%{?suse_version} > 1500 && 0%{?suse_version} < 1550
   516 ac_add_options --enable-lto
   509 ac_add_options --enable-lto
   517 %if 0%{?do_profiling}
   510 %if 0%{?do_profiling}
   518 ac_add_options MOZ_PGO=1
   511 ac_add_options MOZ_PGO=1
   519 %endif
   512 %endif
   520 %endif
   513 %endif