MozillaFirefox/MozillaFirefox.spec
changeset 1134 01a4849e2ed3
parent 1133 0a44f639e5ee
child 1135 082b9d2dfd7d
equal deleted inserted replaced
1133:0a44f639e5ee 1134:01a4849e2ed3
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major          77
    21 %define major          77
    22 %define mainver        %major.99
    22 %define mainver        %major.99
    23 %define orig_version   78.0
    23 %define orig_version   78.0
    24 %define orig_suffix    b6
    24 %define orig_suffix    b7
    25 %define update_channel beta
    25 %define update_channel beta
    26 %define branding       1
    26 %define branding       1
    27 %define devpkg         1
    27 %define devpkg         1
    28 
    28 
    29 # PGO builds do not work in TW currently (bmo#1642410)
    29 # PGO builds do not work in TW currently (bmo#1642410)
    58 %define localize 1
    58 %define localize 1
    59 %ifarch %ix86 x86_64
    59 %ifarch %ix86 x86_64
    60 %define crashreporter 1
    60 %define crashreporter 1
    61 %else
    61 %else
    62 %define crashreporter 0
    62 %define crashreporter 0
       
    63 %endif
       
    64 # pipewire is too old on Leap 15.1
       
    65 %if 0%{?suse_version} == 1500 && 0%{?sle_version} <= 150100
       
    66 %bcond_with pipewire3
       
    67 %else
       
    68 %bcond_without pipewire3
    63 %endif
    69 %endif
    64 
    70 
    65 Name:           %{pkgname}
    71 Name:           %{pkgname}
    66 BuildRequires:  Mesa-devel
    72 BuildRequires:  Mesa-devel
    67 BuildRequires:  alsa-devel
    73 BuildRequires:  alsa-devel
    89 BuildRequires:  python-devel
    95 BuildRequires:  python-devel
    90 BuildRequires:  python2-xml
    96 BuildRequires:  python2-xml
    91 BuildRequires:  python3 >= 3.5
    97 BuildRequires:  python3 >= 3.5
    92 BuildRequires:  rust >= 1.41
    98 BuildRequires:  rust >= 1.41
    93 BuildRequires:  rust-cbindgen >= 0.14.1
    99 BuildRequires:  rust-cbindgen >= 0.14.1
    94 BuildRequires:  startup-notification-devel
       
    95 BuildRequires:  unzip
   100 BuildRequires:  unzip
    96 BuildRequires:  update-desktop-files
   101 BuildRequires:  update-desktop-files
    97 BuildRequires:  xorg-x11-libXt-devel
   102 BuildRequires:  xorg-x11-libXt-devel
    98 %if 0%{?do_profiling}
   103 %if 0%{?do_profiling}
    99 BuildRequires:  xvfb-run
   104 BuildRequires:  xvfb-run
   111 BuildRequires:  pkgconfig(gtk+-3.0) >= 3.14.0
   116 BuildRequires:  pkgconfig(gtk+-3.0) >= 3.14.0
   112 BuildRequires:  pkgconfig(gtk+-unix-print-2.0)
   117 BuildRequires:  pkgconfig(gtk+-unix-print-2.0)
   113 BuildRequires:  pkgconfig(gtk+-unix-print-3.0)
   118 BuildRequires:  pkgconfig(gtk+-unix-print-3.0)
   114 BuildRequires:  pkgconfig(libffi)
   119 BuildRequires:  pkgconfig(libffi)
   115 BuildRequires:  pkgconfig(libpulse)
   120 BuildRequires:  pkgconfig(libpulse)
       
   121 %if %{with pipewire3}
       
   122 BuildRequires:  pkgconfig(libpipewire-0.3)
       
   123 %endif
   116 # libavcodec is required for H.264 support but the
   124 # libavcodec is required for H.264 support but the
   117 # openSUSE version is currently not able to play H.264
   125 # openSUSE version is currently not able to play H.264
   118 # therefore the Packman version is required
   126 # therefore the Packman version is required
   119 # minimum version of libavcodec is 53
   127 # minimum version of libavcodec is 53
   120 Recommends:     libavcodec-full >= 0.10.16
   128 Recommends:     libavcodec-full >= 0.10.16
   177 Patch18:        mozilla-bmo1554971.patch
   185 Patch18:        mozilla-bmo1554971.patch
   178 Patch19:        mozilla-bmo1512162.patch
   186 Patch19:        mozilla-bmo1512162.patch
   179 Patch20:        mozilla-fix-top-level-asm.patch
   187 Patch20:        mozilla-fix-top-level-asm.patch
   180 Patch21:        mozilla-bmo1504834-part4.patch
   188 Patch21:        mozilla-bmo1504834-part4.patch
   181 Patch22:        mozilla-bmo849632.patch
   189 Patch22:        mozilla-bmo849632.patch
       
   190 Patch23:        mozilla-pipewire-0-3.patch
   182 # Firefox/browser
   191 # Firefox/browser
   183 Patch101:       firefox-kde.patch
   192 Patch101:       firefox-kde.patch
   184 Patch102:       firefox-branded-icons.patch
   193 Patch102:       firefox-branded-icons.patch
   185 %endif # only_print_mozconfig
   194 %endif # only_print_mozconfig
   186 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   195 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   309 %patch18 -p1
   318 %patch18 -p1
   310 %patch19 -p1
   319 %patch19 -p1
   311 %patch20 -p1
   320 %patch20 -p1
   312 %patch21 -p1
   321 %patch21 -p1
   313 %patch22 -p1
   322 %patch22 -p1
       
   323 %if %{with pipewire3}
       
   324 %patch23 -p1
       
   325 %endif
   314 # Firefox
   326 # Firefox
   315 %patch101 -p1
   327 %patch101 -p1
   316 %patch102 -p1
   328 %patch102 -p1
   317 %endif # only_print_mozconfig
   329 %endif # only_print_mozconfig
   318 
   330