MozillaFirefox/MozillaFirefox.spec
branchfirefox77
changeset 1128 0d95fa645411
parent 1127 d5b284f833d5
child 1130 ea7152ed4a37
equal deleted inserted replaced
1127:d5b284f833d5 1128:0d95fa645411
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major          77
    21 %define major          77
    22 %define mainver        %major.0
    22 %define mainver        %major.0.1
    23 %define orig_version   77.0
    23 %define orig_version   77.0.1
    24 %define orig_suffix    %{nil}
    24 %define orig_suffix    %{nil}
    25 %define update_channel release
    25 %define update_channel release
    26 %define branding       1
    26 %define branding       1
    27 %define devpkg         1
    27 %define devpkg         1
    28 
    28 
    29 # disable for FF73 for now as it fails for unknown reason
    29 # PGO builds do not work in TW currently (bmo#1642410)
    30 %define do_profiling   0
    30 %define do_profiling   0
    31 
    31 
    32 # upstream default is clang (to use gcc for large parts set to 0)
    32 # upstream default is clang (to use gcc for large parts set to 0)
    33 %define clang_build 1
    33 %define clang_build 0
    34 
    34 
    35 # PIE, full relro
    35 # PIE, full relro
    36 %define build_hardened 1
    36 %define build_hardened 1
    37 
    37 
    38 %bcond_with only_print_mozconfig
    38 %bcond_with only_print_mozconfig
   102 BuildRequires:  yasm
   102 BuildRequires:  yasm
   103 BuildRequires:  zip
   103 BuildRequires:  zip
   104 %if 0%{?suse_version} < 1550
   104 %if 0%{?suse_version} < 1550
   105 BuildRequires:  pkgconfig(gconf-2.0) >= 1.2.1
   105 BuildRequires:  pkgconfig(gconf-2.0) >= 1.2.1
   106 %endif
   106 %endif
       
   107 BuildRequires:  clang-devel >= 5
   107 BuildRequires:  pkgconfig(gdk-x11-2.0)
   108 BuildRequires:  pkgconfig(gdk-x11-2.0)
   108 BuildRequires:  pkgconfig(glib-2.0) >= 2.22
   109 BuildRequires:  pkgconfig(glib-2.0) >= 2.22
   109 BuildRequires:  pkgconfig(gobject-2.0)
   110 BuildRequires:  pkgconfig(gobject-2.0)
   110 BuildRequires:  pkgconfig(gtk+-2.0) >= 2.18.0
   111 BuildRequires:  pkgconfig(gtk+-2.0) >= 2.18.0
   111 BuildRequires:  pkgconfig(gtk+-3.0) >= 3.4.0
   112 BuildRequires:  pkgconfig(gtk+-3.0) >= 3.4.0
   112 BuildRequires:  pkgconfig(gtk+-unix-print-2.0)
   113 BuildRequires:  pkgconfig(gtk+-unix-print-2.0)
   113 BuildRequires:  pkgconfig(gtk+-unix-print-3.0)
   114 BuildRequires:  pkgconfig(gtk+-unix-print-3.0)
   114 BuildRequires:  pkgconfig(libffi)
   115 BuildRequires:  pkgconfig(libffi)
   115 BuildRequires:  pkgconfig(libpulse)
   116 BuildRequires:  pkgconfig(libpulse)
   116 %if 0%{?suse_version} > 1320
       
   117 BuildRequires:  llvm-clang-devel >= 3.9.0
       
   118 %else
       
   119 # this covers the workaround to compile on Leap 42 in OBS
       
   120 BuildRequires:  clang4-devel
       
   121 %endif
       
   122 # libavcodec is required for H.264 support but the
   117 # libavcodec is required for H.264 support but the
   123 # openSUSE version is currently not able to play H.264
   118 # openSUSE version is currently not able to play H.264
   124 # therefore the Packman version is required
   119 # therefore the Packman version is required
   125 # minimum version of libavcodec is 53
   120 # minimum version of libavcodec is 53
   126 Recommends:     libavcodec-full >= 0.10.16
   121 Recommends:     libavcodec-full >= 0.10.16
   184 Patch18:        mozilla-bmo1554971.patch
   179 Patch18:        mozilla-bmo1554971.patch
   185 Patch19:        mozilla-bmo1512162.patch
   180 Patch19:        mozilla-bmo1512162.patch
   186 Patch20:        mozilla-fix-top-level-asm.patch
   181 Patch20:        mozilla-fix-top-level-asm.patch
   187 Patch21:        mozilla-bmo1504834-part4.patch
   182 Patch21:        mozilla-bmo1504834-part4.patch
   188 Patch22:        mozilla-bmo849632.patch
   183 Patch22:        mozilla-bmo849632.patch
       
   184 Patch23:        mozilla-bmo1634646.patch
   189 # Firefox/browser
   185 # Firefox/browser
   190 Patch101:       firefox-kde.patch
   186 Patch101:       firefox-kde.patch
   191 Patch102:       firefox-branded-icons.patch
   187 Patch102:       firefox-branded-icons.patch
   192 %endif # only_print_mozconfig
   188 %endif # only_print_mozconfig
   193 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   189 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   205 %endif
   201 %endif
   206 # libproxy's mozjs pacrunner crashes FF (bnc#759123)
   202 # libproxy's mozjs pacrunner crashes FF (bnc#759123)
   207 %if 0%{?suse_version} < 1220
   203 %if 0%{?suse_version} < 1220
   208 Obsoletes:      libproxy1-pacrunner-mozjs <= 0.4.7
   204 Obsoletes:      libproxy1-pacrunner-mozjs <= 0.4.7
   209 %endif
   205 %endif
   210 ##BuildArch:      i686 x86_64 aarch64 ppc64le
   206 ExcludeArch:    armv6l armv6hl
   211 
   207 
   212 %description
   208 %description
   213 Mozilla Firefox is a standalone web browser, designed for standards
   209 Mozilla Firefox is a standalone web browser, designed for standards
   214 compliance and performance.  Its functionality can be enhanced via a
   210 compliance and performance.  Its functionality can be enhanced via a
   215 plethora of extensions.
   211 plethora of extensions.
   319 %patch18 -p1
   315 %patch18 -p1
   320 %patch19 -p1
   316 %patch19 -p1
   321 %patch20 -p1
   317 %patch20 -p1
   322 %patch21 -p1
   318 %patch21 -p1
   323 %patch22 -p1
   319 %patch22 -p1
       
   320 %patch23 -p1
   324 # Firefox
   321 # Firefox
   325 %patch101 -p1
   322 %patch101 -p1
   326 %patch102 -p1
   323 %patch102 -p1
   327 %endif # only_print_mozconfig
   324 %endif # only_print_mozconfig
   328 
   325