MozillaFirefox/MozillaFirefox.spec
changeset 515 0f6539389500
parent 511 a5cbc8c27e63
child 522 fdca14856f37
equal deleted inserted replaced
514:ff06037ec39c 515:0f6539389500
    15 
    15 
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 %define major 14
    20 %define major 15
    21 %define mainver %major.99
    21 %define mainver %major.98
    22 %define update_channel beta
    22 %define update_channel aurora
    23 
    23 
    24 Name:           MozillaFirefox
    24 Name:           MozillaFirefox
    25 BuildRequires:  Mesa-devel
    25 BuildRequires:  Mesa-devel
    26 BuildRequires:  autoconf213
    26 BuildRequires:  autoconf213
    27 BuildRequires:  dbus-1-glib-devel
    27 BuildRequires:  dbus-1-glib-devel
    42 BuildRequires:  libiw-devel
    42 BuildRequires:  libiw-devel
    43 BuildRequires:  libproxy-devel
    43 BuildRequires:  libproxy-devel
    44 %else
    44 %else
    45 BuildRequires:  wireless-tools
    45 BuildRequires:  wireless-tools
    46 %endif
    46 %endif
    47 BuildRequires:  mozilla-nspr-devel >= 4.9.1
    47 BuildRequires:  mozilla-nspr-devel >= 4.9.2
    48 BuildRequires:  mozilla-nss-devel >= 3.13.5
    48 BuildRequires:  mozilla-nss-devel >= 3.13.5
    49 BuildRequires:  nss-shared-helper-devel
    49 BuildRequires:  nss-shared-helper-devel
    50 %if %suse_version > 1140
    50 %if %suse_version > 1140
    51 BuildRequires:  pkgconfig(gstreamer-0.10)
    51 BuildRequires:  pkgconfig(gstreamer-0.10)
    52 BuildRequires:  pkgconfig(gstreamer-app-0.10)
    52 BuildRequires:  pkgconfig(gstreamer-app-0.10)
    53 BuildRequires:  pkgconfig(gstreamer-plugins-base-0.10)
    53 BuildRequires:  pkgconfig(gstreamer-plugins-base-0.10)
    54 %endif
    54 %endif
    55 Version:        %{mainver}
    55 Version:        %{mainver}
    56 Release:        0
    56 Release:        0
    57 %define         releasedate 2012071800
    57 %define         releasedate 2012072300
    58 Provides:       firefox = %{mainver}
    58 Provides:       firefox = %{mainver}
    59 Provides:       firefox = %{version}-%{release}
    59 Provides:       firefox = %{version}-%{release}
    60 Provides:       web_browser
    60 Provides:       web_browser
    61 Provides:       browser(npapi)
    61 Provides:       browser(npapi)
    62 # this is needed to match this package with the kde4 helper package without the main package
    62 # this is needed to match this package with the kde4 helper package without the main package
    92 Patch8:         mozilla-ntlm-full-path.patch
    92 Patch8:         mozilla-ntlm-full-path.patch
    93 Patch9:         mozilla-repo.patch
    93 Patch9:         mozilla-repo.patch
    94 Patch10:        mozilla-sle11.patch
    94 Patch10:        mozilla-sle11.patch
    95 Patch11:        mozilla-disable-neon-option.patch
    95 Patch11:        mozilla-disable-neon-option.patch
    96 Patch13:        mozilla-arm-disable-edsp.patch
    96 Patch13:        mozilla-arm-disable-edsp.patch
    97 Patch14:        mozilla-crashreporter-restart-args.patch
       
    98 Patch15:        mozilla-gstreamer.patch
    97 Patch15:        mozilla-gstreamer.patch
    99 Patch16:        mozilla-ppc.patch
    98 Patch16:        mozilla-ppc.patch
   100 # Firefox/browser
    99 # Firefox/browser
   101 Patch30:        firefox-browser-css.patch
   100 Patch30:        firefox-browser-css.patch
   102 Patch31:        firefox-kde.patch
   101 Patch31:        firefox-kde.patch
   123 %define desktop_file_name firefox
   122 %define desktop_file_name firefox
   124 %else
   123 %else
   125 %define desktop_file_name %{name}
   124 %define desktop_file_name %{name}
   126 %endif
   125 %endif
   127 ### build options
   126 ### build options
   128 %define branding 1
   127 %define branding 0
   129 %define localize 1
   128 %define localize 1
   130 %ifarch ppc ppc64 s390 s390x ia64 %arm
   129 %ifarch ppc ppc64 s390 s390x ia64 %arm
   131 %define crashreporter 0
   130 %define crashreporter 0
   132 %else
   131 %else
   133 %define crashreporter 1
   132 %define crashreporter 1
   221 %if %suse_version < 1120
   220 %if %suse_version < 1120
   222 %patch10 -p1
   221 %patch10 -p1
   223 %endif
   222 %endif
   224 #%patch11 -p1
   223 #%patch11 -p1
   225 %patch13 -p1
   224 %patch13 -p1
   226 %patch14 -p1
       
   227 %patch15 -p1
   225 %patch15 -p1
   228 %patch16 -p1
   226 %patch16 -p1
   229 #
   227 #
   230 %patch30 -p1
   228 %patch30 -p1
   231 %if %suse_version >= 1110
   229 %if %suse_version >= 1110
   273 ac_add_options --prefix=%{_prefix}
   271 ac_add_options --prefix=%{_prefix}
   274 ac_add_options --libdir=%{_libdir}
   272 ac_add_options --libdir=%{_libdir}
   275 ac_add_options --sysconfdir=%{_sysconfdir}
   273 ac_add_options --sysconfdir=%{_sysconfdir}
   276 ac_add_options --mandir=%{_mandir}
   274 ac_add_options --mandir=%{_mandir}
   277 ac_add_options --includedir=%{_includedir}
   275 ac_add_options --includedir=%{_includedir}
   278 ac_add_options --with-system-nspr
   276 #ac_add_options --with-system-nspr
   279 ac_add_options --with-system-nss
   277 #ac_add_options --with-system-nss
   280 ac_add_options --with-l10n-base=$RPM_BUILD_DIR/l10n
   278 ac_add_options --with-l10n-base=$RPM_BUILD_DIR/l10n
   281 #ac_add_options --with-system-jpeg    # libjpeg-turbo is used internally
   279 #ac_add_options --with-system-jpeg    # libjpeg-turbo is used internally
   282 #ac_add_options --with-system-png     # doesn't work because of missing APNG support
   280 #ac_add_options --with-system-png     # doesn't work because of missing APNG support
   283 ac_add_options --with-system-zlib
   281 ac_add_options --with-system-zlib
   284 ac_add_options --disable-installer
   282 ac_add_options --disable-installer