MozillaFirefox/MozillaFirefox.spec
branchfirefox52
changeset 976 14640a79141f
parent 975 3dafce6546a4
child 980 c0c95a18e37c
equal deleted inserted replaced
975:3dafce6546a4 976:14640a79141f
   293 export MOZILLA_OFFICIAL=1
   293 export MOZILLA_OFFICIAL=1
   294 export BUILD_OFFICIAL=1
   294 export BUILD_OFFICIAL=1
   295 export MOZ_TELEMETRY_REPORTING=1
   295 export MOZ_TELEMETRY_REPORTING=1
   296 export MOZ_GOOGLE_API_KEY=%{_google_api_key}
   296 export MOZ_GOOGLE_API_KEY=%{_google_api_key}
   297 export CFLAGS="%{optflags} -fno-strict-aliasing"
   297 export CFLAGS="%{optflags} -fno-strict-aliasing"
   298 # boo#986541: add -fno-delete-null-pointer-checks and -fno-inline-small-functions for gcc6
   298 # boo#986541: add -fno-delete-null-pointer-checks for gcc6
   299 %if 0%{?suse_version} > 1320
   299 %if 0%{?suse_version} > 1320
   300 export CFLAGS="$CFLAGS -fno-delete-null-pointer-checks -fno-inline-small-functions"
   300 export CFLAGS="$CFLAGS -fno-delete-null-pointer-checks"
   301 %endif
   301 %endif
   302 %ifarch %arm
   302 %ifarch %arm
   303 export CFLAGS="${CFLAGS/-g / }"
   303 export CFLAGS="${CFLAGS/-g / }"
   304 %endif
   304 %endif
   305 %ifarch %arm %ix86
   305 %ifarch %arm %ix86
   334 %else
   334 %else
   335 ac_add_options --enable-default-toolkit=cairo-gtk2
   335 ac_add_options --enable-default-toolkit=cairo-gtk2
   336 %endif
   336 %endif
   337 %if 0%{?build_hardened}
   337 %if 0%{?build_hardened}
   338 ac_add_options --enable-pie
   338 ac_add_options --enable-pie
       
   339 %endif
       
   340 # gcc7 (boo#104105)
       
   341 %if 0%{?suse_version} > 1320
       
   342 ac_add_options --enable-optimize="-g -O2"
   339 %endif
   343 %endif
   340 %ifarch %ix86 %arm
   344 %ifarch %ix86 %arm
   341 %if 0%{?suse_version} > 1230
   345 %if 0%{?suse_version} > 1230
   342 ac_add_options --disable-optimize
   346 ac_add_options --disable-optimize
   343 %endif
   347 %endif