xulrunner/xulrunner.spec
branchfirefox6
changeset 332 15b1945a3bc1
parent 324 c6ab0c6a483b
equal deleted inserted replaced
328:f72845854bff 332:15b1945a3bc1
    18 
    18 
    19 # norootforbuild
    19 # norootforbuild
    20 
    20 
    21 
    21 
    22 Name:           xulrunner
    22 Name:           xulrunner
    23 BuildRequires:  Mesa-devel autoconf213 dbus-1-glib-devel fdupes gcc-c++ hunspell-devel libcurl-devel libgnomeui-devel libidl-devel libnotify-devel python startup-notification-devel unzip pkg-config yasm nss-shared-helper-devel zip
    23 BuildRequires:  Mesa-devel autoconf213 dbus-1-glib-devel fdupes gcc-c++ hunspell-devel libcurl-devel libgnomeui-devel libidl-devel libnotify-devel nss-shared-helper-devel pkg-config python startup-notification-devel unzip yasm zip
    24 %if %suse_version > 1110
    24 %if %suse_version > 1110
    25 BuildRequires:  libiw-devel
    25 BuildRequires:  libiw-devel
    26 BuildRequires:  libproxy-devel
    26 BuildRequires:  libproxy-devel
    27 %else
    27 %else
    28 BuildRequires:  wireless-tools
    28 BuildRequires:  wireless-tools
    63 Patch11:        mozilla-ntlm-full-path.patch
    63 Patch11:        mozilla-ntlm-full-path.patch
    64 Patch12:        mozilla-dump_syms-static.patch
    64 Patch12:        mozilla-dump_syms-static.patch
    65 Patch13:        mozilla-sle11.patch
    65 Patch13:        mozilla-sle11.patch
    66 Patch14:        mozilla-linux3.patch
    66 Patch14:        mozilla-linux3.patch
    67 Patch15:        mozilla-curl.patch
    67 Patch15:        mozilla-curl.patch
       
    68 Patch16:        mozilla-639554.patch
    68 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
    69 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
    69 Requires:       mozilla-js = %{version}
    70 Requires:       mozilla-js = %{version}
    70 Requires(post):  update-alternatives coreutils
    71 Requires(post):  update-alternatives coreutils
    71 Requires(preun): update-alternatives coreutils
    72 Requires(preun): update-alternatives coreutils
    72 ### build configuration ###
    73 ### build configuration ###
   125 
   126 
   126 %description devel
   127 %description devel
   127 Software Development Kit to embed XUL or Gecko into other applications.
   128 Software Development Kit to embed XUL or Gecko into other applications.
   128 
   129 
   129 %if %localize
   130 %if %localize
       
   131 
   130 %package translations-common
   132 %package translations-common
   131 License:        MPLv1.1 or GPLv2+ or LGPLv2+
   133 License:        MPLv1.1 or GPLv2+ or LGPLv2+
   132 Summary:        Common translations for XULRunner
   134 Summary:        Common translations for XULRunner
   133 Group:          System/Localization
   135 Group:          System/Localization
   134 Requires:       %{name} = %{version}
   136 Requires:       %{name} = %{version}
   158 Thunderbird.
   160 Thunderbird.
   159 
   161 
   160 This package contains rarely used languages.
   162 This package contains rarely used languages.
   161 %endif
   163 %endif
   162 
   164 
   163 
       
   164 %if %crashreporter
   165 %if %crashreporter
       
   166 
   165 %package buildsymbols
   167 %package buildsymbols
   166 License:        MPLv1.1 or GPLv2+ or LGPLv2+
   168 License:        MPLv1.1 or GPLv2+ or LGPLv2+
   167 Summary:        Breakpad buildsymbols for %{name}
   169 Summary:        Breakpad buildsymbols for %{name}
   168 Group:          Development/Debug
   170 Group:          Development/Debug
   169 
   171 
   187 %if %suse_version < 1120
   189 %if %suse_version < 1120
   188 %patch13 -p1
   190 %patch13 -p1
   189 %endif
   191 %endif
   190 %patch14 -p1
   192 %patch14 -p1
   191 %patch15 -p1
   193 %patch15 -p1
   192 
   194 %patch16 -p1
   193 
   195 
   194 %build
   196 %build
   195 # no need to add build time to binaries
   197 # no need to add build time to binaries
   196 modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/%{name}.changes")"
   198 modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/%{name}.changes")"
   197 DATE="\"$(date -d "${modified}" "+%%b %%e %%Y")\""
   199 DATE="\"$(date -d "${modified}" "+%%b %%e %%Y")\""
   281 %install
   283 %install
   282 cd ../obj
   284 cd ../obj
   283 # preferences (to package in omni.jar)
   285 # preferences (to package in omni.jar)
   284 cp %{SOURCE4} dist/bin/defaults/pref/all-openSUSE.js
   286 cp %{SOURCE4} dist/bin/defaults/pref/all-openSUSE.js
   285 %makeinstall STRIP=/bin/true
   287 %makeinstall STRIP=/bin/true
       
   288 # xpt.py is not executable
       
   289 chmod a+x $RPM_BUILD_ROOT%{_libdir}/xulrunner-devel-%{version_internal}/sdk/bin/xpt.py
   286 # remove some executable permissions
   290 # remove some executable permissions
   287 find $RPM_BUILD_ROOT%{_includedir}/xulrunner-%{version_internal} \
   291 find $RPM_BUILD_ROOT%{_includedir}/xulrunner-%{version_internal} \
   288      -type f -perm -111 -exec chmod a-x {} \;
   292      -type f -perm -111 -exec chmod a-x {} \;
   289 find $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/ \
   293 find $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/ \
   290      -name "*.js" -o -name "*.xpm" -o -name "*.png" | xargs chmod a-x
   294      -name "*.js" -o -name "*.xpm" -o -name "*.png" | xargs chmod a-x
   476 %attr(644,root,root) %{_libdir}/pkgconfig/*
   480 %attr(644,root,root) %{_libdir}/pkgconfig/*
   477 %{_includedir}/xulrunner-%{version_internal}/
   481 %{_includedir}/xulrunner-%{version_internal}/
   478 %{_datadir}/xulrunner-%{version_internal}/
   482 %{_datadir}/xulrunner-%{version_internal}/
   479 
   483 
   480 %if %localize
   484 %if %localize
       
   485 
   481 %files translations-common -f %{_tmppath}/translations.common
   486 %files translations-common -f %{_tmppath}/translations.common
   482 %defattr(-,root,root)
   487 %defattr(-,root,root)
   483 %dir %{_libdir}/xulrunner-%{version_internal}/
   488 %dir %{_libdir}/xulrunner-%{version_internal}/
   484 %dir %{_libdir}/xulrunner-%{version_internal}/chrome/
   489 %dir %{_libdir}/xulrunner-%{version_internal}/chrome/
   485 
   490 
   488 %dir %{_libdir}/xulrunner-%{version_internal}/
   493 %dir %{_libdir}/xulrunner-%{version_internal}/
   489 %dir %{_libdir}/xulrunner-%{version_internal}/chrome/
   494 %dir %{_libdir}/xulrunner-%{version_internal}/chrome/
   490 %endif
   495 %endif
   491 
   496 
   492 %if %crashreporter
   497 %if %crashreporter
       
   498 
   493 %files buildsymbols
   499 %files buildsymbols
   494 %defattr(-,root,root)
   500 %defattr(-,root,root)
   495 %{_datadir}/mozilla/
   501 %{_datadir}/mozilla/
   496 %endif
   502 %endif
   497 
   503