MozillaFirefox/MozillaFirefox.spec
changeset 1070 18f97bd2c2bf
parent 1069 0410f6db95d5
child 1071 8dc7d19e8298
equal deleted inserted replaced
1069:0410f6db95d5 1070:18f97bd2c2bf
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major          61
    21 %define major          61
    22 %define mainver        %major.99
    22 %define mainver        %major.99
    23 %define orig_version   62.0
    23 %define orig_version   62.0
    24 %define orig_suffix    b19
    24 %define orig_suffix    b20
    25 %define update_channel beta
    25 %define update_channel beta
    26 %define branding       1
    26 %define branding       1
    27 %define releasedate    20180820172315
    27 %define releasedate    20180823143155
    28 %define source_prefix  firefox-%{orig_version}
    28 %define source_prefix  firefox-%{orig_version}
    29 
    29 
    30 # PIE, full relro (x86_64 for now)
    30 # PIE, full relro (x86_64 for now)
    31 %define build_hardened 1
    31 %define build_hardened 1
    32 
    32 
   158 Patch5:         mozilla-no-stdcxx-check.patch
   158 Patch5:         mozilla-no-stdcxx-check.patch
   159 Patch6:         mozilla-reduce-files-per-UnifiedBindings.patch
   159 Patch6:         mozilla-reduce-files-per-UnifiedBindings.patch
   160 Patch7:         mozilla-aarch64-startup-crash.patch
   160 Patch7:         mozilla-aarch64-startup-crash.patch
   161 Patch8:         mozilla-bmo256180.patch
   161 Patch8:         mozilla-bmo256180.patch
   162 Patch9:         mozilla-no-return.patch
   162 Patch9:         mozilla-no-return.patch
   163 Patch10:        mozilla-unsignedScopes.patch
       
   164 # Firefox/browser
   163 # Firefox/browser
   165 Patch101:       firefox-kde.patch
   164 Patch101:       firefox-kde.patch
   166 Patch102:       firefox-branded-icons.patch
   165 Patch102:       firefox-branded-icons.patch
   167 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   166 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   168 Requires(post):   coreutils shared-mime-info desktop-file-utils
   167 Requires(post):   coreutils shared-mime-info desktop-file-utils
   269 %patch6 -p1
   268 %patch6 -p1
   270 %endif
   269 %endif
   271 %patch7 -p1
   270 %patch7 -p1
   272 %patch8 -p1
   271 %patch8 -p1
   273 %patch9 -p1
   272 %patch9 -p1
   274 %patch10 -p1
       
   275 # Firefox
   273 # Firefox
   276 %patch101 -p1
   274 %patch101 -p1
   277 %patch102 -p1
   275 %patch102 -p1
   278 
   276 
   279 %build
   277 %build
   370 ac_add_options --enable-startup-notification
   368 ac_add_options --enable-startup-notification
   371 #ac_add_options --enable-chrome-format=jar
   369 #ac_add_options --enable-chrome-format=jar
   372 ac_add_options --enable-update-channel=%{update_channel}
   370 ac_add_options --enable-update-channel=%{update_channel}
   373 ac_add_options --with-mozilla-api-keyfile=%{SOURCE18}
   371 ac_add_options --with-mozilla-api-keyfile=%{SOURCE18}
   374 ac_add_options --with-google-api-keyfile=%{SOURCE19}
   372 ac_add_options --with-google-api-keyfile=%{SOURCE19}
       
   373 ac_add_options --with-unsigned-addon-scopes=app
   375 %if %branding
   374 %if %branding
   376 ac_add_options --enable-official-branding
   375 ac_add_options --enable-official-branding
   377 %endif
   376 %endif
   378 ac_add_options --enable-libproxy
   377 ac_add_options --enable-libproxy
   379 %if ! %crashreporter
   378 %if ! %crashreporter