MozillaFirefox/MozillaFirefox.spec
branchfirefox110
changeset 1184 1c3d3217d679
parent 1183 e69790650e3c
child 1185 da29365b0b2c
equal deleted inserted replaced
1183:e69790650e3c 1184:1c3d3217d679
    26 # orig_version would be the upstream tar ball
    26 # orig_version would be the upstream tar ball
    27 # orig_version 70.0
    27 # orig_version 70.0
    28 # orig_suffix b3
    28 # orig_suffix b3
    29 # major 69
    29 # major 69
    30 # mainver %major.99
    30 # mainver %major.99
    31 %define major          109
    31 %define major          110
    32 %define mainver        %major.0.1
    32 %define mainver        %major.0.1
    33 %define orig_version   109.0.1
    33 %define orig_version   110.0.1
    34 %define orig_suffix    %{nil}
    34 %define orig_suffix    %{nil}
    35 %define update_channel release
    35 %define update_channel release
    36 %define branding       1
    36 %define branding       1
    37 %define devpkg         1
    37 %define devpkg         1
    38 
    38 
    97 BuildRequires:  gcc11-c++
    97 BuildRequires:  gcc11-c++
    98 %else
    98 %else
    99 BuildRequires:  gcc-c++
    99 BuildRequires:  gcc-c++
   100 %endif
   100 %endif
   101 %if 0%{?suse_version} < 1550 && 0%{?sle_version} < 150300
   101 %if 0%{?suse_version} < 1550 && 0%{?sle_version} < 150300
   102 BuildRequires:  cargo >= 1.63
   102 BuildRequires:  cargo >= 1.65
   103 BuildRequires:  rust >= 1.63
   103 BuildRequires:  rust >= 1.65
   104 %else
   104 %else
   105 # Newer sle/leap/tw use parallel versioned rust releases which have
   105 # Newer sle/leap/tw use parallel versioned rust releases which have
   106 # a different method for provides that we can use to request a
   106 # a different method for provides that we can use to request a
   107 # specific version
   107 # specific version
   108 # minimal requirement:
   108 # minimal requirement:
   109 BuildRequires:  rust+cargo >= 1.63
   109 BuildRequires:  rust+cargo >= 1.65
   110 # actually used upstream:
   110 # actually used upstream:
   111 BuildRequires:  cargo1.65
   111 BuildRequires:  cargo1.66
   112 BuildRequires:  rust1.65
   112 BuildRequires:  rust1.66
   113 %endif
   113 %endif
   114 %if 0%{useccache} != 0
   114 %if 0%{useccache} != 0
   115 BuildRequires:  ccache
   115 BuildRequires:  ccache
   116 %endif
   116 %endif
   117 BuildRequires:  libXcomposite-devel
   117 BuildRequires:  libXcomposite-devel
   118 BuildRequires:  libcurl-devel
   118 BuildRequires:  libcurl-devel
   119 BuildRequires:  libiw-devel
   119 BuildRequires:  libiw-devel
   120 BuildRequires:  libproxy-devel
   120 BuildRequires:  libproxy-devel
   121 BuildRequires:  makeinfo
   121 BuildRequires:  makeinfo
   122 BuildRequires:  mozilla-nspr-devel >= 4.35
   122 BuildRequires:  mozilla-nspr-devel >= 4.35
   123 BuildRequires:  mozilla-nss-devel >= 3.86
   123 BuildRequires:  mozilla-nss-devel >= 3.87
   124 BuildRequires:  nasm >= 2.14
   124 BuildRequires:  nasm >= 2.14
   125 BuildRequires:  nodejs >= 10.22.1
   125 BuildRequires:  nodejs >= 10.22.1
   126 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   126 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   127 BuildRequires:  python-libxml2
   127 BuildRequires:  python-libxml2
   128 BuildRequires:  python36
   128 BuildRequires:  python36
   191 Source8:        firefox-mimeinfo.xml
   191 Source8:        firefox-mimeinfo.xml
   192 Source9:        firefox.js
   192 Source9:        firefox.js
   193 Source11:       firefox.1
   193 Source11:       firefox.1
   194 Source12:       mozilla-get-app-id
   194 Source12:       mozilla-get-app-id
   195 Source13:       spellcheck.js
   195 Source13:       spellcheck.js
   196 Source14:       https://github.com/openSUSE/firefox-scripts/raw/4503820/create-tar.sh
   196 Source14:       https://github.com/openSUSE/firefox-scripts/raw/7335408da3073ec6b582fc364010cf09665765b3/create-tar.sh
   197 Source15:       firefox-appdata.xml
   197 Source15:       firefox-appdata.xml
   198 Source16:       %{name}.changes
   198 Source16:       %{name}.changes
   199 Source17:       firefox-search-provider.ini
   199 Source17:       firefox-search-provider.ini
   200 # Set up API keys, see http://www.chromium.org/developers/how-tos/api-keys
   200 # Set up API keys, see http://www.chromium.org/developers/how-tos/api-keys
   201 # Note: these are for the openSUSE Firefox builds ONLY. For your own distribution,
   201 # Note: these are for the openSUSE Firefox builds ONLY. For your own distribution,
   226 Patch22:        mozilla-silence-no-return-type.patch
   226 Patch22:        mozilla-silence-no-return-type.patch
   227 Patch23:        mozilla-bmo531915.patch
   227 Patch23:        mozilla-bmo531915.patch
   228 Patch25:        one_swizzle_to_rule_them_all.patch
   228 Patch25:        one_swizzle_to_rule_them_all.patch
   229 Patch26:        svg-rendering.patch
   229 Patch26:        svg-rendering.patch
   230 Patch27:        mozilla-buildfixes.patch
   230 Patch27:        mozilla-buildfixes.patch
       
   231 Patch28:        mozilla-bmo1810584.patch
       
   232 Patch29:        gcc13-fix.patch
   231 # Firefox/browser
   233 # Firefox/browser
   232 Patch101:       firefox-kde.patch
   234 Patch101:       firefox-kde.patch
   233 Patch102:       firefox-branded-icons.patch
   235 Patch102:       firefox-branded-icons.patch
   234 %endif
   236 %endif
   235 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   237 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   402 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   404 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   403 EOF
   405 EOF
   404 # Done with env-variables.
   406 # Done with env-variables.
   405 source ./.obsenv.sh
   407 source ./.obsenv.sh
   406 
   408 
   407 %ifarch aarch64 %arm ppc64 ppc64le
   409 %ifarch aarch64 %arm ppc64 ppc64le riscv64
   408 %limit_build -m 2500
   410 %limit_build -m 2500
   409 %endif
   411 %endif
   410 
   412 
   411 # Generating mozconfig
   413 # Generating mozconfig
   412 cat << EOF > $MOZCONFIG
   414 cat << EOF > $MOZCONFIG