MozillaFirefox/MozillaFirefox.spec
changeset 356 30a00f382aed
parent 355 91b462c0fd72
child 358 b28670af14d5
equal deleted inserted replaced
355:91b462c0fd72 356:30a00f382aed
    17 #
    17 #
    18 
    18 
    19 # norootforbuild
    19 # norootforbuild
    20 
    20 
    21 %define major 8
    21 %define major 8
    22 %define mainver %major.0
    22 %define mainver %major.99
    23 
    23 
    24 Name:           MozillaFirefox
    24 Name:           MozillaFirefox
    25 BuildRequires:  Mesa-devel autoconf213 dbus-1-glib-devel fdupes gcc-c++ libcurl-devel libgnomeui-devel libidl-devel libnotify-devel python startup-notification-devel unzip update-desktop-files yasm zip
    25 BuildRequires:  Mesa-devel autoconf213 dbus-1-glib-devel fdupes gcc-c++ libcurl-devel libgnomeui-devel libidl-devel libnotify-devel python startup-notification-devel unzip update-desktop-files yasm zip
    26 %if %suse_version > 1110
    26 %if %suse_version > 1110
    27 BuildRequires:  libiw-devel
    27 BuildRequires:  libiw-devel
    28 BuildRequires:  libproxy-devel
    28 BuildRequires:  libproxy-devel
    29 %else
    29 %else
    30 BuildRequires:  wireless-tools
    30 BuildRequires:  wireless-tools
    31 %endif
    31 %endif
    32 BuildRequires:  mozilla-nspr-devel >= 4.8.8
    32 BuildRequires:  mozilla-nspr-devel >= 4.8.9
    33 BuildRequires:  mozilla-nss-devel >= 3.12.10
    33 BuildRequires:  mozilla-nss-devel >= 3.13.1
    34 BuildRequires:  nss-shared-helper-devel
    34 BuildRequires:  nss-shared-helper-devel
    35 License:        MPLv1.1 or GPLv2+ or LGPLv2+
    35 License:        MPLv1.1 or GPLv2+ or LGPLv2+
    36 Version:        %{mainver}
    36 Version:        %{mainver}
    37 Release:        1
    37 Release:        1
    38 %define         releasedate 2011110500
    38 %define         releasedate 2011111700
    39 Provides:       web_browser
    39 Provides:       web_browser
    40 Provides:       firefox = %{version}-%{release}
    40 Provides:       firefox = %{version}-%{release}
    41 Provides:       firefox = %{mainver}
    41 Provides:       firefox = %{mainver}
    42 # this is needed to match this package with the kde4 helper package without the main package
    42 # this is needed to match this package with the kde4 helper package without the main package
    43 # having a hard requirement on the kde4 package
    43 # having a hard requirement on the kde4 package
   266 ac_add_options --disable-updater
   266 ac_add_options --disable-updater
   267 ac_add_options --disable-tests
   267 ac_add_options --disable-tests
   268 ac_add_options --disable-debug
   268 ac_add_options --disable-debug
   269 ac_add_options --enable-startup-notification
   269 ac_add_options --enable-startup-notification
   270 #ac_add_options --enable-chrome-format=jar
   270 #ac_add_options --enable-chrome-format=jar
   271 ac_add_options --enable-update-channel=default
   271 ac_add_options --enable-update-channel=beta
   272 EOF
   272 EOF
   273 %if %suse_version > 1130
   273 %if %suse_version > 1130
   274 cat << EOF >> $MOZCONFIG
   274 cat << EOF >> $MOZCONFIG
   275 ac_add_options --disable-gnomevfs
   275 ac_add_options --disable-gnomevfs
   276 ac_add_options --enable-gio
   276 ac_add_options --enable-gio
   306 mkdir -p $RPM_BUILD_ROOT/%{progdir}/distribution/extensions
   306 mkdir -p $RPM_BUILD_ROOT/%{progdir}/distribution/extensions
   307 mkdir -p $RPM_BUILD_ROOT%{progdir}/searchplugins
   307 mkdir -p $RPM_BUILD_ROOT%{progdir}/searchplugins
   308 # install kde.js
   308 # install kde.js
   309 %if %suse_version >= 1110
   309 %if %suse_version >= 1110
   310 install -m 644 %{SOURCE6} $RPM_BUILD_ROOT%{progdir}/defaults/pref/kde.js
   310 install -m 644 %{SOURCE6} $RPM_BUILD_ROOT%{progdir}/defaults/pref/kde.js
       
   311 # make sure that instantApply is true by default
       
   312 # (TODO: mozilla-kde.patch needs to be improved to really not load kde.js in non-KDE envs)
       
   313 echo 'pref("browser.preferences.instantApply", true);' > $RPM_BUILD_ROOT%{progdir}/defaults/pref/firefox.js
   311 %endif
   314 %endif
   312 # install add-plugins.sh
   315 # install add-plugins.sh
   313 sed "s:%%PROGDIR:%{progdir}:g" \
   316 sed "s:%%PROGDIR:%{progdir}:g" \
   314   %{SOURCE13} > $RPM_BUILD_ROOT%{progdir}/add-plugins.sh
   317   %{SOURCE13} > $RPM_BUILD_ROOT%{progdir}/add-plugins.sh
   315 chmod 755 $RPM_BUILD_ROOT%{progdir}/add-plugins.sh
   318 chmod 755 $RPM_BUILD_ROOT%{progdir}/add-plugins.sh
   348 find $RPM_BUILD_ROOT%{progdir} \
   351 find $RPM_BUILD_ROOT%{progdir} \
   349      -name "*.js" -o \
   352      -name "*.js" -o \
   350      -name "*.jsm" -o \
   353      -name "*.jsm" -o \
   351      -name "*.rdf" -o \
   354      -name "*.rdf" -o \
   352      -name "*.properties" -o \
   355      -name "*.properties" -o \
   353      -name "*.dtd" | xargs chmod a-x
   356      -name "*.dtd" -o \
       
   357      -name "*.txt" -o \
       
   358      -name "*.xml" -o \
       
   359      -name "*.css" | xargs chmod a-x
   354 # overwrite the mozilla start-script and link it to /usr/bin
   360 # overwrite the mozilla start-script and link it to /usr/bin
   355 mkdir --parents $RPM_BUILD_ROOT/usr/bin
   361 mkdir --parents $RPM_BUILD_ROOT/usr/bin
   356 sed "s:%%PREFIX:%{_prefix}:g
   362 sed "s:%%PREFIX:%{_prefix}:g
   357 s:%%PROGDIR:%{progdir}:g
   363 s:%%PROGDIR:%{progdir}:g
   358 s:%%APPNAME:firefox:g
   364 s:%%APPNAME:firefox:g