xulrunner/xulrunner.spec
branchesr17
changeset 638 3a72bcb470fb
child 652 c3618c6a868d
equal deleted inserted replaced
632:b83636a26466 638:3a72bcb470fb
       
     1 #
       
     2 # spec file for package xulrunner
       
     3 #
       
     4 # Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
       
     5 #               2006-2013 Wolfgang Rosenauer
       
     6 #
       
     7 # All modifications and additions to the file contributed by third parties
       
     8 # remain the property of their copyright owners, unless otherwise agreed
       
     9 # upon. The license for this file, and modifications and additions to the
       
    10 # file, is the same license as for the pristine package itself (unless the
       
    11 # license for the pristine package is not an Open Source License, in which
       
    12 # case the license is the MIT License). An "Open Source License" is a
       
    13 # license that conforms to the Open Source Definition (Version 1.9)
       
    14 # published by the Open Source Initiative.
       
    15 
       
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
       
    17 #
       
    18 
       
    19 
       
    20 Name:           xulrunner
       
    21 BuildRequires:  Mesa-devel
       
    22 BuildRequires:  autoconf213
       
    23 BuildRequires:  dbus-1-glib-devel
       
    24 BuildRequires:  fdupes
       
    25 BuildRequires:  gcc-c++
       
    26 BuildRequires:  hunspell-devel
       
    27 BuildRequires:  libcurl-devel
       
    28 BuildRequires:  libgnomeui-devel
       
    29 BuildRequires:  libidl-devel
       
    30 BuildRequires:  libnotify-devel
       
    31 BuildRequires:  nss-shared-helper-devel
       
    32 BuildRequires:  pkg-config
       
    33 BuildRequires:  python
       
    34 BuildRequires:  startup-notification-devel
       
    35 BuildRequires:  unzip
       
    36 BuildRequires:  xorg-x11-libXt-devel
       
    37 BuildRequires:  yasm
       
    38 BuildRequires:  zip
       
    39 %if %suse_version > 1110
       
    40 BuildRequires:  libiw-devel
       
    41 BuildRequires:  libproxy-devel
       
    42 %else
       
    43 BuildRequires:  wireless-tools
       
    44 %endif
       
    45 BuildRequires:  mozilla-nspr-devel >= 4.9.5
       
    46 BuildRequires:  mozilla-nss-devel >= 3.14.3
       
    47 Version:        17.0.5
       
    48 Release:        0
       
    49 %define         releasedate 2013032900
       
    50 %define         version_internal 17.0.5
       
    51 %define         apiversion 17
       
    52 %define         uaweight 1700005
       
    53 Summary:        Mozilla Runtime Environment
       
    54 License:        MPL-2.0
       
    55 Group:          Productivity/Other
       
    56 Url:            http://www.mozilla.org/
       
    57 Provides:       gecko
       
    58 %ifarch %ix86
       
    59 Provides:       xulrunner-32bit = %{version}-%{release}
       
    60 %endif
       
    61 Source:         xulrunner-%{version}-source.tar.bz2
       
    62 Source1:        l10n-%{version}.tar.bz2
       
    63 Source2:        find-external-requires.sh
       
    64 Source3:        %{name}-rpmlintrc
       
    65 Source4:        xulrunner-openSUSE-prefs.js
       
    66 Source5:        add-plugins.sh.in
       
    67 Source6:        create-tar.sh
       
    68 Source7:        baselibs.conf
       
    69 Source8:        source-stamp.txt
       
    70 Source9:        compare-locales.tar.bz2
       
    71 Patch1:         toolkit-download-folder.patch
       
    72 Patch2:         mozilla-pkgconfig.patch
       
    73 Patch3:         mozilla-idldir.patch
       
    74 Patch4:         mozilla-nongnome-proxies.patch
       
    75 Patch5:         mozilla-prefer_plugin_pref.patch
       
    76 Patch6:         mozilla-language.patch
       
    77 Patch7:         mozilla-ntlm-full-path.patch
       
    78 Patch9:         mozilla-sle11.patch
       
    79 Patch14:        mozilla-ppc.patch
       
    80 # SLE11 patches
       
    81 Patch20:        mozilla-gcc43-enums.patch
       
    82 Patch21:        mozilla-gcc43-template_hacks.patch
       
    83 Patch22:        mozilla-gcc43-templates_instantiation.patch
       
    84 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
       
    85 Requires:       mozilla-js = %{version}
       
    86 Requires(post):  update-alternatives coreutils
       
    87 Requires(preun): update-alternatives coreutils
       
    88 ### build configuration ###
       
    89 %define has_system_nspr  1
       
    90 %define has_system_nss   1
       
    91 %define has_system_cairo 0
       
    92 %define localize 0
       
    93 %ifarch ppc ppc64 s390 s390x ia64 %arm
       
    94 %define crashreporter    0
       
    95 %else
       
    96 %define crashreporter    1
       
    97 %endif
       
    98 ### configuration end ###
       
    99 %define _use_internal_dependency_generator 0
       
   100 %define __find_requires sh %{SOURCE2}
       
   101 %global provfind sh -c "grep -Ev 'mozsqlite3|dbusservice|unixprint' | %__find_provides"
       
   102 %global __find_provides %provfind
       
   103 %if %has_system_nspr
       
   104 Requires:       mozilla-nspr >= %(rpm -q --queryformat '%{VERSION}' mozilla-nspr)
       
   105 %endif
       
   106 %if %has_system_nss
       
   107 Requires:       mozilla-nss >= %(rpm -q --queryformat '%{VERSION}' mozilla-nss)
       
   108 %endif
       
   109 
       
   110 %description
       
   111 XULRunner is a single installable package that can be used to bootstrap
       
   112 multiple XUL+XPCOM applications that are as rich as Firefox and
       
   113 Thunderbird.
       
   114 
       
   115 
       
   116 %package -n mozilla-js
       
   117 Summary:        Mozilla JS engine
       
   118 Group:          Productivity/Other
       
   119 
       
   120 %description -n mozilla-js
       
   121 JavaScript is the Netscape-developed object scripting language used in millions
       
   122 of web pages and server applications worldwide. Netscape's JavaScript is a
       
   123 superset of the ECMA-262 Edition 3 (ECMAScript) standard scripting language,
       
   124 with only mild differences from the published standard.
       
   125 
       
   126 
       
   127 %package devel
       
   128 Summary:        XULRunner/Gecko SDK
       
   129 Group:          Development/Libraries/Other
       
   130 %if %has_system_nspr
       
   131 Requires:       mozilla-nspr-devel >= %(rpm -q --queryformat '%{VERSION}' mozilla-nspr-devel)
       
   132 %endif
       
   133 %if %has_system_nss
       
   134 Requires:       mozilla-nss-devel >= %(rpm -q --queryformat '%{VERSION}' mozilla-nss-devel)
       
   135 %endif
       
   136 Requires:       %{name} = %{version}
       
   137 
       
   138 %description devel
       
   139 Software Development Kit to embed XUL or Gecko into other applications.
       
   140 
       
   141 %if %localize
       
   142 
       
   143 %package translations-common
       
   144 Summary:        Common translations for XULRunner
       
   145 Group:          System/Localization
       
   146 Requires:       %{name} = %{version}
       
   147 Provides:       locale(%{name}:ar;ca;cs;da;de;en_GB;es_AR;es_CL;es_ES;fi;fr;hu;it;ja;ko;nb_NO;nl;pl;pt_BR;pt_PT;ru;sv_SE;zh_CN;zh_TW)
       
   148 Obsoletes:      %{name}-translations < %{version}-%{release}
       
   149 
       
   150 %description translations-common
       
   151 XULRunner is a single installable package that can be used to bootstrap
       
   152 multiple XUL+XPCOM applications that are as rich as Firefox and
       
   153 Thunderbird.
       
   154 
       
   155 This package contains the most common languages but en-US which is
       
   156 delivered in the main package.
       
   157 
       
   158 
       
   159 %package translations-other
       
   160 Summary:        Extra translations for XULRunner
       
   161 Group:          System/Localization
       
   162 Requires:       %{name} = %{version}
       
   163 Provides:       locale(%{name}:ach;af;ak;as;ast;be;bg;bn_BD;bn_IN;br;bs;csb;cy;el;en_ZA;eo;es_MX;et;eu;fa;ff;fy_NL;ga_IE;gd;gl;gu_IN;he;hi_IN;hr;hy_AM;id;is;kk;km;kn;ku;lg;lij;lt;lv;mai;mk;ml;mr;nn_NO;nso;or;pa_IN;rm;ro;si;sk;sl;son;sq;sr;ta;ta_LK;te;th;tr;uk;vi;zu)
       
   164 Obsoletes:      %{name}-translations < %{version}-%{release}
       
   165 
       
   166 %description translations-other
       
   167 XULRunner is a single installable package that can be used to bootstrap
       
   168 multiple XUL+XPCOM applications that are as rich as Firefox and
       
   169 Thunderbird.
       
   170 
       
   171 This package contains rarely used languages.
       
   172 %endif
       
   173 
       
   174 %if %crashreporter
       
   175 
       
   176 %package buildsymbols
       
   177 Summary:        Breakpad buildsymbols for %{name}
       
   178 Group:          Development/Debug
       
   179 
       
   180 %description buildsymbols
       
   181 This subpackage contains the Breakpad created and compatible debugging
       
   182 symbols meant for upload to Mozilla's crash collector database.
       
   183 %endif
       
   184 
       
   185 %prep
       
   186 %setup -n mozilla -q -b 1 -b 9
       
   187 %patch1 -p1
       
   188 %patch2 -p1
       
   189 %patch3 -p1
       
   190 %patch4 -p1
       
   191 %patch5 -p1
       
   192 %patch6 -p1
       
   193 %patch7 -p1
       
   194 %if %suse_version < 1120
       
   195 %patch9 -p1
       
   196 %endif
       
   197 %patch14 -p1
       
   198 # SLE patches
       
   199 %if %suse_version <= 1110
       
   200 %patch20 -p1
       
   201 %patch21 -p1
       
   202 %patch22 -p1
       
   203 %endif
       
   204 
       
   205 %build
       
   206 # no need to add build time to binaries
       
   207 modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/%{name}.changes")"
       
   208 DATE="\"$(date -d "${modified}" "+%%b %%e %%Y")\""
       
   209 TIME="\"$(date -d "${modified}" "+%%R")\""
       
   210 find . -regex ".*\.c\|.*\.cpp\|.*\.h" -exec sed -i "s/__DATE__/${DATE}/g;s/__TIME__/${TIME}/g" {} +
       
   211 #
       
   212 MOZ_APP_DIR=%{_libdir}/xulrunner-%{version_internal}
       
   213 export MOZ_BUILD_DATE=%{releasedate}
       
   214 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
       
   215 %ifarch ppc64
       
   216 export CFLAGS="$CFLAGS -mminimal-toc"
       
   217 %endif
       
   218 export LDFLAGS=" -Wl,-rpath -Wl,${MOZ_APP_DIR}"
       
   219 %ifarch %arm
       
   220 # debug symbols require too much memory during build
       
   221 export CFLAGS="${CFLAGS/-g/}"
       
   222 LDFLAGS+="-Wl,--reduce-memory-overheads -Wl,--no-keep-memory"
       
   223 %endif
       
   224 export CXXFLAGS="$CFLAGS"
       
   225 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
       
   226 export MOZILLA_OFFICIAL=1
       
   227 export BUILD_OFFICIAL=1
       
   228 export MOZ_MILESTONE_RELEASE=1
       
   229 #
       
   230 cat << EOF > $MOZCONFIG
       
   231 mk_add_options MOZILLA_OFFICIAL=1
       
   232 mk_add_options BUILD_OFFICIAL=1
       
   233 mk_add_options MOZ_MILESTONE_RELEASE=1
       
   234 mk_add_options MOZ_MAKE_FLAGS=%{?jobs:-j%jobs}
       
   235 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../obj
       
   236 . \$topsrcdir/xulrunner/config/mozconfig
       
   237 ac_add_options --prefix=%{_prefix}
       
   238 ac_add_options --libdir=%{_libdir}
       
   239 ac_add_options --sysconfdir=%{_sysconfdir}
       
   240 ac_add_options --mandir=%{_mandir}
       
   241 ac_add_options --includedir=%{_includedir}
       
   242 ac_add_options --enable-optimize
       
   243 ac_add_options --enable-extensions=default
       
   244 #ac_add_options --with-system-jpeg # mozilla uses internal libjpeg-turbo now
       
   245 #ac_add_options --with-system-png  # no APNG support
       
   246 ac_add_options --with-system-zlib
       
   247 ac_add_options --with-l10n-base=$RPM_BUILD_DIR/l10n
       
   248 ac_add_options --disable-tests
       
   249 ac_add_options --disable-mochitest
       
   250 ac_add_options --disable-installer
       
   251 ac_add_options --disable-updater
       
   252 ac_add_options --disable-javaxpcom
       
   253 ac_add_options --enable-system-hunspell
       
   254 ac_add_options --enable-startup-notification
       
   255 ac_add_options --enable-shared-js
       
   256 ac_add_options --disable-webrtc   # does not build with system NSPR
       
   257 #ac_add_options --enable-debug
       
   258 EOF
       
   259 %if %suse_version > 1130
       
   260 cat << EOF >> $MOZCONFIG
       
   261 ac_add_options --disable-gnomevfs
       
   262 ac_add_options --enable-gio
       
   263 EOF
       
   264 %endif
       
   265 %if %has_system_nspr
       
   266 cat << EOF >> $MOZCONFIG
       
   267 ac_add_options --with-system-nspr
       
   268 EOF
       
   269 %endif
       
   270 %if %has_system_nss
       
   271 cat << EOF >> $MOZCONFIG
       
   272 ac_add_options --with-system-nss
       
   273 EOF
       
   274 %endif
       
   275 %if %has_system_cairo
       
   276 cat << EOF >> $MOZCONFIG
       
   277 ac_add_options --enable-system-cairo
       
   278 EOF
       
   279 %endif
       
   280 %if %suse_version > 1110
       
   281 cat << EOF >> $MOZCONFIG
       
   282 ac_add_options --enable-libproxy
       
   283 EOF
       
   284 %endif
       
   285 %if ! %crashreporter
       
   286 cat << EOF >> $MOZCONFIG
       
   287 ac_add_options --disable-crashreporter
       
   288 EOF
       
   289 %endif
       
   290 # S/390
       
   291 %ifarch s390 s390x
       
   292 cat << EOF >> $MOZCONFIG
       
   293 ac_add_options --disable-jemalloc
       
   294 EOF
       
   295 %endif
       
   296 # ARM
       
   297 %ifarch %arm
       
   298 cat << EOF >> $MOZCONFIG
       
   299 %ifarch armv7l armv7hl
       
   300 ac_add_options --with-arch=armv7-a
       
   301 ac_add_options --with-float-abi=hard
       
   302 ac_add_options --with-fpu=vfpv3-d16
       
   303 ac_add_options --with-thumb=yes
       
   304 ac_add_options --disable-debug
       
   305 %endif
       
   306 %ifarch armv5tel
       
   307 ac_add_options --with-arch=armv5te
       
   308 ac_add_options --with-float-abi=soft
       
   309 ac_add_options --with-thumb=no
       
   310 %endif
       
   311 EOF
       
   312 %endif
       
   313 make -f client.mk build
       
   314 
       
   315 %install
       
   316 cd ../obj
       
   317 # preferences (to package in omni.jar)
       
   318 cp %{SOURCE4} dist/bin/defaults/pref/all-openSUSE.js
       
   319 %makeinstall STRIP=/bin/true
       
   320 # xpt.py is not executable
       
   321 chmod a+x $RPM_BUILD_ROOT%{_libdir}/xulrunner-devel-%{version_internal}/sdk/bin/*.py
       
   322 # remove some executable permissions
       
   323 find $RPM_BUILD_ROOT%{_includedir}/xulrunner-%{version_internal} \
       
   324      -type f -perm -111 -exec chmod a-x {} \;
       
   325 find $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/ \
       
   326      -name "*.js" -o -name "*.xpm" -o -name "*.png" | xargs chmod a-x
       
   327 # remove mkdir.done files from installed base
       
   328 find $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal} -name ".mkdir.done" | xargs rm
       
   329 mkdir -p $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/extensions
       
   330 # fixing SDK dynamic libs (symlink instead of copy)
       
   331 rm $RPM_BUILD_ROOT%{_libdir}/xulrunner-devel-%{version_internal}/sdk/lib/*.so
       
   332 ln -sf ../../../xulrunner-%{version_internal}/libmozjs.so \
       
   333        $RPM_BUILD_ROOT%{_libdir}/xulrunner-devel-%{version_internal}/sdk/lib/
       
   334 ln -sf ../../../xulrunner-%{version_internal}/libxpcom.so \
       
   335        $RPM_BUILD_ROOT%{_libdir}/xulrunner-devel-%{version_internal}/sdk/lib/
       
   336 ln -sf ../../../xulrunner-%{version_internal}/libxul.so \
       
   337        $RPM_BUILD_ROOT%{_libdir}/xulrunner-devel-%{version_internal}/sdk/lib/
       
   338 # include basic buildenv for xulapps to use
       
   339 mkdir -p $RPM_BUILD_ROOT%{_datadir}/xulrunner-%{version_internal}
       
   340 pushd ..
       
   341 # this list has been compiled by trial and error for prism
       
   342 tar --exclude=*.cpp --exclude=*.mm \
       
   343    -cvjf $RPM_BUILD_ROOT%{_datadir}/xulrunner-%{version_internal}/mozilla-src.tar.bz2 \
       
   344     mozilla/configure.in mozilla/Makefile.in mozilla/client.py mozilla/allmakefiles.sh \
       
   345     mozilla/config mozilla/client.mk mozilla/aclocal.m4 mozilla/build mozilla/js/src/* \
       
   346     mozilla/testing mozilla/toolkit/mozapps/installer mozilla/probes mozilla/memory \
       
   347     mozilla/toolkit/xre mozilla/nsprpub/config mozilla/tools mozilla/xpcom/build
       
   348 popd
       
   349 # install add-plugins.sh
       
   350 sed "s:%%PROGDIR:%{_libdir}/xulrunner-%{version_internal}:g" \
       
   351   %{SOURCE5} > $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/add-plugins.sh
       
   352 chmod 755 $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/add-plugins.sh
       
   353 # ghosts
       
   354 touch $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/global.reginfo
       
   355 # install additional locales
       
   356 %if %localize
       
   357 rm -f %{_tmppath}/translations.*
       
   358 touch %{_tmppath}/translations.{common,other}
       
   359 for locale in $(awk '{ print $1; }' ../mozilla/browser/locales/shipped-locales); do
       
   360   case $locale in
       
   361    ja-JP-mac|en-US)
       
   362       ;;
       
   363    *)
       
   364       pushd $RPM_BUILD_DIR/compare-locales
       
   365       PYTHONPATH=lib \
       
   366         scripts/compare-locales -m ../l10n-merged/$locale \
       
   367 	../mozilla/toolkit/locales/l10n.ini ../l10n $locale
       
   368       popd
       
   369       LOCALE_MERGEDIR=$RPM_BUILD_DIR/l10n-merged/$locale \
       
   370       make -C toolkit/locales langpack-$locale
       
   371       cp dist/xpi-stage/locale-$locale \
       
   372          $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/extensions/langpack-$locale@firefox.mozilla.org
       
   373       # remove prefs and profile defaults from langpack
       
   374       rm -rf $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/extensions/langpack-$locale@firefox.mozilla.org/defaults
       
   375       # check against the fixed common list and sort into the right filelist
       
   376       _matched=0
       
   377       for _match in ar ca cs da de en-GB es-AR es-CL es-ES fi fr hu it ja ko nb-NO nl pl pt-BR pt-PT ru sv-SE zh-CN zh-TW; do
       
   378         [ "$_match" = "$locale" ] && _matched=1
       
   379       done
       
   380       [ $_matched -eq 1 ] && _l10ntarget=common || _l10ntarget=other
       
   381       echo %{_libdir}/xulrunner-%{version_internal}/extensions/langpack-$locale@firefox.mozilla.org \ \
       
   382          >> %{_tmppath}/translations.$_l10ntarget
       
   383   esac
       
   384 done
       
   385 %endif
       
   386 # API symlink
       
   387 ln -sf xulrunner-%{version_internal} $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{apiversion}
       
   388 # compat links
       
   389 %if 0%{?ga_version:1}
       
   390 touch $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{ga_version}
       
   391 %endif
       
   392 # excludes
       
   393 %if %suse_version < 1120
       
   394 rm -f $RPM_BUILD_ROOT%{_bindir}/xulrunner
       
   395 %endif
       
   396 rm -f $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/updater
       
   397 rm -f $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/update.locale
       
   398 rm -f $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/LICENSE
       
   399 rm -f $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/README.txt
       
   400 rm -f $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/dictionaries/en-US*
       
   401 rm -f $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/nspr-config
       
   402 rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/mozilla-plugin.pc
       
   403 # fdupes
       
   404 %fdupes $RPM_BUILD_ROOT%{_includedir}/xulrunner-%{version_internal}/
       
   405 %fdupes $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/
       
   406 # create breakpad debugsymbols
       
   407 %if %crashreporter
       
   408 SYMBOLS_NAME="xulrunner-%{version}-%{release}.%{_arch}-%{suse_version}-symbols"
       
   409 make buildsymbols \
       
   410   SYMBOL_INDEX_NAME="$SYMBOLS_NAME.txt" \
       
   411   SYMBOL_FULL_ARCHIVE_BASENAME="$SYMBOLS_NAME-full" \
       
   412   SYMBOL_ARCHIVE_BASENAME="$SYMBOLS_NAME"
       
   413 if [ -e dist/*symbols.zip ]; then
       
   414   mkdir -p $RPM_BUILD_ROOT%{_datadir}/mozilla/
       
   415   cp dist/*symbols.zip $RPM_BUILD_ROOT%{_datadir}/mozilla/
       
   416 fi
       
   417 %endif
       
   418 
       
   419 %clean
       
   420 rm -rf $RPM_BUILD_ROOT
       
   421 %if %localize
       
   422 rm -rf %{_tmppath}/translations.*
       
   423 %endif
       
   424 
       
   425 %post
       
   426 /usr/sbin/update-alternatives --install %{_bindir}/xulrunner \
       
   427   xulrunner %{_libdir}/xulrunner-%{apiversion}/xulrunner %{uaweight} || :
       
   428 %{_libdir}/xulrunner-%{apiversion}/add-plugins.sh > /dev/null 2>&1
       
   429 exit 0
       
   430 
       
   431 %posttrans
       
   432 # needed for updates which transition directory to symlink
       
   433 %if 0%{?ga_version:1}
       
   434 test -d %{_libdir}/xulrunner-%{ga_version} && rm -rf %{_libdir}/xulrunner-%{ga_version}
       
   435 ln -sf xulrunner-%{version_internal} %{_libdir}/xulrunner-%{ga_version}
       
   436 %endif
       
   437 [ -e %{_libdir}/xulrunner-%{version_internal}/add-plugins.sh ] && \
       
   438   %{_libdir}/xulrunner-%{version_internal}/add-plugins.sh > /dev/null 2>&1
       
   439 exit 0
       
   440 
       
   441 %preun
       
   442 if [ "$1" = "0" ]; then # deinstallation
       
   443   # that's not quite nice since old versions should be removed on update as well
       
   444   # but that's problematic for updates w/o raising the version number
       
   445   /usr/sbin/update-alternatives --remove xulrunner %{_libdir}/xulrunner-%{apiversion}/xulrunner
       
   446 fi
       
   447 rm -f %{_libdir}/xulrunner-%{version_internal}/dictionaries/*
       
   448 exit 0
       
   449 
       
   450 %triggerin -- myspell-dictionary
       
   451 %{_libdir}/xulrunner-%{version_internal}/add-plugins.sh > /dev/null 2>&1
       
   452 exit 0
       
   453 
       
   454 %triggerpostun -- myspell-dictionary
       
   455 %{_libdir}/xulrunner-%{version_internal}/add-plugins.sh > /dev/null 2>&1
       
   456 exit 0
       
   457 
       
   458 %files
       
   459 %defattr(-,root,root)
       
   460 %dir %{_libdir}/xulrunner-%{version_internal}/
       
   461 %dir %{_libdir}/xulrunner-%{version_internal}/chrome/
       
   462 %dir %{_libdir}/xulrunner-%{version_internal}/dictionaries/
       
   463 %dir %{_libdir}/xulrunner-%{version_internal}/extensions/
       
   464 %{_libdir}/xulrunner-%{version_internal}/chrome/icons/
       
   465 %{_libdir}/xulrunner-%{version_internal}/components/
       
   466 %{_libdir}/xulrunner-%{version_internal}/plugins/
       
   467 %{_libdir}/xulrunner-%{version_internal}/*.so
       
   468 %exclude %{_libdir}/xulrunner-%{version_internal}/libmozjs.so
       
   469 %{_libdir}/xulrunner-%{version_internal}/add-plugins.sh
       
   470 %{_libdir}/xulrunner-%{version_internal}/chrome.manifest
       
   471 %{_libdir}/xulrunner-%{version_internal}/dependentlibs.list
       
   472 %{_libdir}/xulrunner-%{version_internal}/mozilla-xremote-client
       
   473 %{_libdir}/xulrunner-%{version_internal}/plugin-container
       
   474 %{_libdir}/xulrunner-%{version_internal}/xulrunner
       
   475 %{_libdir}/xulrunner-%{version_internal}/xulrunner-stub
       
   476 %{_libdir}/xulrunner-%{version_internal}/platform.ini
       
   477 %{_libdir}/xulrunner-%{version_internal}/omni.ja
       
   478 %{_libdir}/xulrunner-%{version_internal}/README.xulrunner
       
   479 # crashreporter files
       
   480 %if %crashreporter
       
   481 %{_libdir}/xulrunner-%{version_internal}/crashreporter
       
   482 %{_libdir}/xulrunner-%{version_internal}/crashreporter.ini
       
   483 %{_libdir}/xulrunner-%{version_internal}/Throbber-small.gif
       
   484 %endif
       
   485 # ghosts
       
   486 %ghost %{_libdir}/xulrunner-%{version_internal}/global.reginfo
       
   487 %if %suse_version >= 1120
       
   488 %ghost %{_bindir}/xulrunner
       
   489 %endif
       
   490 # API symlink (already in mozilla-js)
       
   491 #%{_libdir}/xulrunner-%{apiversion}
       
   492 # compat symlinks
       
   493 %if 0%{?ga_version:1}
       
   494 %ghost %{_libdir}/xulrunner-%{ga_version}
       
   495 %endif
       
   496 
       
   497 %files -n mozilla-js
       
   498 %defattr(-,root,root)
       
   499 %dir %{_libdir}/xulrunner-%{version_internal}/
       
   500 %{_libdir}/xulrunner-%{apiversion}
       
   501 %{_libdir}/xulrunner-%{version_internal}/libmozjs.so
       
   502 
       
   503 %files devel
       
   504 %defattr(-,root,root)
       
   505 %{_libdir}/xulrunner-devel-%{version_internal}/
       
   506 # FIXME symlink dynamic libs below sdk/lib
       
   507 %attr(644,root,root) %{_libdir}/pkgconfig/*
       
   508 %{_includedir}/xulrunner-%{version_internal}/
       
   509 %{_datadir}/xulrunner-%{version_internal}/
       
   510 
       
   511 %if %localize
       
   512 
       
   513 %files translations-common -f %{_tmppath}/translations.common
       
   514 %defattr(-,root,root)
       
   515 %dir %{_libdir}/xulrunner-%{version_internal}/
       
   516 %dir %{_libdir}/xulrunner-%{version_internal}/chrome/
       
   517 
       
   518 %files translations-other -f %{_tmppath}/translations.other
       
   519 %defattr(-,root,root)
       
   520 %dir %{_libdir}/xulrunner-%{version_internal}/
       
   521 %dir %{_libdir}/xulrunner-%{version_internal}/chrome/
       
   522 %endif
       
   523 
       
   524 %if %crashreporter
       
   525 
       
   526 %files buildsymbols
       
   527 %defattr(-,root,root)
       
   528 %{_datadir}/mozilla/
       
   529 %endif
       
   530 
       
   531 %changelog