MozillaFirefox/MozillaFirefox.spec
branchfirefox78
changeset 1138 4ac678bd2a26
parent 1137 909f866430ee
child 1139 4fd43e0d4a8f
equal deleted inserted replaced
1137:909f866430ee 1138:4ac678bd2a26
    23 # orig_version would be the upstream tar ball
    23 # orig_version would be the upstream tar ball
    24 # orig_version 70.0
    24 # orig_version 70.0
    25 # orig_suffix b3
    25 # orig_suffix b3
    26 # major 69
    26 # major 69
    27 # mainver %major.99
    27 # mainver %major.99
    28 %define major          77
    28 %define major          78
    29 %define mainver        %major.99
    29 %define mainver        %major.0.2
    30 %define orig_version   78.0
    30 %define orig_version   78.0.2
    31 %define orig_suffix    b8
    31 %define orig_suffix    %{nil}
    32 %define update_channel beta
    32 %define update_channel release
    33 %define branding       1
    33 %define branding       1
    34 %define devpkg         1
    34 %define devpkg         1
    35 
    35 
    36 %if 0%{?suse_version} > 1500
       
    37 # PGO builds do not work in TW currently (bmo#1642410)
    36 # PGO builds do not work in TW currently (bmo#1642410)
    38 %define do_profiling   0
    37 %define do_profiling   0
    39 %endif
       
    40 
    38 
    41 # upstream default is clang (to use gcc for large parts set to 0)
    39 # upstream default is clang (to use gcc for large parts set to 0)
    42 %define clang_build 0
    40 %define clang_build 0
    43 
    41 
    44 # PIE, full relro
    42 # PIE, full relro
    68 %ifarch %ix86 x86_64
    66 %ifarch %ix86 x86_64
    69 %define crashreporter 1
    67 %define crashreporter 1
    70 %else
    68 %else
    71 %define crashreporter 0
    69 %define crashreporter 0
    72 %endif
    70 %endif
    73 %if 0%{?sle_version} > 150100
    71 %if 0%{?suse_version} < 1550 && 0%{?sle_version} <= 150100
    74 # pipewire is too old on Leap <15.1
    72 # pipewire is too old on Leap <15.1
       
    73 %define with_pipewire0_3 0
       
    74 %else
    75 %define with_pipewire0_3 1
    75 %define with_pipewire0_3 1
    76 %else
       
    77 %define with_pipewire0_3 0
       
    78 %endif
    76 %endif
    79 
    77 
    80 Name:           %{pkgname}
    78 Name:           %{pkgname}
    81 BuildRequires:  Mesa-devel
    79 BuildRequires:  Mesa-devel
    82 BuildRequires:  alsa-devel
    80 BuildRequires:  alsa-devel
   208 Patch23:        mozilla-pipewire-0-3.patch
   206 Patch23:        mozilla-pipewire-0-3.patch
   209 Patch24:        mozilla-bmo1602730.patch
   207 Patch24:        mozilla-bmo1602730.patch
   210 Patch25:        mozilla-bmo998749.patch
   208 Patch25:        mozilla-bmo998749.patch
   211 Patch26:        mozilla-bmo1626236.patch
   209 Patch26:        mozilla-bmo1626236.patch
   212 Patch27:        mozilla-s390x-skia-gradient.patch
   210 Patch27:        mozilla-s390x-skia-gradient.patch
       
   211 Patch28:        mozilla-libavcodec58_91.patch
   213 # Firefox/browser
   212 # Firefox/browser
   214 Patch101:       firefox-kde.patch
   213 Patch101:       firefox-kde.patch
   215 Patch102:       firefox-branded-icons.patch
   214 Patch102:       firefox-branded-icons.patch
   216 %endif # only_print_mozconfig
   215 %endif # only_print_mozconfig
   217 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   216 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   349 %endif
   348 %endif
   350 %patch24 -p1
   349 %patch24 -p1
   351 %patch25 -p1
   350 %patch25 -p1
   352 %patch26 -p1
   351 %patch26 -p1
   353 %patch27 -p1
   352 %patch27 -p1
       
   353 %patch28 -p1
   354 # Firefox
   354 # Firefox
   355 %patch101 -p1
   355 %patch101 -p1
   356 %patch102 -p1
   356 %patch102 -p1
   357 %endif # only_print_mozconfig
   357 %endif # only_print_mozconfig
   358 
   358 
   476 ac_add_options --enable-alsa
   476 ac_add_options --enable-alsa
   477 ac_add_options --disable-debug
   477 ac_add_options --disable-debug
   478 #ac_add_options --enable-chrome-format=jar
   478 #ac_add_options --enable-chrome-format=jar
   479 ac_add_options --enable-update-channel=%{update_channel}
   479 ac_add_options --enable-update-channel=%{update_channel}
   480 ac_add_options --with-mozilla-api-keyfile=%{SOURCE18}
   480 ac_add_options --with-mozilla-api-keyfile=%{SOURCE18}
   481 ac_add_options --with-google-location-service-api-keyfile=%{SOURCE19}
   481 #ac_add_options --with-google-location-service-api-keyfile=%{SOURCE19}
   482 ac_add_options --with-google-safebrowsing-api-keyfile=%{SOURCE19}
   482 ac_add_options --with-google-safebrowsing-api-keyfile=%{SOURCE19}
   483 ac_add_options --with-unsigned-addon-scopes=app
   483 ac_add_options --with-unsigned-addon-scopes=app
       
   484 ac_add_options --allow-addon-sideload
   484 %if %branding
   485 %if %branding
   485 ac_add_options --enable-official-branding
   486 ac_add_options --enable-official-branding
   486 %endif
   487 %endif
   487 ac_add_options --enable-libproxy
   488 ac_add_options --enable-libproxy
   488 %if ! %crashreporter
   489 %if ! %crashreporter
   533 truncate -s 0 %{_tmppath}/translations.{common,other}
   534 truncate -s 0 %{_tmppath}/translations.{common,other}
   534 sed -r '/^(ja-JP-mac|en-US|)$/d;s/ .*$//' $RPM_BUILD_DIR/%{srcname}-%{orig_version}/browser/locales/shipped-locales \
   535 sed -r '/^(ja-JP-mac|en-US|)$/d;s/ .*$//' $RPM_BUILD_DIR/%{srcname}-%{orig_version}/browser/locales/shipped-locales \
   535     | xargs -n 1 -I {} /bin/sh -c '
   536     | xargs -n 1 -I {} /bin/sh -c '
   536         locale=$1
   537         locale=$1
   537         ./mach build langpack-$locale
   538         ./mach build langpack-$locale
   538         cp -rL ../obj/dist/xpi-stage/locale-$locale \
   539         cp -L ../obj/dist/linux-*/xpi/firefox-%{orig_version}.$locale.langpack.xpi \
   539             %{buildroot}%{progdir}/browser/extensions/langpack-$locale@firefox.mozilla.org
   540             %{buildroot}%{progdir}/browser/extensions/langpack-$locale@firefox.mozilla.org.xpi
   540         # remove prefs, profile defaults, and hyphenation from langpack
   541         # remove prefs, profile defaults, and hyphenation from langpack
   541         rm -rf %{buildroot}%{progdir}/browser/extensions/langpack-$locale@firefox.mozilla.org/defaults
   542         #rm -rf %{buildroot}%{progdir}/browser/extensions/langpack-$locale@firefox.mozilla.org/defaults
   542         rm -rf %{buildroot}%{progdir}/browser/extensions/langpack-$locale@firefox.mozilla.org/hyphenation
   543         #rm -rf %{buildroot}%{progdir}/browser/extensions/langpack-$locale@firefox.mozilla.org/hyphenation
   543         # check against the fixed common list and sort into the right filelist
   544         # check against the fixed common list and sort into the right filelist
   544         _matched=0
   545         _matched=0
   545         for _match in ar ca cs da de el en-GB es-AR es-CL es-ES fi fr hu it ja ko nb-NO nl pl pt-BR pt-PT ru sv-SE zh-CN zh-TW; do
   546         for _match in ar ca cs da de el en-GB es-AR es-CL es-ES fi fr hu it ja ko nb-NO nl pl pt-BR pt-PT ru sv-SE zh-CN zh-TW; do
   546             [ "$_match" = "$locale" ] && _matched=1
   547             [ "$_match" = "$locale" ] && _matched=1
   547         done
   548         done
   548         [ $_matched -eq 1 ] && _l10ntarget=common || _l10ntarget=other
   549         [ $_matched -eq 1 ] && _l10ntarget=common || _l10ntarget=other
   549         echo %{progdir}/browser/extensions/langpack-$locale@firefox.mozilla.org \
   550         echo %{progdir}/browser/extensions/langpack-$locale@firefox.mozilla.org.xpi \
   550             >> %{_tmppath}/translations.$_l10ntarget
   551             >> %{_tmppath}/translations.$_l10ntarget
   551 ' -- {}
   552 ' -- {}
   552 %endif
   553 %endif
   553 
   554 
   554 %endif # only_print_mozconfig
   555 %endif # only_print_mozconfig
   759 
   760 
   760 %if %localize
   761 %if %localize
   761 %files translations-common -f %{_tmppath}/translations.common
   762 %files translations-common -f %{_tmppath}/translations.common
   762 %defattr(-,root,root)
   763 %defattr(-,root,root)
   763 %dir %{progdir}
   764 %dir %{progdir}
   764 %dir %{progdir}/browser/extensions/
   765 %dir %{progdir}/browser/extensions
   765 
   766 
   766 %files translations-other -f %{_tmppath}/translations.other
   767 %files translations-other -f %{_tmppath}/translations.other
   767 %defattr(-,root,root)
   768 %defattr(-,root,root)
   768 %dir %{progdir}
   769 %dir %{progdir}
   769 %dir %{progdir}/browser/extensions/
   770 %dir %{progdir}/browser/extensions
   770 %endif
   771 %endif
   771 
   772 
   772 # this package does not need to provide files but is needed to fulfill
   773 # this package does not need to provide files but is needed to fulfill
   773 # requirements if no other branding package is to be installed
   774 # requirements if no other branding package is to be installed
   774 %files branding-upstream
   775 %files branding-upstream