MozillaFirefox/MozillaFirefox.spec
changeset 1031 4b419fce88dc
parent 1030 cd02d400c081
child 1032 8220ea23b47d
equal deleted inserted replaced
1024:d14085eee2b2 1031:4b419fce88dc
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major 57
    21 %define major 58
    22 %define mainver %major.99
    22 %define mainver %major.99
    23 %define update_channel beta
    23 %define update_channel beta
    24 %define branding 1
    24 %define branding 1
    25 %define releasedate 20180108140638
    25 %define releasedate 20180208193705
    26 
    26 
    27 # PIE, full relro (x86_64 for now)
    27 # PIE, full relro (x86_64 for now)
    28 %define build_hardened 1
    28 %define build_hardened 1
    29 
    29 
    30 # Firefox only supports i686
    30 # Firefox only supports i686
    40 %define appname  Firefox
    40 %define appname  Firefox
    41 %define progdir %{_prefix}/%_lib/%{progname}
    41 %define progdir %{_prefix}/%_lib/%{progname}
    42 %define gnome_dir     %{_prefix}
    42 %define gnome_dir     %{_prefix}
    43 %define desktop_file_name %{progname}
    43 %define desktop_file_name %{progname}
    44 %define firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
    44 %define firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
    45 %define _use_internal_dependency_generator 0
    45 %define __provides_exclude ^lib.*\\.so.*$
    46 %define __find_requires sh %{SOURCE4}
    46 %define __requires_exclude ^(libmoz.*|liblgpllibs.*|libxul.*)$
    47 %global provfind sh -c "grep -v '.so' | %__find_provides"
       
    48 %global __find_provides %provfind
       
    49 %define localize 1
    47 %define localize 1
    50 %ifarch %ix86 x86_64
    48 %ifarch %ix86 x86_64
    51 %define crashreporter 1
    49 %define crashreporter 1
    52 %else
    50 %else
    53 %define crashreporter 0
    51 %define crashreporter 0
    70 BuildRequires:  libidl-devel
    68 BuildRequires:  libidl-devel
    71 BuildRequires:  libiw-devel
    69 BuildRequires:  libiw-devel
    72 BuildRequires:  libnotify-devel
    70 BuildRequires:  libnotify-devel
    73 BuildRequires:  libproxy-devel
    71 BuildRequires:  libproxy-devel
    74 BuildRequires:  makeinfo
    72 BuildRequires:  makeinfo
    75 BuildRequires:  mozilla-nspr-devel >= 4.17
    73 BuildRequires:  mozilla-nspr-devel >= 4.18
    76 BuildRequires:  mozilla-nss-devel >= 3.34.1
    74 BuildRequires:  mozilla-nss-devel >= 3.35
    77 BuildRequires:  python-devel
    75 BuildRequires:  python-devel
    78 BuildRequires:  python2-xml
    76 BuildRequires:  python2-xml
    79 BuildRequires:  rust >= 1.21
    77 BuildRequires:  rust >= 1.22.1
    80 BuildRequires:  rust-std
    78 BuildRequires:  rust-std
    81 BuildRequires:  startup-notification-devel
    79 BuildRequires:  startup-notification-devel
    82 BuildRequires:  unzip
    80 BuildRequires:  unzip
    83 BuildRequires:  update-desktop-files
    81 BuildRequires:  update-desktop-files
    84 BuildRequires:  xorg-x11-libXt-devel
    82 BuildRequires:  xorg-x11-libXt-devel
   124 Url:            http://www.mozilla.org/
   122 Url:            http://www.mozilla.org/
   125 Source:         firefox-%{version}-source.tar.xz
   123 Source:         firefox-%{version}-source.tar.xz
   126 Source1:        MozillaFirefox.desktop
   124 Source1:        MozillaFirefox.desktop
   127 Source2:        MozillaFirefox-rpmlintrc
   125 Source2:        MozillaFirefox-rpmlintrc
   128 Source3:        mozilla.sh.in
   126 Source3:        mozilla.sh.in
   129 Source4:        find-external-requires.sh
       
   130 Source5:        source-stamp.txt
   127 Source5:        source-stamp.txt
   131 Source6:        kde.js
   128 Source6:        kde.js
   132 Source7:        l10n-%{version}.tar.xz
   129 Source7:        l10n-%{version}.tar.xz
   133 Source8:        firefox-mimeinfo.xml
   130 Source8:        firefox-mimeinfo.xml
   134 Source9:        firefox.js
   131 Source9:        firefox.js
   151 Patch3:         mozilla-ntlm-full-path.patch
   148 Patch3:         mozilla-ntlm-full-path.patch
   152 Patch4:         mozilla-openaes-decl.patch
   149 Patch4:         mozilla-openaes-decl.patch
   153 Patch5:         mozilla-no-stdcxx-check.patch
   150 Patch5:         mozilla-no-stdcxx-check.patch
   154 Patch6:         mozilla-reduce-files-per-UnifiedBindings.patch
   151 Patch6:         mozilla-reduce-files-per-UnifiedBindings.patch
   155 Patch7:         mozilla-aarch64-startup-crash.patch
   152 Patch7:         mozilla-aarch64-startup-crash.patch
       
   153 Patch8:         mozilla-enable-csd.patch
       
   154 Patch9:         mozilla-bmo256180.patch
       
   155 Patch10:        mozilla-alsa-sandbox.patch
   156 # Firefox/browser
   156 # Firefox/browser
   157 Patch101:       firefox-kde.patch
   157 Patch101:       firefox-kde.patch
   158 Patch102:       firefox-no-default-ualocale.patch
   158 Patch102:       firefox-no-default-ualocale.patch
   159 Patch103:       firefox-branded-icons.patch
   159 Patch103:       firefox-branded-icons.patch
   160 
   160 
   261 %patch5 -p1
   261 %patch5 -p1
   262 %ifarch %ix86
   262 %ifarch %ix86
   263 %patch6 -p1
   263 %patch6 -p1
   264 %endif
   264 %endif
   265 %patch7 -p1
   265 %patch7 -p1
       
   266 %patch8 -p1
       
   267 %patch9 -p1
       
   268 %patch10 -p1
   266 # Firefox
   269 # Firefox
   267 %patch101 -p1
   270 %patch101 -p1
   268 %patch102 -p1
   271 %patch102 -p1
   269 %patch103 -p1
   272 %patch103 -p1
   270 
   273