MozillaFirefox/MozillaFirefox.spec
branchfirefox103
changeset 1177 4bb6d80fcc64
parent 1175 4c6576f9cf04
child 1178 e27c6e9c5c63
equal deleted inserted replaced
1176:f871aac89885 1177:4bb6d80fcc64
    26 # orig_version would be the upstream tar ball
    26 # orig_version would be the upstream tar ball
    27 # orig_version 70.0
    27 # orig_version 70.0
    28 # orig_suffix b3
    28 # orig_suffix b3
    29 # major 69
    29 # major 69
    30 # mainver %major.99
    30 # mainver %major.99
    31 %define major          102
    31 %define major          103
    32 %define mainver        %major.0.1
    32 %define mainver        %major.0.2
    33 %define orig_version   102.0.1
    33 %define orig_version   103.0.2
    34 %define orig_suffix    %{nil}
    34 %define orig_suffix    %{nil}
    35 %define update_channel release
    35 %define update_channel release
    36 %define branding       1
    36 %define branding       1
    37 %define devpkg         1
    37 %define devpkg         1
    38 
    38 
   104 # a different method for provides that we can use to request a
   104 # a different method for provides that we can use to request a
   105 # specific version
   105 # specific version
   106 # minimal requirement:
   106 # minimal requirement:
   107 BuildRequires:  rust+cargo >= 1.59
   107 BuildRequires:  rust+cargo >= 1.59
   108 # actually used upstream:
   108 # actually used upstream:
   109 BuildRequires:  cargo1.60
   109 BuildRequires:  cargo1.61
   110 BuildRequires:  rust1.60
   110 BuildRequires:  rust1.61
   111 %endif
   111 %endif
   112 %if 0%{useccache} != 0
   112 %if 0%{useccache} != 0
   113 BuildRequires:  ccache
   113 BuildRequires:  ccache
   114 %endif
   114 %endif
   115 BuildRequires:  libXcomposite-devel
   115 BuildRequires:  libXcomposite-devel
   116 BuildRequires:  libcurl-devel
   116 BuildRequires:  libcurl-devel
   117 BuildRequires:  libiw-devel
   117 BuildRequires:  libiw-devel
   118 BuildRequires:  libproxy-devel
   118 BuildRequires:  libproxy-devel
   119 BuildRequires:  makeinfo
   119 BuildRequires:  makeinfo
   120 BuildRequires:  mozilla-nspr-devel >= 4.34
   120 BuildRequires:  mozilla-nspr-devel >= 4.34
   121 BuildRequires:  mozilla-nss-devel >= 3.79
   121 BuildRequires:  mozilla-nss-devel >= 3.80
   122 BuildRequires:  nasm >= 2.14
   122 BuildRequires:  nasm >= 2.14
   123 BuildRequires:  nodejs >= 10.22.1
   123 BuildRequires:  nodejs >= 10.22.1
   124 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   124 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   125 BuildRequires:  python-libxml2
   125 BuildRequires:  python-libxml2
   126 BuildRequires:  python36
   126 BuildRequires:  python36
   127 %else
   127 %else
   128 BuildRequires:  python3 >= 3.5
   128 BuildRequires:  python3 >= 3.5
   129 BuildRequires:  python3-devel
   129 BuildRequires:  python3-devel
   130 %endif
   130 %endif
   131 BuildRequires:  rust-cbindgen >= 0.23.0
   131 BuildRequires:  rust-cbindgen >= 0.24.3
   132 BuildRequires:  unzip
   132 BuildRequires:  unzip
   133 BuildRequires:  update-desktop-files
   133 BuildRequires:  update-desktop-files
   134 BuildRequires:  xorg-x11-libXt-devel
   134 BuildRequires:  xorg-x11-libXt-devel
   135 %if 0%{?do_profiling}
   135 %if 0%{?do_profiling}
   136 BuildRequires:  xvfb-run
   136 BuildRequires:  xvfb-run
   222 Patch21:        mozilla-libavcodec58_91.patch
   222 Patch21:        mozilla-libavcodec58_91.patch
   223 Patch22:        mozilla-silence-no-return-type.patch
   223 Patch22:        mozilla-silence-no-return-type.patch
   224 Patch23:        mozilla-bmo531915.patch
   224 Patch23:        mozilla-bmo531915.patch
   225 Patch25:        one_swizzle_to_rule_them_all.patch
   225 Patch25:        one_swizzle_to_rule_them_all.patch
   226 Patch26:        svg-rendering.patch
   226 Patch26:        svg-rendering.patch
       
   227 Patch27:        mozilla-glibc236.patch
   227 # Firefox/browser
   228 # Firefox/browser
   228 Patch101:       firefox-kde.patch
   229 Patch101:       firefox-kde.patch
   229 Patch102:       firefox-branded-icons.patch
   230 Patch102:       firefox-branded-icons.patch
   230 %endif
   231 %endif
   231 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   232 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   397 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   398 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   398 EOF
   399 EOF
   399 # Done with env-variables.
   400 # Done with env-variables.
   400 source ./.obsenv.sh
   401 source ./.obsenv.sh
   401 
   402 
       
   403 %ifarch aarch64 %arm ppc64 ppc64le
       
   404 %limit_build -m 2000
       
   405 %endif
       
   406 
   402 # Generating mozconfig
   407 # Generating mozconfig
   403 cat << EOF > $MOZCONFIG
   408 cat << EOF > $MOZCONFIG
   404 mk_add_options MOZILLA_OFFICIAL=1
   409 mk_add_options MOZILLA_OFFICIAL=1
   405 mk_add_options BUILD_OFFICIAL=1
   410 mk_add_options BUILD_OFFICIAL=1
   406 mk_add_options MOZ_MAKE_FLAGS=%{?jobs:-j%jobs}
   411 mk_add_options MOZ_MAKE_FLAGS=%{?jobs:-j%jobs}
   423 ac_add_options --enable-debug-symbols=-g1
   428 ac_add_options --enable-debug-symbols=-g1
   424 %endif
   429 %endif
   425 ac_add_options --disable-install-strip
   430 ac_add_options --disable-install-strip
   426 # building with elf-hack started to fail everywhere with FF73
   431 # building with elf-hack started to fail everywhere with FF73
   427 #%if 0%{?suse_version} > 1549
   432 #%if 0%{?suse_version} > 1549
   428 %ifnarch aarch64 ppc64 ppc64le s390x
   433 %ifarch %arm %ix86 x86_64
   429 ac_add_options --disable-elf-hack
   434 ac_add_options --disable-elf-hack
   430 %endif
   435 %endif
   431 #%endif
   436 #%endif
   432 ac_add_options --with-system-nspr
   437 ac_add_options --with-system-nspr
   433 ac_add_options --with-system-nss
   438 ac_add_options --with-system-nss
   489 
   494 
   490 %if %{with only_print_mozconfig}
   495 %if %{with only_print_mozconfig}
   491 cat ./.obsenv.sh
   496 cat ./.obsenv.sh
   492 cat $MOZCONFIG
   497 cat $MOZCONFIG
   493 %else
   498 %else
   494 %ifarch aarch64 %arm ppc64 ppc64le
       
   495 %limit_build -m 2000
       
   496 %endif
       
   497 
   499 
   498 %if 0%{useccache} != 0
   500 %if 0%{useccache} != 0
   499 ccache -s
   501 ccache -s
   500 %endif
   502 %endif
   501 %if 0%{?do_profiling}
   503 %if 0%{?do_profiling}