MozillaFirefox/MozillaFirefox.spec
branchfirefox47
changeset 921 4f801233e935
parent 920 4e5807284ef0
child 923 3cc9f17ca9bb
equal deleted inserted replaced
920:4e5807284ef0 921:4f801233e935
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major 47
    21 %define major 47
    22 %define mainver %major.0
    22 %define mainver %major.0.1
    23 %define update_channel release
    23 %define update_channel release
    24 %define releasedate 20160606000000
    24 %define releasedate 20160628000000
    25 
    25 
    26 # PIE, full relro (x86_64 for now)
    26 # PIE, full relro (x86_64 for now)
    27 %define build_hardened 1
    27 %define build_hardened 1
    28 
    28 
    29 # general build definitions
    29 # general build definitions
   292 export MOZILLA_OFFICIAL=1
   292 export MOZILLA_OFFICIAL=1
   293 export BUILD_OFFICIAL=1
   293 export BUILD_OFFICIAL=1
   294 export MOZ_TELEMETRY_REPORTING=1
   294 export MOZ_TELEMETRY_REPORTING=1
   295 export MOZ_GOOGLE_API_KEY=%{_google_api_key}
   295 export MOZ_GOOGLE_API_KEY=%{_google_api_key}
   296 export CFLAGS="%{optflags} -fno-strict-aliasing"
   296 export CFLAGS="%{optflags} -fno-strict-aliasing"
       
   297 # boo#986541: add -fno-delete-null-pointer-checks and -fno-inline-small-functions for gcc6
       
   298 %if 0%{?suse_version} > 1320
       
   299 export CFLAGS="$CFLAGS -fno-delete-null-pointer-checks -fno-inline-small-functions"
       
   300 %endif
   297 %ifarch %arm
   301 %ifarch %arm
   298 export CFLAGS="${CFLAGS/-g / }"
   302 export CFLAGS="${CFLAGS/-g / }"
   299 %endif
   303 %endif
   300 %ifarch %arm %ix86
   304 %ifarch %arm %ix86
   301 # Limit RAM usage during link
   305 # Limit RAM usage during link