MozillaFirefox/MozillaFirefox.spec
changeset 1114 572ec48f3fe8
parent 1113 8e9195853a32
child 1115 ed3548a16248
equal deleted inserted replaced
1113:8e9195853a32 1114:572ec48f3fe8
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major          70
    21 %define major          70
    22 %define mainver        %major.0
    22 %define mainver        %major.99
    23 %define orig_version   70.0
    23 %define orig_version   71.0
    24 %define orig_suffix    %{nil}
    24 %define orig_suffix    b11
    25 %define update_channel beta
    25 %define update_channel beta
    26 %define branding       1
    26 %define branding       1
    27 %define devpkg         1
    27 %define devpkg         1
    28 %define releasedate    20191016161957
       
    29 
    28 
    30 # always build with GCC as SUSE Security Team requires that
    29 # always build with GCC as SUSE Security Team requires that
    31 %define clang_build 0
    30 %define clang_build 0
    32 
    31 
    33 # PIE, full relro
    32 # PIE, full relro
    71 %if 0%{?suse_version} <= 1320
    70 %if 0%{?suse_version} <= 1320
    72 BuildRequires:  gcc7-c++
    71 BuildRequires:  gcc7-c++
    73 %else
    72 %else
    74 BuildRequires:  gcc-c++
    73 BuildRequires:  gcc-c++
    75 %endif
    74 %endif
    76 BuildRequires:  cargo >= 1.36
    75 BuildRequires:  cargo >= 1.37
    77 BuildRequires:  libXcomposite-devel
    76 BuildRequires:  libXcomposite-devel
    78 BuildRequires:  libcurl-devel
    77 BuildRequires:  libcurl-devel
    79 BuildRequires:  libidl-devel
    78 BuildRequires:  libidl-devel
    80 BuildRequires:  libiw-devel
    79 BuildRequires:  libiw-devel
    81 BuildRequires:  libnotify-devel
    80 BuildRequires:  libnotify-devel
    82 BuildRequires:  libproxy-devel
    81 BuildRequires:  libproxy-devel
    83 BuildRequires:  makeinfo
    82 BuildRequires:  makeinfo
    84 BuildRequires:  mozilla-nspr-devel >= 4.22
    83 BuildRequires:  mozilla-nspr-devel >= 4.23
    85 BuildRequires:  mozilla-nss-devel >= 3.46.1
    84 BuildRequires:  mozilla-nss-devel >= 3.47.1
    86 BuildRequires:  nasm >= 2.13
    85 BuildRequires:  nasm >= 2.13
    87 BuildRequires:  nodejs8 >= 8.11
    86 BuildRequires:  nodejs8 >= 8.11
    88 BuildRequires:  python-devel
    87 BuildRequires:  python-devel
    89 BuildRequires:  python2-xml
    88 BuildRequires:  python2-xml
    90 BuildRequires:  python3 >= 3.5
    89 BuildRequires:  python3 >= 3.5
    91 BuildRequires:  rust >= 1.36
    90 BuildRequires:  rust >= 1.37
    92 BuildRequires:  rust-cbindgen >= 0.9.1
    91 BuildRequires:  rust-cbindgen >= 0.9.1
    93 BuildRequires:  startup-notification-devel
    92 BuildRequires:  startup-notification-devel
    94 BuildRequires:  unzip
    93 BuildRequires:  unzip
    95 BuildRequires:  update-desktop-files
    94 BuildRequires:  update-desktop-files
    96 BuildRequires:  xorg-x11-libXt-devel
    95 BuildRequires:  xorg-x11-libXt-devel
   143 Source:         http://ftp.mozilla.org/pub/%{srcname}/releases/%{version}%{orig_suffix}/source/%{srcname}-%{orig_version}%{orig_suffix}.source.tar.xz
   142 Source:         http://ftp.mozilla.org/pub/%{srcname}/releases/%{version}%{orig_suffix}/source/%{srcname}-%{orig_version}%{orig_suffix}.source.tar.xz
   144 Source1:        MozillaFirefox.desktop
   143 Source1:        MozillaFirefox.desktop
   145 Source2:        MozillaFirefox-rpmlintrc
   144 Source2:        MozillaFirefox-rpmlintrc
   146 Source3:        mozilla.sh.in
   145 Source3:        mozilla.sh.in
   147 Source4:        tar_stamps
   146 Source4:        tar_stamps
   148 Source5:        source-stamp.txt
       
   149 Source7:        l10n-%{orig_version}%{orig_suffix}.tar.xz
   147 Source7:        l10n-%{orig_version}%{orig_suffix}.tar.xz
   150 Source8:        firefox-mimeinfo.xml
   148 Source8:        firefox-mimeinfo.xml
   151 Source9:        firefox.js
   149 Source9:        firefox.js
   152 Source10:       compare-locales.tar.xz
   150 Source10:       compare-locales.tar.xz
   153 Source11:       firefox.1
   151 Source11:       firefox.1
   154 Source12:       mozilla-get-app-id
   152 Source12:       mozilla-get-app-id
   155 Source13:       spellcheck.js
   153 Source13:       spellcheck.js
   156 Source14:       https://github.com/openSUSE/firefox-scripts/raw/master/create-tar.sh
   154 Source14:       https://github.com/openSUSE/firefox-scripts/raw/04d38e104a6ecdea33442755282688e8090ffa66/create-tar.sh
   157 Source15:       firefox-appdata.xml
   155 Source15:       firefox-appdata.xml
   158 Source16:       %{name}.changes
   156 Source16:       %{name}.changes
   159 # Set up API keys, see http://www.chromium.org/developers/how-tos/api-keys
   157 # Set up API keys, see http://www.chromium.org/developers/how-tos/api-keys
   160 # Note: these are for the openSUSE Firefox builds ONLY. For your own distribution,
   158 # Note: these are for the openSUSE Firefox builds ONLY. For your own distribution,
   161 # please get your own set of keys.
   159 # please get your own set of keys.
   165 Source21:       https://ftp.mozilla.org/pub/%{srcname}/releases/%{version}%{orig_suffix}/KEY#/mozilla.keyring
   163 Source21:       https://ftp.mozilla.org/pub/%{srcname}/releases/%{version}%{orig_suffix}/KEY#/mozilla.keyring
   166 # Gecko/Toolkit
   164 # Gecko/Toolkit
   167 Patch1:         mozilla-nongnome-proxies.patch
   165 Patch1:         mozilla-nongnome-proxies.patch
   168 Patch2:         mozilla-kde.patch
   166 Patch2:         mozilla-kde.patch
   169 Patch3:         mozilla-ntlm-full-path.patch
   167 Patch3:         mozilla-ntlm-full-path.patch
   170 Patch4:         mozilla-openaes-decl.patch
   168 Patch4:         mozilla-aarch64-startup-crash.patch
   171 Patch5:         mozilla-aarch64-startup-crash.patch
   169 Patch5:         mozilla-bmo1463035.patch
   172 Patch6:         mozilla-bmo1463035.patch
   170 Patch6:         mozilla-cubeb-noreturn.patch
   173 Patch7:         mozilla-cubeb-noreturn.patch
   171 Patch7:         mozilla-fix-aarch64-libopus.patch
   174 Patch8:         mozilla-fix-aarch64-libopus.patch
   172 Patch8:         mozilla-disable-wasm-emulate-arm-unaligned-fp-access.patch
   175 Patch9:         mozilla-disable-wasm-emulate-arm-unaligned-fp-access.patch
   173 Patch9:         mozilla-s390-context.patch
   176 Patch10:        mozilla-s390-context.patch
   174 Patch10:        mozilla-s390-bigendian.patch
   177 Patch11:        mozilla-s390-bigendian.patch
   175 Patch11:        mozilla-reduce-rust-debuginfo.patch
   178 Patch12:        mozilla-reduce-rust-debuginfo.patch
   176 Patch12:        mozilla-ppc-altivec_static_inline.patch
   179 Patch13:        mozilla-ppc-altivec_static_inline.patch
   177 Patch13:        mozilla-bmo1005535.patch
   180 Patch14:        mozilla-bmo1005535.patch
   178 Patch14:        mozilla-bmo1568145.patch
   181 Patch15:        mozilla-bmo1568145.patch
   179 Patch15:        mozilla-bmo1504834-part1.patch
   182 Patch16:        mozilla-bmo1504834-part1.patch
   180 Patch16:        mozilla-bmo1504834-part2.patch
   183 Patch17:        mozilla-bmo1504834-part2.patch
   181 Patch17:        mozilla-bmo1504834-part3.patch
   184 Patch18:        mozilla-bmo1504834-part3.patch
   182 Patch18:        mozilla-bmo1554971.patch
   185 Patch19:        mozilla-bmo1511604.patch
   183 Patch19:        mozilla-bmo1512162.patch
   186 Patch20:        mozilla-bmo1554971.patch
   184 Patch20:        mozilla-fix-top-level-asm.patch
   187 Patch21:        mozilla-bmo1512162.patch
   185 Patch21:        mozilla-bmo1504834-part4.patch
   188 Patch22:        mozilla-fix-top-level-asm.patch
   186 Patch22:        mozilla-bmo849632.patch
   189 # Firefox/browser
   187 # Firefox/browser
   190 Patch101:       firefox-kde.patch
   188 Patch101:       firefox-kde.patch
   191 Patch102:       firefox-branded-icons.patch
   189 Patch102:       firefox-branded-icons.patch
   192 %endif # only_print_mozconfig
   190 %endif # only_print_mozconfig
   193 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   191 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   304 %patch5 -p1
   302 %patch5 -p1
   305 %patch6 -p1
   303 %patch6 -p1
   306 %patch7 -p1
   304 %patch7 -p1
   307 %patch8 -p1
   305 %patch8 -p1
   308 %patch9 -p1
   306 %patch9 -p1
       
   307 %ifarch s390x ppc64
   309 %patch10 -p1
   308 %patch10 -p1
   310 %ifarch s390x ppc64
   309 %endif
   311 %patch11 -p1
   310 %patch11 -p1
   312 %endif
       
   313 %patch12 -p1
   311 %patch12 -p1
   314 %patch13 -p1
   312 %patch13 -p1
   315 %patch14 -p1
   313 %patch14 -p1
   316 %patch15 -p1
   314 %patch15 -p1
   317 %patch16 -p1
   315 %patch16 -p1
   337 kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)
   335 kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)
   338 if test "$kdehelperversion" != %{kde_helper_version}; then
   336 if test "$kdehelperversion" != %{kde_helper_version}; then
   339   echo fix kde helper version in the .spec file
   337   echo fix kde helper version in the .spec file
   340   exit 1
   338   exit 1
   341 fi
   339 fi
   342 source %{SOURCE5}
   340 source %{SOURCE4}
   343 %endif # only_print_mozconfig
   341 %endif # only_print_mozconfig
   344 
   342 
   345 export CARGO_HOME=${RPM_BUILD_DIR}/%{srcname}-%{orig_version}/.cargo
   343 export CARGO_HOME=${RPM_BUILD_DIR}/%{srcname}-%{orig_version}/.cargo
   346 export MOZ_SOURCE_CHANGESET=$REV
   344 export MOZ_SOURCE_CHANGESET=$RELEASE_TAG
   347 export SOURCE_REPO=$REPO
   345 export SOURCE_REPO=$RELEASE_REPO
   348 export source_repo=$REPO
   346 export source_repo=$RELEASE_REPO
   349 export MOZ_SOURCE_REPO=$REPO
   347 export MOZ_SOURCE_REPO=$RELEASE_REPO
   350 export MOZ_BUILD_DATE=%{releasedate}
   348 export MOZ_BUILD_DATE=$RELEASE_TIMESTAMP
   351 export MOZILLA_OFFICIAL=1
   349 export MOZILLA_OFFICIAL=1
   352 export BUILD_OFFICIAL=1
   350 export BUILD_OFFICIAL=1
   353 export MOZ_TELEMETRY_REPORTING=1
   351 export MOZ_TELEMETRY_REPORTING=1
   354 %if 0%{?suse_version} <= 1320
   352 %if 0%{?suse_version} <= 1320
   355 export CC=gcc-7
   353 export CC=gcc-7
   441 %ifarch armv6l armv6hl
   439 %ifarch armv6l armv6hl
   442 ac_add_options --with-arch=armv6
   440 ac_add_options --with-arch=armv6
   443 %else
   441 %else
   444 ac_add_options --with-arch=armv7-a
   442 ac_add_options --with-arch=armv7-a
   445 %endif
   443 %endif
   446 %endif
       
   447 %ifarch aarch64 %arm s390x
       
   448 ac_add_options --disable-webrtc
       
   449 %endif
   444 %endif
   450 # mitigation/workaround for bmo#1512162
   445 # mitigation/workaround for bmo#1512162
   451 %ifarch s390x
   446 %ifarch s390x
   452 ac_add_options --enable-optimize="-O1"
   447 ac_add_options --enable-optimize="-O1"
   453 %endif
   448 %endif