MozillaFirefox/MozillaFirefox.spec
branchfirefox85
changeset 1154 71a92b4d0527
parent 1153 fdd746757dda
child 1155 b8c834aafde2
equal deleted inserted replaced
1153:fdd746757dda 1154:71a92b4d0527
     1 #
     1 #
     2 # spec file for package MozillaFirefox
     2 # spec file for package MozillaFirefox
     3 #
     3 #
     4 # Copyright (c) 2021 SUSE LLC
     4 # Copyright (c) 2021 SUSE LLC
     5 #               2006-2020 Wolfgang Rosenauer <wr@rosenauer.org>
     5 #               2006-2021 Wolfgang Rosenauer <wr@rosenauer.org>
     6 #
     6 #
     7 # All modifications and additions to the file contributed by third parties
     7 # All modifications and additions to the file contributed by third parties
     8 # remain the property of their copyright owners, unless otherwise agreed
     8 # remain the property of their copyright owners, unless otherwise agreed
     9 # upon. The license for this file, and modifications and additions to the
     9 # upon. The license for this file, and modifications and additions to the
    10 # file, is the same license as for the pristine package itself (unless the
    10 # file, is the same license as for the pristine package itself (unless the
    27 # orig_version would be the upstream tar ball
    27 # orig_version would be the upstream tar ball
    28 # orig_version 70.0
    28 # orig_version 70.0
    29 # orig_suffix b3
    29 # orig_suffix b3
    30 # major 69
    30 # major 69
    31 # mainver %major.99
    31 # mainver %major.99
    32 %define major          84
    32 %define major          85
    33 %define mainver        %major.0.2
    33 %define mainver        %major.0
    34 %define orig_version   84.0.2
    34 %define orig_version   85.0
    35 %define orig_suffix    %{nil}
    35 %define orig_suffix    %{nil}
    36 %define update_channel release
    36 %define update_channel release
    37 %define branding       1
    37 %define branding       1
    38 %define devpkg         1
    38 %define devpkg         1
    39 
    39 
    90 %if 0%{?suse_version} <= 1320
    90 %if 0%{?suse_version} <= 1320
    91 BuildRequires:  gcc9-c++
    91 BuildRequires:  gcc9-c++
    92 %else
    92 %else
    93 BuildRequires:  gcc-c++
    93 BuildRequires:  gcc-c++
    94 %endif
    94 %endif
    95 BuildRequires:  cargo >= 1.44
    95 BuildRequires:  cargo >= 1.47
    96 BuildRequires:  ccache
    96 BuildRequires:  ccache
    97 BuildRequires:  libXcomposite-devel
    97 BuildRequires:  libXcomposite-devel
    98 BuildRequires:  libcurl-devel
    98 BuildRequires:  libcurl-devel
    99 BuildRequires:  libidl-devel
    99 BuildRequires:  libidl-devel
   100 BuildRequires:  libiw-devel
   100 BuildRequires:  libiw-devel
   101 BuildRequires:  libproxy-devel
   101 BuildRequires:  libproxy-devel
   102 BuildRequires:  makeinfo
   102 BuildRequires:  makeinfo
   103 BuildRequires:  mozilla-nspr-devel >= 4.29
   103 BuildRequires:  mozilla-nspr-devel >= 4.29
   104 BuildRequires:  mozilla-nss-devel >= 3.59.1
   104 BuildRequires:  mozilla-nss-devel >= 3.60.1
   105 BuildRequires:  nasm >= 2.14
   105 BuildRequires:  nasm >= 2.14
   106 BuildRequires:  nodejs10 >= 10.22.1
   106 BuildRequires:  nodejs10 >= 10.22.1
   107 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   107 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   108 BuildRequires:  python-libxml2
   108 BuildRequires:  python-libxml2
   109 BuildRequires:  python36
   109 BuildRequires:  python36
   110 %else
   110 %else
   111 BuildRequires:  python3 >= 3.5
   111 BuildRequires:  python3 >= 3.5
   112 BuildRequires:  python3-devel
   112 BuildRequires:  python3-devel
   113 %endif
   113 %endif
   114 BuildRequires:  rust >= 1.44
   114 BuildRequires:  rust >= 1.47
   115 BuildRequires:  rust-cbindgen >= 0.15.0
   115 BuildRequires:  rust-cbindgen >= 0.15.0
   116 BuildRequires:  unzip
   116 BuildRequires:  unzip
   117 BuildRequires:  update-desktop-files
   117 BuildRequires:  update-desktop-files
   118 BuildRequires:  xorg-x11-libXt-devel
   118 BuildRequires:  xorg-x11-libXt-devel
   119 %if 0%{?do_profiling}
   119 %if 0%{?do_profiling}
   205 Patch18:        mozilla-bmo1554971.patch
   205 Patch18:        mozilla-bmo1554971.patch
   206 Patch19:        mozilla-bmo1512162.patch
   206 Patch19:        mozilla-bmo1512162.patch
   207 Patch20:        mozilla-fix-top-level-asm.patch
   207 Patch20:        mozilla-fix-top-level-asm.patch
   208 Patch21:        mozilla-bmo1504834-part4.patch
   208 Patch21:        mozilla-bmo1504834-part4.patch
   209 Patch22:        mozilla-bmo849632.patch
   209 Patch22:        mozilla-bmo849632.patch
   210 Patch23:        mozilla-pipewire-0-3.patch
       
   211 Patch24:        mozilla-bmo1602730.patch
   210 Patch24:        mozilla-bmo1602730.patch
   212 Patch25:        mozilla-bmo998749.patch
   211 Patch25:        mozilla-bmo998749.patch
   213 Patch26:        mozilla-bmo1626236.patch
   212 Patch26:        mozilla-bmo1626236.patch
   214 Patch27:        mozilla-s390x-skia-gradient.patch
   213 Patch27:        mozilla-s390x-skia-gradient.patch
   215 Patch28:        mozilla-libavcodec58_91.patch
   214 Patch28:        mozilla-libavcodec58_91.patch
   345 %patch18 -p1
   344 %patch18 -p1
   346 %patch19 -p1
   345 %patch19 -p1
   347 %patch20 -p1
   346 %patch20 -p1
   348 %patch21 -p1
   347 %patch21 -p1
   349 %patch22 -p1
   348 %patch22 -p1
   350 %if %{with_pipewire0_3}
       
   351 %patch23 -p1
       
   352 %endif
       
   353 %patch24 -p1
   349 %patch24 -p1
   354 %patch25 -p1
   350 %patch25 -p1
   355 %patch26 -p1
   351 %patch26 -p1
   356 %patch27 -p1
   352 %patch27 -p1
   357 %patch28 -p1
   353 %patch28 -p1