MozillaFirefox/MozillaFirefox.spec
changeset 270 785d28fc6d4d
parent 269 9ec311cdd7c8
child 271 0cb54f456d88
equal deleted inserted replaced
269:9ec311cdd7c8 270:785d28fc6d4d
    33 BuildRequires:  mozilla-nss-devel >= 3.12.8
    33 BuildRequires:  mozilla-nss-devel >= 3.12.8
    34 BuildRequires:  nss-shared-helper-devel
    34 BuildRequires:  nss-shared-helper-devel
    35 License:        MPLv1.1 or GPLv2+ or LGPLv2+
    35 License:        MPLv1.1 or GPLv2+ or LGPLv2+
    36 Version:        %{mainver}
    36 Version:        %{mainver}
    37 Release:        1
    37 Release:        1
    38 %define         releasedate 2011041800
    38 %define         releasedate 2011042700
    39 Provides:       web_browser
    39 Provides:       web_browser
    40 Provides:       firefox = %{version}-%{release}
    40 Provides:       firefox = %{version}-%{release}
    41 Provides:       firefox = %{mainver}
    41 Provides:       firefox = %{mainver}
    42 # this is needed to match this package with the kde4 helper package without the main package
    42 # this is needed to match this package with the kde4 helper package without the main package
    43 # having a hard requirement on the kde4 package
    43 # having a hard requirement on the kde4 package
    68 Patch6:         mozilla-cairo-lcd.patch
    68 Patch6:         mozilla-cairo-lcd.patch
    69 Patch7:         mozilla-language.patch
    69 Patch7:         mozilla-language.patch
    70 Patch8:         mozilla-gio.patch
    70 Patch8:         mozilla-gio.patch
    71 Patch9:         mozilla-cairo-return.patch
    71 Patch9:         mozilla-cairo-return.patch
    72 Patch10:        mozilla-ntlm-full-path.patch
    72 Patch10:        mozilla-ntlm-full-path.patch
       
    73 Patch11:        mozilla-ppc-ipc.patch
    73 # Firefox/browser
    74 # Firefox/browser
    74 Patch30:        firefox-linkorder.patch
    75 Patch30:        firefox-linkorder.patch
    75 Patch31:        firefox-browser-css.patch
    76 Patch31:        firefox-browser-css.patch
    76 Patch32:        firefox-cross-desktop.patch
    77 Patch32:        firefox-cross-desktop.patch
    77 Patch33:        firefox-kde.patch
    78 Patch33:        firefox-kde.patch
   103 ### build options
   104 ### build options
   104 %define branding 0
   105 %define branding 0
   105 %define localize 1
   106 %define localize 1
   106 %ifarch ppc ppc64 s390 s390x ia64
   107 %ifarch ppc ppc64 s390 s390x ia64
   107 %define crashreporter    0
   108 %define crashreporter    0
   108 %define plugincontainer  0
       
   109 %else
   109 %else
   110 %define crashreporter    1
   110 %define crashreporter    1
   111 %define plugincontainer  1
       
   112 %endif
   111 %endif
   113 ### build options end
   112 ### build options end
   114 
   113 
   115 %description
   114 %description
   116 Mozilla Firefox is a standalone web browser, designed for standards
   115 Mozilla Firefox is a standalone web browser, designed for standards
   199 %patch6 -p1
   198 %patch6 -p1
   200 %patch7 -p1
   199 %patch7 -p1
   201 %patch8 -p1
   200 %patch8 -p1
   202 %patch9 -p1
   201 %patch9 -p1
   203 %patch10 -p1
   202 %patch10 -p1
       
   203 %patch11 -p1
   204 #
   204 #
   205 %patch30 -p1
   205 %patch30 -p1
   206 %patch31 -p1
   206 %patch31 -p1
   207 %patch32 -p1
   207 %patch32 -p1
   208 %if %suse_version >= 1110
   208 %if %suse_version >= 1110
   275 EOF
   275 EOF
   276 %endif
   276 %endif
   277 %if ! %crashreporter
   277 %if ! %crashreporter
   278 cat << EOF >> $MOZCONFIG
   278 cat << EOF >> $MOZCONFIG
   279 ac_add_options --disable-crashreporter
   279 ac_add_options --disable-crashreporter
   280 EOF
       
   281 %endif
       
   282 %if ! %plugincontainer
       
   283 cat << EOF >> $MOZCONFIG
       
   284 ac_add_options --disable-ipc
       
   285 EOF
   280 EOF
   286 %endif
   281 %endif
   287 make -f client.mk build
   282 make -f client.mk build
   288 
   283 
   289 %install
   284 %install
   484 %{progdir}/distribution/extensions/
   479 %{progdir}/distribution/extensions/
   485 %{progdir}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
   480 %{progdir}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
   486 %{progdir}/icons/
   481 %{progdir}/icons/
   487 %{progdir}/searchplugins/
   482 %{progdir}/searchplugins/
   488 %attr(755,root,root) %{progdir}/%{progname}.sh
   483 %attr(755,root,root) %{progdir}/%{progname}.sh
   489 %{progdir}/Throbber-small.gif
       
   490 %{progdir}/firefox-bin
   484 %{progdir}/firefox-bin
   491 %{progdir}/add-plugins.sh
   485 %{progdir}/add-plugins.sh
   492 %{progdir}/application.ini
   486 %{progdir}/application.ini
   493 %{progdir}/blocklist.xml
   487 %{progdir}/blocklist.xml
   494 %{progdir}/dependentlibs.list
   488 %{progdir}/dependentlibs.list
   500 %{progdir}/plugin-container
   494 %{progdir}/plugin-container
   501 %if %crashreporter
   495 %if %crashreporter
   502 %{progdir}/crashreporter-override.ini
   496 %{progdir}/crashreporter-override.ini
   503 %{progdir}/crashreporter
   497 %{progdir}/crashreporter
   504 %{progdir}/crashreporter.ini
   498 %{progdir}/crashreporter.ini
       
   499 %{progdir}/Throbber-small.gif
   505 %endif
   500 %endif
   506 %{progdir}/chrome.manifest
   501 %{progdir}/chrome.manifest
   507 %{_datadir}/applications/%{desktop_file_name}.desktop
   502 %{_datadir}/applications/%{desktop_file_name}.desktop
   508 %{_datadir}/mime/packages/%{progname}.xml
   503 %{_datadir}/mime/packages/%{progname}.xml
   509 %{_datadir}/pixmaps/firefox*
   504 %{_datadir}/pixmaps/firefox*