MozillaFirefox/MozillaFirefox.spec
branchmozilla-1.9.2
changeset 64 7bb1edb78dd5
parent 63 9213a0672227
child 65 6a711ebb385d
equal deleted inserted replaced
63:9213a0672227 64:7bb1edb78dd5
     1 #
     1 #
     2 # spec file for package MozillaFirefox (Version 3.6.3)
     2 # spec file for package MozillaFirefox (Version 3.6.4)
     3 #
     3 #
     4 # Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
     4 # Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
     5 #               2006-2010 Wolfgang Rosenauer
     5 #               2006-2010 Wolfgang Rosenauer
     6 #
     6 #
     7 # All modifications and additions to the file contributed by third parties
     7 # All modifications and additions to the file contributed by third parties
    20 
    20 
    21 
    21 
    22 Name:           MozillaFirefox
    22 Name:           MozillaFirefox
    23 %define xulrunner mozilla-xulrunner192
    23 %define xulrunner mozilla-xulrunner192
    24 BuildRequires:  autoconf213 gcc-c++ libcurl-devel libgnomeui-devel libidl-devel libnotify-devel python unzip update-desktop-files zip
    24 BuildRequires:  autoconf213 gcc-c++ libcurl-devel libgnomeui-devel libidl-devel libnotify-devel python unzip update-desktop-files zip
    25 BuildRequires:  %{xulrunner}-devel = 1.9.2.3
    25 BuildRequires:  %{xulrunner}-devel = 1.9.2.4
    26 %if %suse_version > 1020
    26 %if %suse_version > 1020
    27 BuildRequires:  fdupes
    27 BuildRequires:  fdupes
    28 %endif
    28 %endif
    29 %if %suse_version > 1110
    29 %if %suse_version > 1110
    30 BuildRequires:  libiw-devel
    30 BuildRequires:  libiw-devel
    32 BuildRequires:  wireless-tools
    32 BuildRequires:  wireless-tools
    33 %endif
    33 %endif
    34 License:        GPLv2+ ; LGPLv2.1+ ; MPLv1.1+
    34 License:        GPLv2+ ; LGPLv2.1+ ; MPLv1.1+
    35 Provides:       web_browser
    35 Provides:       web_browser
    36 Provides:       firefox
    36 Provides:       firefox
    37 Version:        3.6.3
    37 Version:        3.6.4
    38 Release:        1
    38 Release:        1
    39 %define         releasedate 2010040100
    39 %define         releasedate 2010040900
    40 Summary:        Mozilla Firefox Web Browser
    40 Summary:        Mozilla Firefox Web Browser
    41 Url:            http://www.mozilla.org/
    41 Url:            http://www.mozilla.org/
    42 Group:          Productivity/Networking/Web/Browsers
    42 Group:          Productivity/Networking/Web/Browsers
    43 Source:         firefox-%{version}-source.tar.bz2
    43 Source:         firefox-%{version}-source.tar.bz2
    44 Source1:        MozillaFirefox.desktop
    44 Source1:        MozillaFirefox.desktop
    61 Patch7:         firefox-no-gnomevfs.patch
    61 Patch7:         firefox-no-gnomevfs.patch
    62 Patch8:         firefox-appname.patch
    62 Patch8:         firefox-appname.patch
    63 Patch9:         firefox-kde.patch
    63 Patch9:         firefox-kde.patch
    64 Patch10:        firefox-ui-lockdown.patch
    64 Patch10:        firefox-ui-lockdown.patch
    65 Patch11:        firefox-crashreporter.patch
    65 Patch11:        firefox-crashreporter.patch
       
    66 Patch12:        mozilla-crashreporter-x86_64.patch
    66 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
    67 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
    67 Requires(post):   coreutils shared-mime-info desktop-file-utils
    68 Requires(post):   coreutils shared-mime-info desktop-file-utils
    68 Requires(postun): shared-mime-info desktop-file-utils
    69 Requires(postun): shared-mime-info desktop-file-utils
    69 Requires:       %{xulrunner} >= %(rpm -q --queryformat '%{VERSION}-%{RELEASE}' %{xulrunner})
    70 Requires:       %{xulrunner} >= %(rpm -q --queryformat '%{VERSION}-%{RELEASE}' %{xulrunner})
    70 %requires_eq    %{xulrunner}
    71 %requires_eq    %{xulrunner}
   164 # install kde.js
   165 # install kde.js
   165 install -m 644 %{SOURCE6} browser/app/profile/kde.js
   166 install -m 644 %{SOURCE6} browser/app/profile/kde.js
   166 %endif
   167 %endif
   167 %patch10 -p1
   168 %patch10 -p1
   168 %patch11 -p1
   169 %patch11 -p1
       
   170 %patch12 -p1
   169 
   171 
   170 %build
   172 %build
   171 export MOZ_BUILD_DATE=%{releasedate}
   173 export MOZ_BUILD_DATE=%{releasedate}
   172 export MOZILLA_OFFICIAL=1
   174 export MOZILLA_OFFICIAL=1
   173 export BUILD_OFFICIAL=1
   175 export BUILD_OFFICIAL=1
   357 %{progdir}/modules/
   359 %{progdir}/modules/
   358 %attr(755,root,root) %{progdir}/%{progname}.sh
   360 %attr(755,root,root) %{progdir}/%{progname}.sh
   359 %{progdir}/%{progname}
   361 %{progdir}/%{progname}
   360 %{progdir}/application.ini
   362 %{progdir}/application.ini
   361 %{progdir}/blocklist.xml
   363 %{progdir}/blocklist.xml
   362 %ifarch %ix86
       
   363 %{progdir}/crashreporter-override.ini
   364 %{progdir}/crashreporter-override.ini
   364 %endif
       
   365 %{_datadir}/applications/%{name}.desktop
   365 %{_datadir}/applications/%{name}.desktop
   366 %{_datadir}/mime/packages/%{progname}.xml
   366 %{_datadir}/mime/packages/%{progname}.xml
   367 %{_datadir}/pixmaps/firefox*
   367 %{_datadir}/pixmaps/firefox*
   368 %if %branding
   368 %if %branding
   369 %{gnome_dir}/share/icons/hicolor/
   369 %{gnome_dir}/share/icons/hicolor/