MozillaFirefox/MozillaFirefox.spec
branchfirefox26
changeset 695 81c8f51dbf67
parent 694 89d4b9910eb7
equal deleted inserted replaced
694:89d4b9910eb7 695:81c8f51dbf67
     1 #
     1 #
     2 # spec file for package MozillaFirefox
     2 # spec file for package MozillaFirefox
     3 #
     3 #
     4 # Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
     4 # Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
     5 #               2006-2013 Wolfgang Rosenauer
     5 #               2006-2013 Wolfgang Rosenauer
     6 #
     6 #
     7 # All modifications and additions to the file contributed by third parties
     7 # All modifications and additions to the file contributed by third parties
     8 # remain the property of their copyright owners, unless otherwise agreed
     8 # remain the property of their copyright owners, unless otherwise agreed
     9 # upon. The license for this file, and modifications and additions to the
     9 # upon. The license for this file, and modifications and additions to the
   141 %define desktop_file_name %{name}
   141 %define desktop_file_name %{name}
   142 %endif
   142 %endif
   143 ### build options
   143 ### build options
   144 %define branding 1
   144 %define branding 1
   145 %define localize 1
   145 %define localize 1
   146 %ifarch ppc ppc64 s390 s390x ia64 %arm
   146 %ifarch ppc ppc64 ppc64le s390 s390x ia64 %arm
   147 %define crashreporter 0
   147 %define crashreporter 0
   148 %else
   148 %else
   149 %define crashreporter 1
   149 %define crashreporter 1
   150 %endif
   150 %endif
   151 ### build options end
   151 ### build options end
   279 export MOZ_TELEMETRY_REPORTING=1
   279 export MOZ_TELEMETRY_REPORTING=1
   280 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
   280 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
   281 %ifarch %arm
   281 %ifarch %arm
   282 export CFLAGS="${CFLAGS/-g / }"
   282 export CFLAGS="${CFLAGS/-g / }"
   283 %endif
   283 %endif
   284 %ifarch ppc64
   284 %ifarch ppc64 ppc64le
   285 export CFLAGS="$CFLAGS -mminimal-toc"
   285 export CFLAGS="$CFLAGS -mminimal-toc"
   286 %endif
   286 %endif
   287 export CXXFLAGS="$CFLAGS"
   287 export CXXFLAGS="$CFLAGS"
   288 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   288 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   289 cat << EOF > $MOZCONFIG
   289 cat << EOF > $MOZCONFIG