MozillaFirefox/MozillaFirefox.spec
changeset 541 830e50bbfc79
parent 540 55fe9dc16b1f
child 543 24c3eafd49a1
equal deleted inserted replaced
540:55fe9dc16b1f 541:830e50bbfc79
   273 ac_add_options --prefix=%{_prefix}
   273 ac_add_options --prefix=%{_prefix}
   274 ac_add_options --libdir=%{_libdir}
   274 ac_add_options --libdir=%{_libdir}
   275 ac_add_options --sysconfdir=%{_sysconfdir}
   275 ac_add_options --sysconfdir=%{_sysconfdir}
   276 ac_add_options --mandir=%{_mandir}
   276 ac_add_options --mandir=%{_mandir}
   277 ac_add_options --includedir=%{_includedir}
   277 ac_add_options --includedir=%{_includedir}
   278 ac_add_options --with-system-nspr
   278 #ac_add_options --with-system-nspr
   279 ac_add_options --with-system-nss
   279 ac_add_options --with-system-nss
   280 ac_add_options --with-l10n-base=$RPM_BUILD_DIR/l10n
   280 ac_add_options --with-l10n-base=$RPM_BUILD_DIR/l10n
   281 #ac_add_options --with-system-jpeg    # libjpeg-turbo is used internally
   281 #ac_add_options --with-system-jpeg    # libjpeg-turbo is used internally
   282 #ac_add_options --with-system-png     # doesn't work because of missing APNG support
   282 #ac_add_options --with-system-png     # doesn't work because of missing APNG support
   283 ac_add_options --with-system-zlib
   283 ac_add_options --with-system-zlib
   361 	popd
   361 	popd
   362 	LOCALE_MERGEDIR=$RPM_BUILD_DIR/l10n-merged/$locale \
   362 	LOCALE_MERGEDIR=$RPM_BUILD_DIR/l10n-merged/$locale \
   363   	make -C browser/locales langpack-$locale
   363   	make -C browser/locales langpack-$locale
   364 	cp -rL dist/xpi-stage/locale-$locale \
   364 	cp -rL dist/xpi-stage/locale-$locale \
   365 	       $RPM_BUILD_ROOT%{progdir}/extensions/langpack-$locale@firefox.mozilla.org
   365 	       $RPM_BUILD_ROOT%{progdir}/extensions/langpack-$locale@firefox.mozilla.org
   366 	rm $RPM_BUILD_ROOT%{progdir}/extensions/langpack-$locale@firefox.mozilla.org/chrome/.mkdir.done
       
   367 	# remove prefs, profile defaults, and hyphenation from langpack
   366 	# remove prefs, profile defaults, and hyphenation from langpack
   368 	rm -rf $RPM_BUILD_ROOT%{progdir}/extensions/langpack-$locale@firefox.mozilla.org/defaults
   367 	rm -rf $RPM_BUILD_ROOT%{progdir}/extensions/langpack-$locale@firefox.mozilla.org/defaults
   369 	rm -rf $RPM_BUILD_ROOT%{progdir}/extensions/langpack-$locale@firefox.mozilla.org/hyphenation
   368 	rm -rf $RPM_BUILD_ROOT%{progdir}/extensions/langpack-$locale@firefox.mozilla.org/hyphenation
   370 	# check against the fixed common list and sort into the right filelist
   369 	# check against the fixed common list and sort into the right filelist
   371 	_matched=0
   370 	_matched=0
   386      -name "*.properties" -o \
   385      -name "*.properties" -o \
   387      -name "*.dtd" -o \
   386      -name "*.dtd" -o \
   388      -name "*.txt" -o \
   387      -name "*.txt" -o \
   389      -name "*.xml" -o \
   388      -name "*.xml" -o \
   390      -name "*.css" | xargs chmod a-x
   389      -name "*.css" | xargs chmod a-x
       
   390 # remove mkdir.done files from installed base
       
   391 find $RPM_BUILD_ROOT%{progdir} -name ".mkdir.done" | xargs rm
   391 # overwrite the mozilla start-script and link it to /usr/bin
   392 # overwrite the mozilla start-script and link it to /usr/bin
   392 mkdir --parents $RPM_BUILD_ROOT/usr/bin
   393 mkdir --parents $RPM_BUILD_ROOT/usr/bin
   393 sed "s:%%PREFIX:%{_prefix}:g
   394 sed "s:%%PREFIX:%{_prefix}:g
   394 s:%%PROGDIR:%{progdir}:g
   395 s:%%PROGDIR:%{progdir}:g
   395 s:%%APPNAME:firefox:g
   396 s:%%APPNAME:firefox:g