MozillaFirefox/MozillaFirefox.spec
changeset 673 89ef5ce746c2
parent 671 f5edfe756055
parent 672 2268d308dc15
child 675 3b47e7008410
equal deleted inserted replaced
671:f5edfe756055 673:89ef5ce746c2
    55 BuildRequires:  nss-shared-helper-devel
    55 BuildRequires:  nss-shared-helper-devel
    56 %if %suse_version > 1210
    56 %if %suse_version > 1210
    57 BuildRequires:  pkgconfig(gstreamer-%gstreamer_ver)
    57 BuildRequires:  pkgconfig(gstreamer-%gstreamer_ver)
    58 BuildRequires:  pkgconfig(gstreamer-app-%gstreamer_ver)
    58 BuildRequires:  pkgconfig(gstreamer-app-%gstreamer_ver)
    59 BuildRequires:  pkgconfig(gstreamer-plugins-base-%gstreamer_ver)
    59 BuildRequires:  pkgconfig(gstreamer-plugins-base-%gstreamer_ver)
       
    60 Requires:       libgstreamer-0_10-0
       
    61 Recommends:     gstreamer-0_10-fluendo-mp3
       
    62 Recommends:     gstreamer-0_10-plugins-ffmpeg
    60 %endif
    63 %endif
    61 Version:        %{mainver}
    64 Version:        %{mainver}
    62 Release:        0
    65 Release:        0
    63 %define         releasedate 2013091200
    66 %define         releasedate 2013091200
    64 Provides:       firefox = %{mainver}
    67 Provides:       firefox = %{mainver}
   163 %if %localize
   166 %if %localize
   164 
   167 
   165 %package translations-common
   168 %package translations-common
   166 Summary:        Common translations for Firefox
   169 Summary:        Common translations for Firefox
   167 Group:          System/Localization
   170 Group:          System/Localization
   168 Provides:       locale(%{name}:ar;ca;cs;da;de;el;en_GB;es_AR;es_CL;es_ES;fi;fr;hu;it;ja;ko;nb_NO;nl;pl;pt_BR;pt_PT;ru;sv_SE;zh_CN;zh_TW)
   171 Provides:       locale(%{name}:ar;ca;cs;da;de;en_GB;el;es_AR;es_CL;es_ES;fi;fr;hu;it;ja;ko;nb_NO;nl;pl;pt_BR;pt_PT;ru;sv_SE;zh_CN;zh_TW)
   169 Requires:       %{name} = %{version}
   172 Requires:       %{name} = %{version}
   170 Obsoletes:      %{name}-translations < %{version}-%{release}
   173 Obsoletes:      %{name}-translations < %{version}-%{release}
   171 
   174 
   172 %description translations-common
   175 %description translations-common
   173 This package contains several common languages for the user interface
   176 This package contains several common languages for the user interface
   298 ac_add_options --disable-tests
   301 ac_add_options --disable-tests
   299 ac_add_options --disable-debug
   302 ac_add_options --disable-debug
   300 ac_add_options --enable-startup-notification
   303 ac_add_options --enable-startup-notification
   301 #ac_add_options --enable-chrome-format=jar
   304 #ac_add_options --enable-chrome-format=jar
   302 ac_add_options --enable-update-channel=%{update_channel}
   305 ac_add_options --enable-update-channel=%{update_channel}
       
   306 EOF
   303 %if %suse_version > 1130
   307 %if %suse_version > 1130
       
   308 cat << EOF >> $MOZCONFIG
   304 ac_add_options --disable-gnomevfs
   309 ac_add_options --disable-gnomevfs
   305 ac_add_options --enable-gio
   310 ac_add_options --enable-gio
       
   311 EOF
   306 %endif
   312 %endif
   307 %if %suse_version < 1220
   313 %if %suse_version < 1220
       
   314 cat << EOF >> $MOZCONFIG
   308 ac_add_options --disable-gstreamer
   315 ac_add_options --disable-gstreamer
       
   316 EOF
   309 %endif
   317 %endif
   310 %if %branding
   318 %if %branding
       
   319 cat << EOF >> $MOZCONFIG
   311 ac_add_options --enable-official-branding
   320 ac_add_options --enable-official-branding
       
   321 EOF
   312 %endif
   322 %endif
   313 %if %suse_version > 1110
   323 %if %suse_version > 1110
       
   324 cat << EOF >> $MOZCONFIG
   314 ac_add_options --enable-libproxy
   325 ac_add_options --enable-libproxy
       
   326 EOF
   315 %endif
   327 %endif
   316 %if ! %crashreporter
   328 %if ! %crashreporter
       
   329 cat << EOF >> $MOZCONFIG
   317 ac_add_options --disable-crashreporter
   330 ac_add_options --disable-crashreporter
       
   331 EOF
   318 %endif
   332 %endif
   319 # Disable neon for arm as it does not build correctly
   333 # Disable neon for arm as it does not build correctly
   320 %ifarch %arm
   334 %ifarch %arm
       
   335 cat << EOF >> $MOZCONFIG
   321 ac_add_options --disable-neon
   336 ac_add_options --disable-neon
       
   337 EOF
   322 %endif
   338 %endif
   323 %ifnarch %ix86 x86_64
   339 %ifnarch %ix86 x86_64
       
   340 cat << EOF >> $MOZCONFIG
   324 ac_add_options --disable-webrtc
   341 ac_add_options --disable-webrtc
   325 %endif
   342 EOF
   326 EOF
   343 %endif
   327 make -f client.mk build
   344 make -f client.mk build
   328 
   345 
   329 %install
   346 %install
   330 cd $RPM_BUILD_DIR/obj
   347 cd $RPM_BUILD_DIR/obj
   331 source %{SOURCE5}
   348 source %{SOURCE5}
   373 	# remove prefs, profile defaults, and hyphenation from langpack
   390 	# remove prefs, profile defaults, and hyphenation from langpack
   374 	rm -rf $RPM_BUILD_ROOT%{progdir}/browser/extensions/langpack-$locale@firefox.mozilla.org/defaults
   391 	rm -rf $RPM_BUILD_ROOT%{progdir}/browser/extensions/langpack-$locale@firefox.mozilla.org/defaults
   375 	rm -rf $RPM_BUILD_ROOT%{progdir}/browser/extensions/langpack-$locale@firefox.mozilla.org/hyphenation
   392 	rm -rf $RPM_BUILD_ROOT%{progdir}/browser/extensions/langpack-$locale@firefox.mozilla.org/hyphenation
   376 	# check against the fixed common list and sort into the right filelist
   393 	# check against the fixed common list and sort into the right filelist
   377 	_matched=0
   394 	_matched=0
   378 	for _match in ar ca cs da de el en-GB es-AR es-CL es-ES fi fr hu it ja ko nb-NO nl pl pt-BR pt-PT ru sv-SE zh-CN zh-TW; do
   395 	for _match in ar ca cs da de en-GB el es-AR es-CL es-ES fi fr hu it ja ko nb-NO nl pl pt-BR pt-PT ru sv-SE zh-CN zh-TW; do
   379 	  [ "$_match" = "$locale" ] && _matched=1
   396 	  [ "$_match" = "$locale" ] && _matched=1
   380 	done
   397 	done
   381 	[ $_matched -eq 1 ] && _l10ntarget=common || _l10ntarget=other
   398 	[ $_matched -eq 1 ] && _l10ntarget=common || _l10ntarget=other
   382   	echo %{progdir}/browser/extensions/langpack-$locale@firefox.mozilla.org \
   399   	echo %{progdir}/browser/extensions/langpack-$locale@firefox.mozilla.org \
   383 	  >> %{_tmppath}/translations.$_l10ntarget
   400 	  >> %{_tmppath}/translations.$_l10ntarget