MozillaFirefox/MozillaFirefox.spec
changeset 984 98c4a3711f11
parent 983 87a20e4490e0
child 985 038d048a3940
equal deleted inserted replaced
981:593707d5c013 984:98c4a3711f11
    14 # published by the Open Source Initiative.
    14 # published by the Open Source Initiative.
    15 
    15 
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
       
    20 # changed with every update
    19 # changed with every update
    21 %define major 53
    20 %define major 54
    22 %define mainver %major.99
    21 %define mainver %major.99
    23 %define update_channel beta
    22 %define update_channel beta
    24 %define branding 1
    23 %define branding 1
    25 %define releasedate 20170602000000
    24 %define releasedate 20170804000000
    26 
    25 
    27 # PIE, full relro (x86_64 for now)
    26 # PIE, full relro (x86_64 for now)
    28 %define build_hardened 1
    27 %define build_hardened 1
    29 
    28 
    30 %if 0%{?suse_version} > 1320
    29 # Firefox only supports i686
    31 %ifarch %ix86 x86_64
    30 %ifarch %ix86
    32 %define firefox_use_rust 1
    31 ExclusiveArch: i586 i686
    33 %endif
    32 BuildArch:     i686
       
    33 %{expand:%%global optflags %(echo "%optflags"|sed -e s/i586/i686/) -march=i686 -mtune=generic}
    34 %endif
    34 %endif
    35 
    35 
    36 # general build definitions
    36 # general build definitions
    37 %define progname firefox
    37 %define progname firefox
    38 %define pkgname  MozillaFirefox
    38 %define pkgname  MozillaFirefox
    87 BuildRequires:  pkgconfig(libffi)
    87 BuildRequires:  pkgconfig(libffi)
    88 BuildRequires:  pkgconfig(glib-2.0)
    88 BuildRequires:  pkgconfig(glib-2.0)
    89 BuildRequires:  pkgconfig(gobject-2.0)
    89 BuildRequires:  pkgconfig(gobject-2.0)
    90 BuildRequires:  pkgconfig(gtk+-3.0) >= 3.4.0
    90 BuildRequires:  pkgconfig(gtk+-3.0) >= 3.4.0
    91 BuildRequires:  pkgconfig(gtk+-unix-print-3.0)
    91 BuildRequires:  pkgconfig(gtk+-unix-print-3.0)
    92 %if 0%{?firefox_use_rust}
       
    93 BuildRequires:  cargo
    92 BuildRequires:  cargo
    94 BuildRequires:  rust >= 1.15.1
    93 BuildRequires:  rust >= 1.15.1
    95 BuildRequires:  rust-std
    94 BuildRequires:  rust-std
    96 %endif
       
    97 # libavcodec is required for H.264 support but the
    95 # libavcodec is required for H.264 support but the
    98 # openSUSE version is currently not able to play H.264
    96 # openSUSE version is currently not able to play H.264
    99 # therefore the Packman version is required
    97 # therefore the Packman version is required
   100 # minimum version of libavcodec is 53
    98 # minimum version of libavcodec is 53
   101 Recommends:     libavcodec-full >= 0.10.16
    99 Recommends:     libavcodec-full >= 0.10.16
   315 . \$topsrcdir/browser/config/mozconfig
   313 . \$topsrcdir/browser/config/mozconfig
   316 ac_add_options --prefix=%{_prefix}
   314 ac_add_options --prefix=%{_prefix}
   317 ac_add_options --libdir=%{_libdir}
   315 ac_add_options --libdir=%{_libdir}
   318 ac_add_options --includedir=%{_includedir}
   316 ac_add_options --includedir=%{_includedir}
   319 ac_add_options --enable-release
   317 ac_add_options --enable-release
   320 %if 0%{?firefox_use_rust}
       
   321 %else
       
   322 ac_add_options --disable-rust
       
   323 %endif
       
   324 ac_add_options --enable-default-toolkit=cairo-gtk3
   318 ac_add_options --enable-default-toolkit=cairo-gtk3
   325 %if 0%{?build_hardened}
   319 %if 0%{?build_hardened}
   326 ac_add_options --enable-pie
   320 ac_add_options --enable-pie
   327 %endif
   321 %endif
   328 # gcc7 (boo#104105)
   322 # gcc7 (boo#104105)
   580 %{progdir}/dependentlibs.list
   574 %{progdir}/dependentlibs.list
   581 %{progdir}/icudt58l.dat
   575 %{progdir}/icudt58l.dat
   582 %{progdir}/*.so
   576 %{progdir}/*.so
   583 %{progdir}/omni.ja
   577 %{progdir}/omni.ja
   584 %{progdir}/fonts/
   578 %{progdir}/fonts/
       
   579 %{progdir}/pingsender
   585 %{progdir}/platform.ini
   580 %{progdir}/platform.ini
   586 %{progdir}/plugin-container
   581 %{progdir}/plugin-container
   587 %if %crashreporter
   582 %if %crashreporter
   588 %{progdir}/crashreporter
   583 %{progdir}/crashreporter
   589 %{progdir}/crashreporter.ini
   584 %{progdir}/crashreporter.ini