MozillaFirefox/MozillaFirefox.spec
changeset 935 9ae2b79d3bb1
parent 933 7f60766aae16
child 936 096e59808e91
equal deleted inserted replaced
934:b61e849fe451 935:9ae2b79d3bb1
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major 50
    21 %define major 50
    22 %define mainver %major.1.0
    22 %define mainver %major.99
    23 %define update_channel release
    23 %define update_channel beta
    24 %define releasedate 20161212000000
    24 %define releasedate 20170117000000
    25 
    25 
    26 # PIE, full relro (x86_64 for now)
    26 # PIE, full relro (x86_64 for now)
    27 %define build_hardened 1
    27 %define build_hardened 1
    28 
    28 
    29 # general build definitions
    29 # general build definitions
    72 BuildRequires:  libidl-devel
    72 BuildRequires:  libidl-devel
    73 BuildRequires:  libiw-devel
    73 BuildRequires:  libiw-devel
    74 BuildRequires:  libnotify-devel
    74 BuildRequires:  libnotify-devel
    75 BuildRequires:  libproxy-devel
    75 BuildRequires:  libproxy-devel
    76 BuildRequires:  makeinfo
    76 BuildRequires:  makeinfo
    77 BuildRequires:  mozilla-nspr-devel >= 4.12
    77 BuildRequires:  mozilla-nspr-devel >= 4.13.1
    78 BuildRequires:  mozilla-nss-devel >= 3.26.2
    78 BuildRequires:  mozilla-nss-devel >= 3.28.1
    79 BuildRequires:  nss-shared-helper-devel
    79 BuildRequires:  nss-shared-helper-devel
    80 BuildRequires:  python-devel
    80 BuildRequires:  python-devel
    81 BuildRequires:  startup-notification-devel
    81 BuildRequires:  startup-notification-devel
    82 BuildRequires:  unzip
    82 BuildRequires:  unzip
    83 BuildRequires:  update-desktop-files
    83 BuildRequires:  update-desktop-files
   150 # Firefox/browser
   150 # Firefox/browser
   151 Patch101:       firefox-kde.patch
   151 Patch101:       firefox-kde.patch
   152 Patch102:       firefox-no-default-ualocale.patch
   152 Patch102:       firefox-no-default-ualocale.patch
   153 Patch103:       firefox-branded-icons.patch
   153 Patch103:       firefox-branded-icons.patch
   154 # hotfix
   154 # hotfix
   155 Patch150:       mozilla-flex_buffer_overrun.patch
       
   156 Patch200:       mozilla-aarch64-startup-crash.patch
   155 Patch200:       mozilla-aarch64-startup-crash.patch
   157 
   156 
   158 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   157 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   159 Requires(post):   coreutils shared-mime-info desktop-file-utils
   158 Requires(post):   coreutils shared-mime-info desktop-file-utils
   160 Requires(postun): shared-mime-info desktop-file-utils
   159 Requires(postun): shared-mime-info desktop-file-utils
   264 %patch17 -p1
   263 %patch17 -p1
   265 # Firefox
   264 # Firefox
   266 %patch101 -p1
   265 %patch101 -p1
   267 %patch102 -p1
   266 %patch102 -p1
   268 %patch103 -p1
   267 %patch103 -p1
   269 %patch150 -p1
       
   270 %patch200 -p1
   268 %patch200 -p1
   271 
   269 
   272 %build
   270 %build
   273 # no need to add build time to binaries
   271 # no need to add build time to binaries
   274 modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/MozillaFirefox.changes")"
   272 modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/MozillaFirefox.changes")"