MozillaFirefox/MozillaFirefox.spec
branchfirefox112
changeset 1188 a2caa2a2494f
parent 1187 17bc5a064ab4
child 1189 ba0c97b018a6
equal deleted inserted replaced
1187:17bc5a064ab4 1188:a2caa2a2494f
    26 # orig_version would be the upstream tar ball
    26 # orig_version would be the upstream tar ball
    27 # orig_version 70.0
    27 # orig_version 70.0
    28 # orig_suffix b3
    28 # orig_suffix b3
    29 # major 69
    29 # major 69
    30 # mainver %%major.99
    30 # mainver %%major.99
    31 %define major          111
    31 %define major          112
    32 %define mainver        %major.0.1
    32 %define mainver        %major.0.2
    33 %define orig_version   111.0.1
    33 %define orig_version   112.0.2
    34 %define orig_suffix    %{nil}
    34 %define orig_suffix    %{nil}
    35 %define update_channel release
    35 %define update_channel release
    36 %define branding       1
    36 %define branding       1
    37 %define devpkg         1
    37 %define devpkg         1
    38 
    38 
   118 BuildRequires:  libcurl-devel
   118 BuildRequires:  libcurl-devel
   119 BuildRequires:  libiw-devel
   119 BuildRequires:  libiw-devel
   120 BuildRequires:  libproxy-devel
   120 BuildRequires:  libproxy-devel
   121 BuildRequires:  makeinfo
   121 BuildRequires:  makeinfo
   122 BuildRequires:  mozilla-nspr-devel >= 4.35
   122 BuildRequires:  mozilla-nspr-devel >= 4.35
   123 BuildRequires:  mozilla-nss-devel >= 3.88.1
   123 BuildRequires:  mozilla-nss-devel >= 3.89
   124 BuildRequires:  nasm >= 2.14
   124 BuildRequires:  nasm >= 2.14
   125 BuildRequires:  nodejs >= 10.22.1
   125 BuildRequires:  nodejs >= 10.22.1
   126 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   126 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   127 BuildRequires:  python-libxml2
   127 BuildRequires:  python-libxml2
   128 BuildRequires:  python36
   128 BuildRequires:  python36
   129 %else
   129 %else
   130 BuildRequires:  python3 >= 3.5
   130 %if 0%{?sle_version} >= 150000 && 0%{?sle_version} <= 150500
       
   131 BuildRequires:  python39
       
   132 BuildRequires:  python39-curses
       
   133 BuildRequires:  python39-devel
       
   134 %else
       
   135 BuildRequires:  python3 >= 3.7
   131 BuildRequires:  python3-curses
   136 BuildRequires:  python3-curses
   132 BuildRequires:  python3-devel
   137 BuildRequires:  python3-devel
       
   138 %endif
   133 %endif
   139 %endif
   134 BuildRequires:  rust-cbindgen >= 0.24.3
   140 BuildRequires:  rust-cbindgen >= 0.24.3
   135 BuildRequires:  unzip
   141 BuildRequires:  unzip
   136 BuildRequires:  update-desktop-files
   142 BuildRequires:  update-desktop-files
   137 BuildRequires:  xorg-x11-libXt-devel
   143 BuildRequires:  xorg-x11-libXt-devel
   226 Patch22:        mozilla-silence-no-return-type.patch
   232 Patch22:        mozilla-silence-no-return-type.patch
   227 Patch23:        mozilla-bmo531915.patch
   233 Patch23:        mozilla-bmo531915.patch
   228 Patch25:        one_swizzle_to_rule_them_all.patch
   234 Patch25:        one_swizzle_to_rule_them_all.patch
   229 Patch26:        svg-rendering.patch
   235 Patch26:        svg-rendering.patch
   230 Patch27:        mozilla-buildfixes.patch
   236 Patch27:        mozilla-buildfixes.patch
   231 Patch28:        mozilla-bmo1807652.patch
       
   232 # Firefox/browser
   237 # Firefox/browser
   233 Patch101:       firefox-kde.patch
   238 Patch101:       firefox-kde.patch
   234 Patch102:       firefox-branded-icons.patch
   239 Patch102:       firefox-branded-icons.patch
   235 %endif
   240 %endif
   236 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   241 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   245 # addon leads to startup crash (bnc#908892)
   250 # addon leads to startup crash (bnc#908892)
   246 Obsoletes:      tracker-miner-firefox < 0.15
   251 Obsoletes:      tracker-miner-firefox < 0.15
   247 %if 0%{?devpkg} == 0
   252 %if 0%{?devpkg} == 0
   248 Obsoletes:      %{name}-devel < %{version}
   253 Obsoletes:      %{name}-devel < %{version}
   249 %endif
   254 %endif
   250 ExcludeArch:    armv6l armv6hl ppc ppc64 ppc64le %ix86
   255 ExcludeArch:    armv6l armv6hl ppc ppc64 ppc64le
   251 
   256 
   252 %description
   257 %description
   253 Mozilla Firefox is a standalone web browser, designed for standards
   258 Mozilla Firefox is a standalone web browser, designed for standards
   254 compliance and performance.  Its functionality can be enhanced via a
   259 compliance and performance.  Its functionality can be enhanced via a
   255 plethora of extensions.
   260 plethora of extensions.
   393 export LDFLAGS="\$LDFLAGS -fPIC -Wl,-z,relro,-z,now"
   398 export LDFLAGS="\$LDFLAGS -fPIC -Wl,-z,relro,-z,now"
   394 %ifarch ppc64 ppc64le
   399 %ifarch ppc64 ppc64le
   395 %if 0%{?clang_build} == 0
   400 %if 0%{?clang_build} == 0
   396 export CFLAGS="\$CFLAGS -mminimal-toc"
   401 export CFLAGS="\$CFLAGS -mminimal-toc"
   397 %endif
   402 %endif
       
   403 %endif
       
   404 %ifarch %ix86
       
   405 # Not enough memory on 32-bit systems, reduce debug info.
       
   406 export CFLAGS="\$CFLAGS -g1"
   398 %endif
   407 %endif
   399 export CXXFLAGS="\$CFLAGS"
   408 export CXXFLAGS="\$CFLAGS"
   400 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   409 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   401 EOF
   410 EOF
   402 # Done with env-variables.
   411 # Done with env-variables.
   616 ln -sf ../..%{progdir}/%{progname}.sh %{buildroot}%{_bindir}/%{progname}
   625 ln -sf ../..%{progdir}/%{progname}.sh %{buildroot}%{_bindir}/%{progname}
   617 # desktop file
   626 # desktop file
   618 mkdir -p %{buildroot}%{_datadir}/applications
   627 mkdir -p %{buildroot}%{_datadir}/applications
   619 sed "s:%%NAME:%{appname}:g
   628 sed "s:%%NAME:%{appname}:g
   620 s:%%EXEC:%{progname}:g
   629 s:%%EXEC:%{progname}:g
   621 s:%%ICON:%{progname}:g" \
   630 s:%%ICON:%{progname}:g
       
   631 s:%%WMCLASS:%{progname}%{major}:g" \
   622   %{SOURCE1} > %{buildroot}%{_datadir}/applications/%{desktop_file_name}.desktop
   632   %{SOURCE1} > %{buildroot}%{_datadir}/applications/%{desktop_file_name}.desktop
   623 %suse_update_desktop_file %{desktop_file_name} Network WebBrowser GTK
   633 %suse_update_desktop_file %{desktop_file_name} Network WebBrowser GTK
   624 # additional mime-types
   634 # additional mime-types
   625 mkdir -p %{buildroot}%{_datadir}/mime/packages
   635 mkdir -p %{buildroot}%{_datadir}/mime/packages
   626 cp %{SOURCE8} %{buildroot}%{_datadir}/mime/packages/%{progname}.xml
   636 cp %{SOURCE8} %{buildroot}%{_datadir}/mime/packages/%{progname}.xml