MozillaFirefox/MozillaFirefox.spec
changeset 943 ace605efe50f
parent 942 66115255ad6f
child 944 ce8a98f8d8d7
equal deleted inserted replaced
942:66115255ad6f 943:ace605efe50f
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major 51
    21 %define major 51
    22 %define mainver %major.99
    22 %define mainver %major.99
    23 %define update_channel beta
    23 %define update_channel beta
    24 %define releasedate 20170111000000
    24 %define releasedate 20170224000000
    25 
    25 
    26 # PIE, full relro (x86_64 for now)
    26 # PIE, full relro (x86_64 for now)
    27 %define build_hardened 1
    27 %define build_hardened 1
       
    28 
       
    29 %if 0%{?suse_version} > 1320
       
    30 %define firefox_use_gtk3 1
       
    31 %define firefox_use_rust 1
       
    32 %endif
       
    33 
    28 
    34 
    29 # general build definitions
    35 # general build definitions
    30 %if "%{update_channel}" != "aurora"
    36 %if "%{update_channel}" != "aurora"
    31 %define progname firefox
    37 %define progname firefox
    32 %define pkgname  MozillaFirefox
    38 %define pkgname  MozillaFirefox
    33 %define appname  Firefox
    39 %define appname  Firefox
    34 %else
    40 %else
    35 %define progname firefox-dev
    41 %define progname firefox-dev
    36 %define pkgname  firefox-dev-edition
    42 %define pkgname  firefox-dev-edition
    37 %define appname  Firefox Developer Edition
    43 %define appname  Firefox Developer Edition
    38 %endif
       
    39 %if 0%{?suse_version} > 1320
       
    40 %define firefox_use_gtk3 1
       
    41 %endif
    44 %endif
    42 %define progdir %{_prefix}/%_lib/%{progname}
    45 %define progdir %{_prefix}/%_lib/%{progname}
    43 %define gnome_dir     %{_prefix}
    46 %define gnome_dir     %{_prefix}
    44 %define desktop_file_name %{progname}
    47 %define desktop_file_name %{progname}
    45 %define firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
    48 %define firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
    91 %if 0%{?firefox_use_gtk3}
    94 %if 0%{?firefox_use_gtk3}
    92 BuildRequires:  pkgconfig(glib-2.0)
    95 BuildRequires:  pkgconfig(glib-2.0)
    93 BuildRequires:  pkgconfig(gobject-2.0)
    96 BuildRequires:  pkgconfig(gobject-2.0)
    94 BuildRequires:  pkgconfig(gtk+-3.0) >= 3.4.0
    97 BuildRequires:  pkgconfig(gtk+-3.0) >= 3.4.0
    95 BuildRequires:  pkgconfig(gtk+-unix-print-3.0)
    98 BuildRequires:  pkgconfig(gtk+-unix-print-3.0)
       
    99 %endif
       
   100 %if 0%{?firefox_use_rust}
       
   101 BuildRequires:  cargo
       
   102 BuildRequires:  rust >= 1.10
    96 %endif
   103 %endif
    97 # libavcodec is required for H.264 support but the
   104 # libavcodec is required for H.264 support but the
    98 # openSUSE version is currently not able to play H.264
   105 # openSUSE version is currently not able to play H.264
    99 # therefore the Packman version is required
   106 # therefore the Packman version is required
   100 # minimum version of libavcodec is 53
   107 # minimum version of libavcodec is 53
   315 . \$topsrcdir/browser/config/mozconfig
   322 . \$topsrcdir/browser/config/mozconfig
   316 ac_add_options --prefix=%{_prefix}
   323 ac_add_options --prefix=%{_prefix}
   317 ac_add_options --libdir=%{_libdir}
   324 ac_add_options --libdir=%{_libdir}
   318 ac_add_options --includedir=%{_includedir}
   325 ac_add_options --includedir=%{_includedir}
   319 ac_add_options --enable-release
   326 ac_add_options --enable-release
       
   327 %if 0%{?firefox_use_rust}
       
   328 ac_add_options --enable-rust
       
   329 %endif
   320 %if 0%{?firefox_use_gtk3}
   330 %if 0%{?firefox_use_gtk3}
   321 ac_add_options --enable-default-toolkit=cairo-gtk3
   331 ac_add_options --enable-default-toolkit=cairo-gtk3
   322 %else
   332 %else
   323 ac_add_options --enable-default-toolkit=cairo-gtk2
   333 ac_add_options --enable-default-toolkit=cairo-gtk2
   324 %endif
   334 %endif