MozillaFirefox/MozillaFirefox.spec
changeset 809 af47260a332c
parent 807 f54c68340963
child 816 5551f1ff7e1d
equal deleted inserted replaced
807:f54c68340963 809:af47260a332c
    14 # published by the Open Source Initiative.
    14 # published by the Open Source Initiative.
    15 
    15 
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
       
    20 # changed with every update
    19 # changed with every update
    21 %define major 34
    20 %define major 34
    22 %define mainver %major.98
    21 %define mainver %major.98
    23 %define update_channel aurora
    22 %define update_channel aurora
    24 %define releasedate 2014111500
    23 %define releasedate 2014111500
    25 
    24 
    26 # general build definitions
    25 # general build definitions
       
    26 %if "%{update_channel}" != "aurora"
       
    27 %define progname firefox
       
    28 %define pkgname  MozillaFirefox
       
    29 %define appname  Firefox
       
    30 %else
       
    31 %define progname firefox-dev
       
    32 %define pkgname  firefox-dev-edition
       
    33 %define appname  Firefox Developer Edition
       
    34 %endif
       
    35 %define progdir %{_prefix}/%_lib/%{progname}
       
    36 %define gnome_dir     %{_prefix}
       
    37 %define desktop_file_name %{progname}
    27 %define firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
    38 %define firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
    28 %define _use_internal_dependency_generator 0
    39 %define _use_internal_dependency_generator 0
    29 %define __find_requires sh %{SOURCE4}
    40 %define __find_requires sh %{SOURCE4}
    30 %global provfind sh -c "grep -v '.so' | %__find_provides"
    41 %global provfind sh -c "grep -v '.so' | %__find_provides"
    31 %global __find_provides %provfind
    42 %global __find_provides %provfind
    32 %define progname firefox
       
    33 %define progdir %{_prefix}/%_lib/%{progname}
       
    34 %define gnome_dir     %{_prefix}
       
    35 %if 0%{?suse_version} > 1130
       
    36 %define desktop_file_name firefox
       
    37 %else
       
    38 %define desktop_file_name %{name}
       
    39 %endif
       
    40 %if 0%{?suse_version} > 1210
       
    41 %if 0%{?suse_version} > 1310
    43 %if 0%{?suse_version} > 1310
    42 %define gstreamer_ver 1.0
    44 %define gstreamer_ver 1.0
    43 %define gstreamer 1
    45 %define gstreamer 1
    44 %else
    46 %else
    45 %define gstreamer_ver 0.10
    47 %define gstreamer_ver 0.10
    46 %endif
    48 %endif
    47 %endif
       
    48 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
    49 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
    49 # Note: these are for the openSUSE Firefox builds ONLY. For your own distribution,
    50 # Note: these are for the openSUSE Firefox builds ONLY. For your own distribution,
    50 # please get your own set of keys.
    51 # please get your own set of keys.
    51 %define _google_api_key AIzaSyD1hTe85_a14kr1Ks8T3Ce75rvbR1_Dx7Q
    52 %define _google_api_key AIzaSyD1hTe85_a14kr1Ks8T3Ce75rvbR1_Dx7Q
       
    53 %if %update_channel == "aurora"
    52 %define branding 0
    54 %define branding 0
       
    55 %else
       
    56 %define branding 1
       
    57 %endif
    53 %define localize 1
    58 %define localize 1
    54 %ifarch aarch64 ppc ppc64 ppc64le s390 s390x ia64 %arm
    59 %ifarch aarch64 ppc ppc64 ppc64le s390 s390x ia64 %arm
    55 %define crashreporter 0
    60 %define crashreporter 0
    56 %else
    61 %else
    57 %define crashreporter 1
    62 %define crashreporter 1
    58 %endif
    63 %endif
    59 %if 0%{?suse_version} > 1210
    64 
    60 %if 0%{?suse_version} > 1310
    65 Name:           %{pkgname}
    61 %define gstreamer_ver 1.0
       
    62 %define gstreamer 1
       
    63 %else
       
    64 %define gstreamer_ver 0.10
       
    65 %endif
       
    66 %endif
       
    67 
       
    68 Name:           MozillaFirefox
       
    69 BuildRequires:  Mesa-devel
    66 BuildRequires:  Mesa-devel
    70 BuildRequires:  autoconf213
    67 BuildRequires:  autoconf213
    71 BuildRequires:  dbus-1-glib-devel
    68 BuildRequires:  dbus-1-glib-devel
    72 BuildRequires:  fdupes
    69 BuildRequires:  fdupes
    73 BuildRequires:  gcc-c++
    70 BuildRequires:  gcc-c++
    81 BuildRequires:  unzip
    78 BuildRequires:  unzip
    82 BuildRequires:  update-desktop-files
    79 BuildRequires:  update-desktop-files
    83 BuildRequires:  xorg-x11-libXt-devel
    80 BuildRequires:  xorg-x11-libXt-devel
    84 BuildRequires:  yasm
    81 BuildRequires:  yasm
    85 BuildRequires:  zip
    82 BuildRequires:  zip
    86 %if 0%{?suse_version} > 1110
       
    87 BuildRequires:  libiw-devel
    83 BuildRequires:  libiw-devel
    88 BuildRequires:  libproxy-devel
    84 BuildRequires:  libproxy-devel
    89 %else
       
    90 BuildRequires:  wireless-tools
       
    91 %endif
       
    92 BuildRequires:  mozilla-nspr-devel >= 4.10.7
    85 BuildRequires:  mozilla-nspr-devel >= 4.10.7
    93 BuildRequires:  mozilla-nss-devel >= 3.17.2
    86 BuildRequires:  mozilla-nss-devel >= 3.17.2
    94 BuildRequires:  nss-shared-helper-devel
    87 BuildRequires:  nss-shared-helper-devel
    95 BuildRequires:  pkgconfig(libpulse)
    88 BuildRequires:  pkgconfig(libpulse)
    96 %if 0%{?suse_version} > 1210
       
    97 BuildRequires:  pkgconfig(gstreamer-%gstreamer_ver)
    89 BuildRequires:  pkgconfig(gstreamer-%gstreamer_ver)
    98 BuildRequires:  pkgconfig(gstreamer-app-%gstreamer_ver)
    90 BuildRequires:  pkgconfig(gstreamer-app-%gstreamer_ver)
    99 BuildRequires:  pkgconfig(gstreamer-plugins-base-%gstreamer_ver)
    91 BuildRequires:  pkgconfig(gstreamer-plugins-base-%gstreamer_ver)
   100 %if 0%{?gstreamer} == 1
    92 %if 0%{?gstreamer} == 1
   101 Requires:       libgstreamer-1_0-0
    93 Requires:       libgstreamer-1_0-0
   104 %else
    96 %else
   105 Requires:       libgstreamer-0_10-0
    97 Requires:       libgstreamer-0_10-0
   106 Recommends:     gstreamer-0_10-fluendo-mp3
    98 Recommends:     gstreamer-0_10-fluendo-mp3
   107 Recommends:     gstreamer-0_10-plugins-ffmpeg
    99 Recommends:     gstreamer-0_10-plugins-ffmpeg
   108 %endif
   100 %endif
   109 %endif
       
   110 Version:        %{mainver}
   101 Version:        %{mainver}
   111 Release:        0
   102 Release:        0
       
   103 %if "%{name}" == "MozillaFirefox"
   112 Provides:       firefox = %{mainver}
   104 Provides:       firefox = %{mainver}
   113 Provides:       firefox = %{version}-%{release}
   105 Provides:       firefox = %{version}-%{release}
       
   106 %endif
   114 Provides:       web_browser
   107 Provides:       web_browser
   115 Provides:       browser(npapi)
   108 Provides:       browser(npapi)
   116 # this is needed to match this package with the kde4 helper package without the main package
   109 # this is needed to match this package with the kde4 helper package without the main package
   117 # having a hard requirement on the kde4 package
   110 # having a hard requirement on the kde4 package
   118 %define kde_helper_version 6
   111 %define kde_helper_version 6
   119 Provides:       mozilla-kde4-version = %{kde_helper_version}
   112 Provides:       mozilla-kde4-version = %{kde_helper_version}
   120 Summary:        Mozilla Firefox Web Browser
   113 Summary:        Mozilla %{appname} Web Browser
   121 License:        MPL-2.0
   114 License:        MPL-2.0
   122 Group:          Productivity/Networking/Web/Browsers
   115 Group:          Productivity/Networking/Web/Browsers
   123 Url:            http://www.mozilla.org/
   116 Url:            http://www.mozilla.org/
   124 Source:         firefox-%{version}-source.tar.xz
   117 Source:         firefox-%{version}-source.tar.xz
   125 Source1:        MozillaFirefox.desktop
   118 Source1:        MozillaFirefox.desktop
   145 Patch5:         mozilla-kde.patch
   138 Patch5:         mozilla-kde.patch
   146 Patch6:         mozilla-preferences.patch
   139 Patch6:         mozilla-preferences.patch
   147 Patch7:         mozilla-language.patch
   140 Patch7:         mozilla-language.patch
   148 Patch8:         mozilla-ntlm-full-path.patch
   141 Patch8:         mozilla-ntlm-full-path.patch
   149 Patch9:         mozilla-repo.patch
   142 Patch9:         mozilla-repo.patch
   150 Patch10:        mozilla-sle11.patch
   143 Patch10:        mozilla-icu-strncat.patch
   151 Patch11:        mozilla-icu-strncat.patch
   144 Patch11:        mozilla-arm-disable-edsp.patch
   152 Patch12:        mozilla-arm-disable-edsp.patch
   145 Patch12:        mozilla-bmo1088588.patch
   153 Patch13:        mozilla-bmo1088588.patch
   146 Patch13:        mozilla-openaes-decl.patch
   154 # Firefox/browser
   147 # Firefox/browser
   155 Patch101:       firefox-kde.patch
   148 Patch101:       firefox-kde.patch
   156 Patch102:       firefox-kde-114.patch
   149 Patch102:       firefox-no-default-ualocale.patch
   157 Patch103:       firefox-no-default-ualocale.patch
   150 Patch103:       firefox-multilocale-chrome.patch
   158 Patch104:       firefox-multilocale-chrome.patch
   151 Patch104:       firefox-branded-icons.patch
   159 Patch105:       firefox-branded-icons.patch
       
   160 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   152 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   161 Requires(post):   coreutils shared-mime-info desktop-file-utils
   153 Requires(post):   coreutils shared-mime-info desktop-file-utils
   162 Requires(postun): shared-mime-info desktop-file-utils
   154 Requires(postun): shared-mime-info desktop-file-utils
       
   155 %if %branding
   163 Requires:       %{name}-branding > 20.0
   156 Requires:       %{name}-branding > 20.0
       
   157 %endif
   164 Requires:       mozilla-nspr >= %(rpm -q --queryformat '%{VERSION}' mozilla-nspr)
   158 Requires:       mozilla-nspr >= %(rpm -q --queryformat '%{VERSION}' mozilla-nspr)
   165 Requires:       mozilla-nss >= %(rpm -q --queryformat '%{VERSION}' mozilla-nss)
   159 Requires:       mozilla-nss >= %(rpm -q --queryformat '%{VERSION}' mozilla-nss)
   166 Recommends:     libcanberra0
   160 Recommends:     libcanberra0
   167 Recommends:     libpulse0
   161 Recommends:     libpulse0
   168 # libproxy's mozjs pacrunner crashes FF (bnc#759123)
   162 # libproxy's mozjs pacrunner crashes FF (bnc#759123)
   174 Mozilla Firefox is a standalone web browser, designed for standards
   168 Mozilla Firefox is a standalone web browser, designed for standards
   175 compliance and performance.  Its functionality can be enhanced via a
   169 compliance and performance.  Its functionality can be enhanced via a
   176 plethora of extensions.
   170 plethora of extensions.
   177 
   171 
   178 %package devel
   172 %package devel
   179 Summary:        Devel package for Firefox
   173 Summary:        Devel package for %{appname}
   180 Group:          Development/Tools/Other
   174 Group:          Development/Tools/Other
   181 Provides:       firefox-devel = %{version}-%{release}
   175 Provides:       firefox-devel = %{version}-%{release}
   182 Requires:       %{name} = %{version}
   176 Requires:       %{name} = %{version}
   183 Requires:       perl(Archive::Zip)
   177 Requires:       perl(Archive::Zip)
   184 Requires:       perl(XML::Simple)
   178 Requires:       perl(XML::Simple)
   185 
   179 
   186 %description devel
   180 %description devel
   187 Development files for Firefox to make packaging of addons easier.
   181 Development files for %{appname} to make packaging of addons easier.
   188 
   182 
   189 %if %localize
   183 %if %localize
   190 %package translations-common
   184 %package translations-common
   191 Summary:        Common translations for Firefox
   185 Summary:        Common translations for %{appname}
   192 Group:          System/Localization
   186 Group:          System/Localization
   193 Provides:       locale(%{name}:ar;ca;cs;da;de;en_GB;el;es_AR;es_CL;es_ES;fi;fr;hu;it;ja;ko;nb_NO;nl;pl;pt_BR;pt_PT;ru;sv_SE;zh_CN;zh_TW)
   187 Provides:       locale(%{name}:ar;ca;cs;da;de;en_GB;el;es_AR;es_CL;es_ES;fi;fr;hu;it;ja;ko;nb_NO;nl;pl;pt_BR;pt_PT;ru;sv_SE;zh_CN;zh_TW)
   194 Requires:       %{name} = %{version}
   188 Requires:       %{name} = %{version}
   195 Obsoletes:      %{name}-translations < %{version}-%{release}
   189 Obsoletes:      %{name}-translations < %{version}-%{release}
   196 
   190 
   197 %description translations-common
   191 %description translations-common
   198 This package contains several common languages for the user interface
   192 This package contains several common languages for the user interface
   199 of Firefox.
   193 of %{appname}.
   200 
   194 
   201 %package translations-other
   195 %package translations-other
   202 Summary:        Extra translations for Firefox
   196 Summary:        Extra translations for %{appname}
   203 Group:          System/Localization
   197 Group:          System/Localization
   204 Provides:       locale(%{name}:ach;af;ak;as;ast;be;bg;bn_BD;bn_IN;br;bs;csb;cy;en_ZA;eo;es_MX;et;eu;fa;ff;fy_NL;ga_IE;gd;gl;gu_IN;he;hi_IN;hr;hy_AM;id;is;kk;km;kn;ku;lg;lij;lt;lv;mai;mk;ml;mr;nn_NO;nso;or;pa_IN;rm;ro;si;sk;sl;son;sq;sr;ta;ta_LK;te;th;tr;uk;vi;zu)
   198 Provides:       locale(%{name}:ach;af;ak;as;ast;be;bg;bn_BD;bn_IN;br;bs;csb;cy;en_ZA;eo;es_MX;et;eu;fa;ff;fy_NL;ga_IE;gd;gl;gu_IN;he;hi_IN;hr;hy_AM;id;is;kk;km;kn;ku;lg;lij;lt;lv;mai;mk;ml;mr;nn_NO;nso;or;pa_IN;rm;ro;si;sk;sl;son;sq;sr;ta;ta_LK;te;th;tr;uk;vi;zu)
   205 Requires:       %{name} = %{version}
   199 Requires:       %{name} = %{version}
   206 Obsoletes:      %{name}-translations < %{version}-%{release}
   200 Obsoletes:      %{name}-translations < %{version}-%{release}
   207 
   201 
   208 %description translations-other
   202 %description translations-other
   209 This package contains rarely used languages for the user interface
   203 This package contains rarely used languages for the user interface
   210 of Firefox.
   204 of %{appname}.
   211 %endif
   205 %endif
   212 
   206 
       
   207 %if %branding
   213 %package branding-upstream
   208 %package branding-upstream
   214 Summary:        Upstream branding for Firefox
   209 Summary:        Upstream branding for %{appname}
   215 Group:          Productivity/Networking/Web/Browsers
   210 Group:          Productivity/Networking/Web/Browsers
   216 Provides:       %{name}-branding = %{version}
   211 Provides:       %{name}-branding = %{version}
   217 Conflicts:      otherproviders(%{name}-branding)
   212 Conflicts:      otherproviders(%{name}-branding)
   218 Supplements:    packageand(%{name}:branding-upstream)
   213 Supplements:    packageand(%{name}:branding-upstream)
   219 #BRAND: Provide three files -
   214 #BRAND: Provide three files -
   225 #BRAND: /usr/lib/firefox/defaults/preferences/firefox-$vendor.js to set
   220 #BRAND: /usr/lib/firefox/defaults/preferences/firefox-$vendor.js to set
   226 #BRAND: custom preference overrides.
   221 #BRAND: custom preference overrides.
   227 #BRAND: It's also possible to drop files in /usr/lib/firefox/searchplugins
   222 #BRAND: It's also possible to drop files in /usr/lib/firefox/searchplugins
   228 
   223 
   229 %description branding-upstream
   224 %description branding-upstream
   230 This package provides upstream look and feel for Firefox.
   225 This package provides upstream look and feel for %{appname}.
   231 
   226 %endif
   232 
   227 
   233 %if %crashreporter
   228 %if %crashreporter
   234 
       
   235 %package buildsymbols
   229 %package buildsymbols
   236 Summary:        Breakpad buildsymbols for %{name}
   230 Summary:        Breakpad buildsymbols for %{appname}
   237 Group:          Development/Debug
   231 Group:          Development/Debug
   238 
   232 
   239 %description buildsymbols
   233 %description buildsymbols
   240 This subpackage contains the Breakpad created and compatible debugging
   234 This subpackage contains the Breakpad created and compatible debugging
   241 symbols meant for upload to Mozilla's crash collector database.
   235 symbols meant for upload to Mozilla's crash collector database.
   255 %patch5 -p1
   249 %patch5 -p1
   256 %patch6 -p1
   250 %patch6 -p1
   257 %patch7 -p1
   251 %patch7 -p1
   258 %patch8 -p1
   252 %patch8 -p1
   259 %patch9 -p1
   253 %patch9 -p1
   260 %if 0%{?suse_version} < 1120
       
   261 %patch10 -p1
   254 %patch10 -p1
   262 %endif
       
   263 %patch11 -p1
   255 %patch11 -p1
   264 %patch12 -p1
   256 %patch12 -p1
   265 %patch13 -p1
   257 %patch13 -p1
   266 # Firefox
   258 # Firefox
   267 %patch101 -p1
   259 %patch101 -p1
   268 %if 0%{?suse_version} >= 1140
       
   269 %patch102 -p1
   260 %patch102 -p1
   270 %endif
       
   271 %patch103 -p1
   261 %patch103 -p1
   272 %patch104 -p1
   262 %patch104 -p1
   273 %patch105 -p1
       
   274 
   263 
   275 %build
   264 %build
   276 # no need to add build time to binaries
   265 # no need to add build time to binaries
   277 modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/%{name}.changes")"
   266 modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/MozillaFirefox.changes")"
   278 DATE="\"$(date -d "${modified}" "+%%b %%e %%Y")\""
   267 DATE="\"$(date -d "${modified}" "+%%b %%e %%Y")\""
   279 TIME="\"$(date -d "${modified}" "+%%R")\""
   268 TIME="\"$(date -d "${modified}" "+%%R")\""
   280 find . -regex ".*\.c\|.*\.cpp\|.*\.h" -exec sed -i "s/__DATE__/${DATE}/g;s/__TIME__/${TIME}/g" {} +
   269 find . -regex ".*\.c\|.*\.cpp\|.*\.h" -exec sed -i "s/__DATE__/${DATE}/g;s/__TIME__/${TIME}/g" {} +
   281 #
   270 #
   282 kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)
   271 kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)
   344 #ac_add_options --enable-chrome-format=jar
   333 #ac_add_options --enable-chrome-format=jar
   345 ac_add_options --enable-update-channel=%{update_channel}
   334 ac_add_options --enable-update-channel=%{update_channel}
   346 %if 0%{?gstreamer} == 1
   335 %if 0%{?gstreamer} == 1
   347 ac_add_options --enable-gstreamer=1.0
   336 ac_add_options --enable-gstreamer=1.0
   348 %endif
   337 %endif
   349 %if 0%{?suse_version} > 1130
       
   350 ac_add_options --disable-gnomevfs
   338 ac_add_options --disable-gnomevfs
   351 ac_add_options --enable-gio
   339 ac_add_options --enable-gio
   352 %endif
       
   353 %if 0%{?suse_version} < 1220
       
   354 ac_add_options --disable-gstreamer
       
   355 %endif
       
   356 %if %branding
   340 %if %branding
   357 ac_add_options --enable-official-branding
   341 ac_add_options --enable-official-branding
   358 %endif
   342 %endif
   359 %if 0%{?suse_version} > 1110
       
   360 ac_add_options --enable-libproxy
   343 ac_add_options --enable-libproxy
   361 %endif
       
   362 %if ! %crashreporter
   344 %if ! %crashreporter
   363 ac_add_options --disable-crashreporter
   345 ac_add_options --disable-crashreporter
   364 %endif
   346 %endif
   365 # Disable neon for arm as it does not build correctly
   347 # Disable neon for arm as it does not build correctly
   366 %ifarch %arm
   348 %ifarch %arm
   450 s:%%APPNAME:firefox:g
   432 s:%%APPNAME:firefox:g
   451 s:%%PROFILE:.mozilla/firefox:g" \
   433 s:%%PROFILE:.mozilla/firefox:g" \
   452   %{SOURCE3} > %{buildroot}%{progdir}/%{progname}.sh
   434   %{SOURCE3} > %{buildroot}%{progdir}/%{progname}.sh
   453 chmod 755 %{buildroot}%{progdir}/%{progname}.sh
   435 chmod 755 %{buildroot}%{progdir}/%{progname}.sh
   454 ln -sf ../..%{progdir}/%{progname}.sh %{buildroot}%{_bindir}/%{progname}
   436 ln -sf ../..%{progdir}/%{progname}.sh %{buildroot}%{_bindir}/%{progname}
   455 # desktop definition
   437 # desktop file
   456 mkdir -p %{buildroot}%{_datadir}/applications
   438 mkdir -p %{buildroot}%{_datadir}/applications
   457 install -m 644 %{SOURCE1} \
   439 sed "s:%%NAME:%{appname}:g
   458    %{buildroot}%{_datadir}/applications/%{desktop_file_name}.desktop
   440 s:%%EXEC:%{progname}:g
       
   441 s:%%ICON:%{progname}:g" \
       
   442   %{SOURCE1} > %{buildroot}%{_datadir}/applications/%{desktop_file_name}.desktop
       
   443 %suse_update_desktop_file %{desktop_file_name} Network WebBrowser GTK
   459 # additional mime-types
   444 # additional mime-types
   460 mkdir -p %{buildroot}%{_datadir}/mime/packages
   445 mkdir -p %{buildroot}%{_datadir}/mime/packages
   461 cp %{SOURCE8} %{buildroot}%{_datadir}/mime/packages/%{progname}.xml
   446 cp %{SOURCE8} %{buildroot}%{_datadir}/mime/packages/%{progname}.xml
   462 # appdata
   447 # appdata
       
   448 %if "%{update_channel}" != "aurora"
   463 mkdir -p %{buildroot}%{_datadir}/appdata
   449 mkdir -p %{buildroot}%{_datadir}/appdata
   464 cp %{SOURCE15} %{buildroot}%{_datadir}/appdata/%{desktop_file_name}.appdata.xml
   450 cp %{SOURCE15} %{buildroot}%{_datadir}/appdata/%{desktop_file_name}.appdata.xml
       
   451 %endif
   465 # install man-page
   452 # install man-page
   466 mkdir -p %{buildroot}%{_mandir}/man1/
   453 mkdir -p %{buildroot}%{_mandir}/man1/
   467 cp %{SOURCE11} %{buildroot}%{_mandir}/man1/%{progname}.1
   454 cp %{SOURCE11} %{buildroot}%{_mandir}/man1/%{progname}.1
   468 ##########
   455 ##########
   469 # ADDONS
   456 # ADDONS
   480 %endif
   467 %endif
   481   mkdir -p %{buildroot}%{gnome_dir}/share/icons/hicolor/${size}x${size}/apps/
   468   mkdir -p %{buildroot}%{gnome_dir}/share/icons/hicolor/${size}x${size}/apps/
   482   ln -sf %{progdir}/browser/chrome/icons/default/default$size.png \
   469   ln -sf %{progdir}/browser/chrome/icons/default/default$size.png \
   483          %{buildroot}%{gnome_dir}/share/icons/hicolor/${size}x${size}/apps/%{progname}.png
   470          %{buildroot}%{gnome_dir}/share/icons/hicolor/${size}x${size}/apps/%{progname}.png
   484 done
   471 done
   485 %suse_update_desktop_file %{desktop_file_name} Network WebBrowser GTK
       
   486 # excludes
   472 # excludes
   487 rm -f %{buildroot}%{progdir}/updater.ini
   473 rm -f %{buildroot}%{progdir}/updater.ini
   488 rm -f %{buildroot}%{progdir}/removed-files
   474 rm -f %{buildroot}%{progdir}/removed-files
   489 rm -f %{buildroot}%{progdir}/README.txt
   475 rm -f %{buildroot}%{progdir}/README.txt
   490 rm -f %{buildroot}%{progdir}/old-homepage-default.properties
   476 rm -f %{buildroot}%{progdir}/old-homepage-default.properties
   542 rm -rf %{_tmppath}/translations.*
   528 rm -rf %{_tmppath}/translations.*
   543 %endif
   529 %endif
   544 
   530 
   545 %post
   531 %post
   546 # update mime and desktop database
   532 # update mime and desktop database
   547 %if 0%{?suse_version} > 1130
       
   548 %mime_database_post
   533 %mime_database_post
   549 %desktop_database_post
   534 %desktop_database_post
   550 %icon_theme_cache_post
   535 %icon_theme_cache_post
   551 %else
       
   552 if [ -f usr/bin/update-mime-database ] ; then
       
   553   usr/bin/update-mime-database %{_datadir}/mime > /dev/null || :
       
   554 fi
       
   555 if [ -f usr/bin/update-desktop-database ] ; then
       
   556   usr/bin/update-desktop-database > /dev/null || :
       
   557 fi
       
   558 %endif
       
   559 exit 0
   536 exit 0
   560 
   537 
   561 %postun
   538 %postun
   562 %if 0%{?suse_version} > 1130
       
   563 %icon_theme_cache_postun
   539 %icon_theme_cache_postun
   564 %desktop_database_postun
   540 %desktop_database_postun
   565 %mime_database_postun
   541 %mime_database_postun
   566 %else
       
   567 if [ -f usr/bin/update-mime-database ] ; then
       
   568   usr/bin/update-mime-database %{_datadir}/mime > /dev/null || :
       
   569 fi
       
   570 if [ -f usr/bin/update-desktop-database ] ; then
       
   571   usr/bin/update-desktop-database > /dev/null || :
       
   572 fi
       
   573 %endif
       
   574 exit 0
   542 exit 0
   575 
   543 
   576 %files
   544 %files
   577 %defattr(-,root,root)
   545 %defattr(-,root,root)
   578 %dir %{progdir}
   546 %dir %{progdir}
   613 %{progdir}/browser/crashreporter-override.ini
   581 %{progdir}/browser/crashreporter-override.ini
   614 %endif
   582 %endif
   615 %{_datadir}/applications/%{desktop_file_name}.desktop
   583 %{_datadir}/applications/%{desktop_file_name}.desktop
   616 %{_datadir}/mime/packages/%{progname}.xml
   584 %{_datadir}/mime/packages/%{progname}.xml
   617 %{_datadir}/pixmaps/firefox*
   585 %{_datadir}/pixmaps/firefox*
   618 %{_datadir}/appdata/
       
   619 %dir %{_datadir}/mozilla
   586 %dir %{_datadir}/mozilla
   620 %dir %{_datadir}/mozilla/extensions
   587 %dir %{_datadir}/mozilla/extensions
   621 %dir %{_datadir}/mozilla/extensions/%{firefox_appid}
   588 %dir %{_datadir}/mozilla/extensions/%{firefox_appid}
   622 %dir %{_libdir}/mozilla
   589 %dir %{_libdir}/mozilla
   623 %dir %{_libdir}/mozilla/extensions
   590 %dir %{_libdir}/mozilla/extensions
   624 %dir %{_libdir}/mozilla/extensions/%{firefox_appid}
   591 %dir %{_libdir}/mozilla/extensions/%{firefox_appid}
   625 %{gnome_dir}/share/icons/hicolor/
   592 %{gnome_dir}/share/icons/hicolor/
   626 %{_bindir}/%{progname}
   593 %{_bindir}/%{progname}
   627 %doc %{_mandir}/man1/%{progname}.1.gz
   594 %doc %{_mandir}/man1/%{progname}.1.gz
       
   595 %if "%{update_channel}" != "aurora"
       
   596 %{_datadir}/appdata/
       
   597 %endif
   628 
   598 
   629 %files devel
   599 %files devel
   630 %defattr(-,root,root)
   600 %defattr(-,root,root)
   631 %{_bindir}/mozilla-get-app-id
   601 %{_bindir}/mozilla-get-app-id
   632 %config %{_sysconfdir}/rpm/macros.%{progname}
   602 %config %{_sysconfdir}/rpm/macros.%{progname}
   644 %dir %{progdir}/browser/extensions/
   614 %dir %{progdir}/browser/extensions/
   645 %endif
   615 %endif
   646 
   616 
   647 # this package does not need to provide files but is needed to fulfill
   617 # this package does not need to provide files but is needed to fulfill
   648 # requirements if no other branding package is to be installed
   618 # requirements if no other branding package is to be installed
   649 
   619 %if %branding
   650 %files branding-upstream
   620 %files branding-upstream
   651 %defattr(-,root,root)
   621 %defattr(-,root,root)
   652 %dir %{progdir}
   622 %dir %{progdir}
       
   623 %endif
   653 
   624 
   654 %if %crashreporter
   625 %if %crashreporter
   655 
       
   656 %files buildsymbols
   626 %files buildsymbols
   657 %defattr(-,root,root)
   627 %defattr(-,root,root)
   658 %{_datadir}/mozilla/*.zip
   628 %{_datadir}/mozilla/*.zip
   659 %endif
   629 %endif
   660 
   630