MozillaFirefox/firefox-esr.spec
branchesr17
changeset 632 b83636a26466
parent 598 92044e416d59
child 638 3a72bcb470fb
equal deleted inserted replaced
599:95b8784f9466 632:b83636a26466
     1 #
     1 #
     2 # spec file for package firefox-esr
     2 # spec file for package firefox-esr
     3 #
     3 #
     4 # Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
     4 # Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
     5 #               2006-2012 Wolfgang Rosenauer
     5 #               2006-2013 Wolfgang Rosenauer
     6 #
     6 #
     7 # All modifications and additions to the file contributed by third parties
     7 # All modifications and additions to the file contributed by third parties
     8 # remain the property of their copyright owners, unless otherwise agreed
     8 # remain the property of their copyright owners, unless otherwise agreed
     9 # upon. The license for this file, and modifications and additions to the
     9 # upon. The license for this file, and modifications and additions to the
    10 # file, is the same license as for the pristine package itself (unless the
    10 # file, is the same license as for the pristine package itself (unless the
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 %define major 17
    20 %define major 17
    21 %define mainver %major.0.2
    21 %define mainver %major.0.4
    22 %define update_channel release
    22 %define update_channel release
    23 
    23 
    24 Name:           firefox-esr
    24 Name:           firefox-esr
    25 BuildRequires:  Mesa-devel
    25 BuildRequires:  Mesa-devel
    26 BuildRequires:  autoconf213
    26 BuildRequires:  autoconf213
    52 BuildRequires:  pkgconfig(gstreamer-app-0.10)
    52 BuildRequires:  pkgconfig(gstreamer-app-0.10)
    53 BuildRequires:  pkgconfig(gstreamer-plugins-base-0.10)
    53 BuildRequires:  pkgconfig(gstreamer-plugins-base-0.10)
    54 %endif
    54 %endif
    55 Version:        %{mainver}
    55 Version:        %{mainver}
    56 Release:        0
    56 Release:        0
    57 %define         releasedate 2013010500
    57 %define         releasedate 2013030700
    58 Provides:       firefox-esr = %{mainver}
    58 Provides:       firefox-esr = %{mainver}
    59 Provides:       web_browser
    59 Provides:       web_browser
    60 Provides:       browser(npapi)
    60 Provides:       browser(npapi)
    61 # this is needed to match this package with the kde4 helper package without the main package
    61 # this is needed to match this package with the kde4 helper package without the main package
    62 # having a hard requirement on the kde4 package
    62 # having a hard requirement on the kde4 package
   103 Patch11:        mozilla-disable-neon-option.patch
   103 Patch11:        mozilla-disable-neon-option.patch
   104 Patch12:        mozilla-arm-disable-edsp.patch
   104 Patch12:        mozilla-arm-disable-edsp.patch
   105 Patch13:        mozilla-gstreamer.patch
   105 Patch13:        mozilla-gstreamer.patch
   106 Patch14:        mozilla-ppc.patch
   106 Patch14:        mozilla-ppc.patch
   107 Patch15:        mozilla-gstreamer-760140.patch
   107 Patch15:        mozilla-gstreamer-760140.patch
       
   108 Patch16:        mozilla-deoptimize.patch
   108 # SLE11 patches
   109 # SLE11 patches
   109 Patch20:        mozilla-gcc43-enums.patch
   110 Patch20:        mozilla-gcc43-enums.patch
   110 Patch21:        mozilla-gcc43-template_hacks.patch
   111 Patch21:        mozilla-gcc43-template_hacks.patch
   111 Patch22:        mozilla-gcc43-templates_instantiation.patch
   112 Patch22:        mozilla-gcc43-templates_instantiation.patch
   112 # Firefox/browser
   113 # Firefox/browser
   245 #%patch11 -p1
   246 #%patch11 -p1
   246 %patch12 -p1
   247 %patch12 -p1
   247 %patch13 -p1
   248 %patch13 -p1
   248 %patch14 -p1
   249 %patch14 -p1
   249 %patch15 -p1
   250 %patch15 -p1
       
   251 %if %suse_version == 1120
       
   252 %ifarch %x86
       
   253 %patch16 -p1
       
   254 %endif
       
   255 %endif
   250 # SLE patches
   256 # SLE patches
   251 %if %suse_version <= 1110
   257 %if %suse_version <= 1120
   252 %patch20 -p1
   258 %patch20 -p1
   253 %patch21 -p1
   259 %patch21 -p1
   254 %patch22 -p1
   260 %patch22 -p1
   255 %endif
   261 %endif
   256 #
   262 #
   284 export MOZ_BUILD_DATE=%{releasedate}
   290 export MOZ_BUILD_DATE=%{releasedate}
   285 export MOZILLA_OFFICIAL=1
   291 export MOZILLA_OFFICIAL=1
   286 export BUILD_OFFICIAL=1
   292 export BUILD_OFFICIAL=1
   287 export MOZ_TELEMETRY_REPORTING=1
   293 export MOZ_TELEMETRY_REPORTING=1
   288 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
   294 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
       
   295 %if %suse_version == 1120
       
   296 %ifarch %x86
       
   297 export CFLAGS="$RPM_OPT_FLAGS -O1 -fno-strict-aliasing"
       
   298 %endif
       
   299 %endif
   289 %ifarch ppc64
   300 %ifarch ppc64
   290 export CFLAGS="$CFLAGS -mminimal-toc"
   301 export CFLAGS="$CFLAGS -mminimal-toc"
   291 %endif
   302 %endif
   292 export CXXFLAGS="$CFLAGS"
   303 export CXXFLAGS="$CFLAGS"
   293 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   304 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig