MozillaFirefox/MozillaFirefox.spec
branchfirefox87
changeset 1155 b8c834aafde2
parent 1154 71a92b4d0527
child 1156 c3d884659acf
equal deleted inserted replaced
1154:71a92b4d0527 1155:b8c834aafde2
    15 
    15 
    16 # Please submit bugfixes or comments via https://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via https://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
    19 
       
    20 %define _dwz_low_mem_die_limit  40000000
       
    21 %define _dwz_max_die_limit     200000000
       
    22 
    20 %if 0%{?suse_version} < 1550 && 0%{?sle_version} <= 150100
    23 %if 0%{?suse_version} < 1550 && 0%{?sle_version} <= 150100
    21 #!BuildIgnore: post-build-checks
    24 #!BuildIgnore: post-build-checks
    22 %endif
    25 %endif
    23 
    26 
    24 # changed with every update
    27 # changed with every update
    27 # orig_version would be the upstream tar ball
    30 # orig_version would be the upstream tar ball
    28 # orig_version 70.0
    31 # orig_version 70.0
    29 # orig_suffix b3
    32 # orig_suffix b3
    30 # major 69
    33 # major 69
    31 # mainver %major.99
    34 # mainver %major.99
    32 %define major          85
    35 %define major          87
    33 %define mainver        %major.0
    36 %define mainver        %major.0
    34 %define orig_version   85.0
    37 %define orig_version   87.0
    35 %define orig_suffix    %{nil}
    38 %define orig_suffix    %{nil}
    36 %define update_channel release
    39 %define update_channel release
    37 %define branding       1
    40 %define branding       1
    38 %define devpkg         1
    41 %define devpkg         1
    39 
    42 
    99 BuildRequires:  libidl-devel
   102 BuildRequires:  libidl-devel
   100 BuildRequires:  libiw-devel
   103 BuildRequires:  libiw-devel
   101 BuildRequires:  libproxy-devel
   104 BuildRequires:  libproxy-devel
   102 BuildRequires:  makeinfo
   105 BuildRequires:  makeinfo
   103 BuildRequires:  mozilla-nspr-devel >= 4.29
   106 BuildRequires:  mozilla-nspr-devel >= 4.29
   104 BuildRequires:  mozilla-nss-devel >= 3.60.1
   107 BuildRequires:  mozilla-nss-devel >= 3.62
   105 BuildRequires:  nasm >= 2.14
   108 BuildRequires:  nasm >= 2.14
   106 BuildRequires:  nodejs10 >= 10.22.1
   109 BuildRequires:  nodejs10 >= 10.22.1
   107 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   110 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   108 BuildRequires:  python-libxml2
   111 BuildRequires:  python-libxml2
   109 BuildRequires:  python36
   112 BuildRequires:  python36
   110 %else
   113 %else
   111 BuildRequires:  python3 >= 3.5
   114 BuildRequires:  python3 >= 3.5
   112 BuildRequires:  python3-devel
   115 BuildRequires:  python3-devel
   113 %endif
   116 %endif
   114 BuildRequires:  rust >= 1.47
   117 BuildRequires:  rust >= 1.47
   115 BuildRequires:  rust-cbindgen >= 0.15.0
   118 BuildRequires:  rust-cbindgen >= 0.16.0
   116 BuildRequires:  unzip
   119 BuildRequires:  unzip
   117 BuildRequires:  update-desktop-files
   120 BuildRequires:  update-desktop-files
   118 BuildRequires:  xorg-x11-libXt-devel
   121 BuildRequires:  xorg-x11-libXt-devel
   119 %if 0%{?do_profiling}
   122 %if 0%{?do_profiling}
   120 BuildRequires:  xvfb-run
   123 BuildRequires:  xvfb-run
   173 Source8:        firefox-mimeinfo.xml
   176 Source8:        firefox-mimeinfo.xml
   174 Source9:        firefox.js
   177 Source9:        firefox.js
   175 Source11:       firefox.1
   178 Source11:       firefox.1
   176 Source12:       mozilla-get-app-id
   179 Source12:       mozilla-get-app-id
   177 Source13:       spellcheck.js
   180 Source13:       spellcheck.js
   178 Source14:       https://github.com/openSUSE/firefox-scripts/raw/5e54f4a/create-tar.sh
   181 Source14:       https://github.com/openSUSE/firefox-scripts/raw/4503820/create-tar.sh
   179 Source15:       firefox-appdata.xml
   182 Source15:       firefox-appdata.xml
   180 Source16:       %{name}.changes
   183 Source16:       %{name}.changes
   181 Source17:       firefox-search-provider.ini
   184 Source17:       firefox-search-provider.ini
   182 # Set up API keys, see http://www.chromium.org/developers/how-tos/api-keys
   185 # Set up API keys, see http://www.chromium.org/developers/how-tos/api-keys
   183 # Note: these are for the openSUSE Firefox builds ONLY. For your own distribution,
   186 # Note: these are for the openSUSE Firefox builds ONLY. For your own distribution,
   200 Patch13:        mozilla-bmo1005535.patch
   203 Patch13:        mozilla-bmo1005535.patch
   201 Patch14:        mozilla-bmo1568145.patch
   204 Patch14:        mozilla-bmo1568145.patch
   202 Patch15:        mozilla-bmo1504834-part1.patch
   205 Patch15:        mozilla-bmo1504834-part1.patch
   203 Patch16:        mozilla-bmo1504834-part2.patch
   206 Patch16:        mozilla-bmo1504834-part2.patch
   204 Patch17:        mozilla-bmo1504834-part3.patch
   207 Patch17:        mozilla-bmo1504834-part3.patch
   205 Patch18:        mozilla-bmo1554971.patch
       
   206 Patch19:        mozilla-bmo1512162.patch
   208 Patch19:        mozilla-bmo1512162.patch
   207 Patch20:        mozilla-fix-top-level-asm.patch
   209 Patch20:        mozilla-fix-top-level-asm.patch
   208 Patch21:        mozilla-bmo1504834-part4.patch
   210 Patch21:        mozilla-bmo1504834-part4.patch
   209 Patch22:        mozilla-bmo849632.patch
   211 Patch22:        mozilla-bmo849632.patch
   210 Patch24:        mozilla-bmo1602730.patch
   212 Patch24:        mozilla-bmo1602730.patch
   215 # Firefox/browser
   217 # Firefox/browser
   216 Patch101:       firefox-kde.patch
   218 Patch101:       firefox-kde.patch
   217 Patch102:       firefox-branded-icons.patch
   219 Patch102:       firefox-branded-icons.patch
   218 %endif
   220 %endif
   219 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   221 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   220 Requires(post):   coreutils shared-mime-info desktop-file-utils
   222 Requires(post): coreutils shared-mime-info desktop-file-utils
   221 Requires(postun): shared-mime-info desktop-file-utils
   223 Requires(postun):shared-mime-info desktop-file-utils
   222 Requires:       %{name}-branding >= 68
   224 Requires:       %{name}-branding >= 68
   223 %requires_ge    mozilla-nspr
   225 %requires_ge    mozilla-nspr
   224 %requires_ge    mozilla-nss
   226 %requires_ge    mozilla-nss
   225 %requires_ge    libfreetype6
   227 %requires_ge    libfreetype6
   226 Recommends:     libcanberra0
   228 Recommends:     libcanberra0
   296 #BRAND: custom preference overrides.
   298 #BRAND: custom preference overrides.
   297 #BRAND: It's also possible to drop files in /usr/lib/firefox/distribution/searchplugins/common/
   299 #BRAND: It's also possible to drop files in /usr/lib/firefox/distribution/searchplugins/common/
   298 
   300 
   299 %description branding-upstream
   301 %description branding-upstream
   300 This package provides upstream look and feel for %{appname}.
   302 This package provides upstream look and feel for %{appname}.
   301 
       
   302 %if %crashreporter
       
   303 %package buildsymbols
       
   304 Summary:        Breakpad buildsymbols for %{appname}
       
   305 Group:          Development/Debug
       
   306 
       
   307 %description buildsymbols
       
   308 This subpackage contains the Breakpad created and compatible debugging
       
   309 symbols meant for upload to Mozilla's crash collector database.
       
   310 %endif
       
   311 
   303 
   312 %if !%{with only_print_mozconfig}
   304 %if !%{with only_print_mozconfig}
   313 %prep
   305 %prep
   314 %if %localize
   306 %if %localize
   315 
   307 
   339 %patch13 -p1
   331 %patch13 -p1
   340 %patch14 -p1
   332 %patch14 -p1
   341 %patch15 -p1
   333 %patch15 -p1
   342 %patch16 -p1
   334 %patch16 -p1
   343 %patch17 -p1
   335 %patch17 -p1
   344 %patch18 -p1
       
   345 %patch19 -p1
   336 %patch19 -p1
   346 %patch20 -p1
   337 %patch20 -p1
   347 %patch21 -p1
   338 %patch21 -p1
   348 %patch22 -p1
   339 %patch22 -p1
   349 %patch24 -p1
   340 %patch24 -p1
   429 echo "export BUILD_OFFICIAL=1"
   420 echo "export BUILD_OFFICIAL=1"
   430 echo "export MOZ_TELEMETRY_REPORTING=1"
   421 echo "export MOZ_TELEMETRY_REPORTING=1"
   431 echo ""
   422 echo ""
   432 cat << EOF
   423 cat << EOF
   433 %else
   424 %else
   434 %ifarch aarch64 %arm
   425 %ifarch aarch64 %arm ppc64 ppc64le
   435 %limit_build -m 2000
   426 %limit_build -m 2000
   436 %endif
   427 %endif
   437 cat << EOF > $MOZCONFIG
   428 cat << EOF > $MOZCONFIG
   438 %endif
   429 %endif
   439 mk_add_options MOZILLA_OFFICIAL=1
   430 mk_add_options MOZILLA_OFFICIAL=1
   512 %endif
   503 %endif
   513 %endif
   504 %endif
   514 %endif
   505 %endif
   515 EOF
   506 EOF
   516 %if !%{with only_print_mozconfig}
   507 %if !%{with only_print_mozconfig}
   517 %ifarch ppc64 s390x s390
       
   518 # NOTE: Currently, system-icu is too old, so we can't build with that,
       
   519 #       but have to generate the .dat-file freshly. This seems to be a
       
   520 #       less fragile approach anyways.
       
   521 # ac_add_options --with-system-icu
       
   522 echo "Generate big endian version of config/external/icu/data/icud58l.dat"
       
   523 ./mach python intl/icu_sources_data.py .
       
   524 ls -l config/external/icu/data
       
   525 rm -f config/external/icu/data/icudt*l.dat
       
   526 %endif
       
   527 ccache -s
   508 ccache -s
   528 %if 0%{?do_profiling}
   509 %if 0%{?do_profiling}
   529 xvfb-run --server-args="-screen 0 1920x1080x24" \
   510 xvfb-run --server-args="-screen 0 1920x1080x24" \
   530 %endif
   511 %endif
   531 ./mach build -v
   512 ./mach build -v
   704 FIN
   685 FIN
   705 %endif
   686 %endif
   706 # fdupes
   687 # fdupes
   707 %fdupes %{buildroot}%{progdir}
   688 %fdupes %{buildroot}%{progdir}
   708 %fdupes %{buildroot}%{_datadir}
   689 %fdupes %{buildroot}%{_datadir}
   709 # create breakpad debugsymbols
       
   710 %if %crashreporter
       
   711 SYMBOLS_NAME="firefox-%{version}-` echo '%{release}' | sed 's@\.[^\.]\+$@@' `.%{_arch}-%{suse_version}-symbols"
       
   712 make buildsymbols \
       
   713   SYMBOL_INDEX_NAME="$SYMBOLS_NAME.txt" \
       
   714   SYMBOL_FULL_ARCHIVE_BASENAME="$SYMBOLS_NAME-full" \
       
   715   SYMBOL_ARCHIVE_BASENAME="$SYMBOLS_NAME"
       
   716 if [ -e dist/*symbols.zip ]; then
       
   717   mkdir -p %{buildroot}%{_datadir}/mozilla/
       
   718   cp dist/*symbols.zip %{buildroot}%{_datadir}/mozilla/
       
   719 fi
       
   720 %endif
       
   721 
   690 
   722 %clean
   691 %clean
   723 rm -rf %{buildroot}
   692 rm -rf %{buildroot}
   724 %if %localize
   693 %if %localize
   725 rm -rf %{_tmppath}/translations.*
   694 rm -rf %{_tmppath}/translations.*
   810 # requirements if no other branding package is to be installed
   779 # requirements if no other branding package is to be installed
   811 %files branding-upstream
   780 %files branding-upstream
   812 %defattr(-,root,root)
   781 %defattr(-,root,root)
   813 %dir %{progdir}
   782 %dir %{progdir}
   814 
   783 
   815 %if %crashreporter
       
   816 %files buildsymbols
       
   817 %defattr(-,root,root)
       
   818 %{_datadir}/mozilla/*.zip
       
   819 %endif
       
   820 
       
   821 %changelog
   784 %changelog