MozillaFirefox/MozillaFirefox.spec
changeset 993 c360e9aac24a
parent 992 b2ba34e0dc10
child 994 9fc447b00040
equal deleted inserted replaced
985:038d048a3940 993:c360e9aac24a
    15 
    15 
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 # changed with every update
    19 # changed with every update
    20 %define major 54
    20 %define major 55
    21 %define mainver %major.99
    21 %define mainver %major.99
    22 %define update_channel beta
    22 %define update_channel beta
    23 %define branding 1
    23 %define branding 1
    24 %define releasedate 20170804000000
    24 %define releasedate 20170914000000
    25 
    25 
    26 # PIE, full relro (x86_64 for now)
    26 # PIE, full relro (x86_64 for now)
    27 %define build_hardened 1
    27 %define build_hardened 1
    28 
    28 
    29 # Firefox only supports i686
    29 # Firefox only supports i686
    43 %define firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
    43 %define firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
    44 %define _use_internal_dependency_generator 0
    44 %define _use_internal_dependency_generator 0
    45 %define __find_requires sh %{SOURCE4}
    45 %define __find_requires sh %{SOURCE4}
    46 %global provfind sh -c "grep -v '.so' | %__find_provides"
    46 %global provfind sh -c "grep -v '.so' | %__find_provides"
    47 %global __find_provides %provfind
    47 %global __find_provides %provfind
    48 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
       
    49 # Note: these are for the openSUSE Firefox builds ONLY. For your own distribution,
       
    50 # please get your own set of keys.
       
    51 %define _google_api_key AIzaSyD1hTe85_a14kr1Ks8T3Ce75rvbR1_Dx7Q
       
    52 %define localize 1
    48 %define localize 1
    53 %ifarch %ix86 x86_64
    49 %ifarch %ix86 x86_64
    54 %define crashreporter 1
    50 %define crashreporter 1
    55 %else
    51 %else
    56 %define crashreporter 0
    52 %define crashreporter 0
    72 BuildRequires:  libidl-devel
    68 BuildRequires:  libidl-devel
    73 BuildRequires:  libiw-devel
    69 BuildRequires:  libiw-devel
    74 BuildRequires:  libnotify-devel
    70 BuildRequires:  libnotify-devel
    75 BuildRequires:  libproxy-devel
    71 BuildRequires:  libproxy-devel
    76 BuildRequires:  makeinfo
    72 BuildRequires:  makeinfo
    77 BuildRequires:  mozilla-nspr-devel >= 4.15
    73 BuildRequires:  mozilla-nspr-devel >= 4.16
    78 BuildRequires:  mozilla-nss-devel >= 3.31
    74 BuildRequires:  mozilla-nss-devel >= 3.32.1
    79 BuildRequires:  python-devel
    75 BuildRequires:  python-devel
    80 BuildRequires:  startup-notification-devel
    76 BuildRequires:  startup-notification-devel
    81 BuildRequires:  unzip
    77 BuildRequires:  unzip
    82 BuildRequires:  update-desktop-files
    78 BuildRequires:  update-desktop-files
    83 BuildRequires:  xorg-x11-libXt-devel
    79 BuildRequires:  xorg-x11-libXt-devel
   130 Source13:       spellcheck.js
   126 Source13:       spellcheck.js
   131 Source14:       create-tar.sh
   127 Source14:       create-tar.sh
   132 Source15:       firefox-appdata.xml
   128 Source15:       firefox-appdata.xml
   133 Source16:       MozillaFirefox.changes
   129 Source16:       MozillaFirefox.changes
   134 Source17:       l10n_changesets.txt
   130 Source17:       l10n_changesets.txt
       
   131 # Set up API keys, see http://www.chromium.org/developers/how-tos/api-keys
       
   132 # Note: these are for the openSUSE Firefox builds ONLY. For your own distribution,
       
   133 # please get your own set of keys.
   135 Source18:       mozilla-api-key
   134 Source18:       mozilla-api-key
       
   135 Source19:       google-api-key
   136 # Gecko/Toolkit
   136 # Gecko/Toolkit
   137 Patch1:         mozilla-nongnome-proxies.patch
   137 Patch1:         mozilla-nongnome-proxies.patch
   138 Patch3:         mozilla-kde.patch
   138 Patch3:         mozilla-kde.patch
   139 Patch5:         mozilla-language.patch
   139 Patch5:         mozilla-language.patch
   140 Patch6:         mozilla-ntlm-full-path.patch
   140 Patch6:         mozilla-ntlm-full-path.patch
   141 Patch7:         mozilla-openaes-decl.patch
   141 Patch7:         mozilla-openaes-decl.patch
   142 Patch8:         mozilla-no-stdcxx-check.patch
   142 Patch8:         mozilla-no-stdcxx-check.patch
   143 Patch9:         mozilla-reduce-files-per-UnifiedBindings.patch
   143 Patch9:         mozilla-reduce-files-per-UnifiedBindings.patch
   144 Patch10:        mozilla-aarch64-startup-crash.patch
   144 Patch10:        mozilla-aarch64-startup-crash.patch
       
   145 Patch11:        mozilla-ucontext.patch
   145 # Firefox/browser
   146 # Firefox/browser
   146 Patch101:       firefox-kde.patch
   147 Patch101:       firefox-kde.patch
   147 Patch102:       firefox-no-default-ualocale.patch
   148 Patch102:       firefox-no-default-ualocale.patch
   148 Patch103:       firefox-branded-icons.patch
   149 Patch103:       firefox-branded-icons.patch
   149 
   150 
   251 %patch8 -p1
   252 %patch8 -p1
   252 %ifarch %ix86
   253 %ifarch %ix86
   253 %patch9 -p1
   254 %patch9 -p1
   254 %endif
   255 %endif
   255 %patch10 -p1
   256 %patch10 -p1
       
   257 %patch11 -p1
   256 # Firefox
   258 # Firefox
   257 %patch101 -p1
   259 %patch101 -p1
   258 %patch102 -p1
   260 %patch102 -p1
   259 %patch103 -p1
   261 %patch103 -p1
   260 
   262 
   277 export MOZ_SOURCE_REPO=$REPO
   279 export MOZ_SOURCE_REPO=$REPO
   278 export MOZ_BUILD_DATE=%{releasedate}
   280 export MOZ_BUILD_DATE=%{releasedate}
   279 export MOZILLA_OFFICIAL=1
   281 export MOZILLA_OFFICIAL=1
   280 export BUILD_OFFICIAL=1
   282 export BUILD_OFFICIAL=1
   281 export MOZ_TELEMETRY_REPORTING=1
   283 export MOZ_TELEMETRY_REPORTING=1
   282 export MOZ_GOOGLE_API_KEY=%{_google_api_key}
       
   283 %if 0%{?suse_version} <= 1320
   284 %if 0%{?suse_version} <= 1320
   284 export CC=gcc-5
   285 export CC=gcc-5
   285 %endif
   286 %endif
   286 export CFLAGS="%{optflags} -fno-strict-aliasing"
   287 export CFLAGS="%{optflags} -fno-strict-aliasing"
   287 # boo#986541: add -fno-delete-null-pointer-checks for gcc6
   288 # boo#986541: add -fno-delete-null-pointer-checks for gcc6
   345 ac_add_options --disable-debug
   346 ac_add_options --disable-debug
   346 ac_add_options --enable-startup-notification
   347 ac_add_options --enable-startup-notification
   347 #ac_add_options --enable-chrome-format=jar
   348 #ac_add_options --enable-chrome-format=jar
   348 ac_add_options --enable-update-channel=%{update_channel}
   349 ac_add_options --enable-update-channel=%{update_channel}
   349 ac_add_options --with-mozilla-api-keyfile=%{SOURCE18}
   350 ac_add_options --with-mozilla-api-keyfile=%{SOURCE18}
       
   351 ac_add_options --with-google-api-keyfile=%{SOURCE19}
   350 %if %branding
   352 %if %branding
   351 ac_add_options --enable-official-branding
   353 ac_add_options --enable-official-branding
   352 %endif
   354 %endif
   353 ac_add_options --enable-libproxy
   355 ac_add_options --enable-libproxy
   354 %if ! %crashreporter
   356 %if ! %crashreporter