MozillaFirefox/MozillaFirefox.spec
branchfirefox10
changeset 396 c7b8a6aede34
parent 388 79f457fa15a7
child 397 efe18be91213
equal deleted inserted replaced
393:997d2e729a8c 396:c7b8a6aede34
    32 BuildRequires:  libnotify-devel
    32 BuildRequires:  libnotify-devel
    33 BuildRequires:  python
    33 BuildRequires:  python
    34 BuildRequires:  startup-notification-devel
    34 BuildRequires:  startup-notification-devel
    35 BuildRequires:  unzip
    35 BuildRequires:  unzip
    36 BuildRequires:  update-desktop-files
    36 BuildRequires:  update-desktop-files
       
    37 BuildRequires:  xorg-x11-devel
    37 BuildRequires:  yasm
    38 BuildRequires:  yasm
    38 BuildRequires:  zip
    39 BuildRequires:  zip
    39 %if %suse_version > 1110
    40 %if %suse_version > 1110
    40 BuildRequires:  libiw-devel
    41 BuildRequires:  libiw-devel
    41 BuildRequires:  libproxy-devel
    42 BuildRequires:  libproxy-devel
   204 cd $RPM_BUILD_DIR/mozilla
   205 cd $RPM_BUILD_DIR/mozilla
   205 %patch1 -p1
   206 %patch1 -p1
   206 %patch2 -p1
   207 %patch2 -p1
   207 %patch3 -p1
   208 %patch3 -p1
   208 %patch4 -p1
   209 %patch4 -p1
   209 #%patch5 -p1
   210 %patch5 -p1
   210 %patch6 -p1
   211 %patch6 -p1
   211 %patch7 -p1
   212 %patch7 -p1
   212 %patch8 -p1
   213 %patch8 -p1
   213 %patch9 -p1
   214 %patch9 -p1
   214 %patch10 -p1
   215 %patch10 -p1
   222 %patch16 -p1
   223 %patch16 -p1
   223 #
   224 #
   224 %patch31 -p1
   225 %patch31 -p1
   225 %patch32 -p1
   226 %patch32 -p1
   226 %if %suse_version >= 1110
   227 %if %suse_version >= 1110
   227 #%patch33 -p1
   228 %patch33 -p1
   228 %endif
   229 %endif
   229 %if %suse_version >= 1140
   230 %if %suse_version >= 1140
   230 #%patch34 -p1
   231 %patch34 -p1
   231 %endif
   232 %endif
   232 %patch38 -p1
   233 %patch38 -p1
   233 %patch39 -p1
   234 %patch39 -p1
   234 %patch41 -p1
   235 %patch41 -p1
   235 
   236 
   238 modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/%{name}.changes")"
   239 modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/%{name}.changes")"
   239 DATE="\"$(date -d "${modified}" "+%%b %%e %%Y")\""
   240 DATE="\"$(date -d "${modified}" "+%%b %%e %%Y")\""
   240 TIME="\"$(date -d "${modified}" "+%%R")\""
   241 TIME="\"$(date -d "${modified}" "+%%R")\""
   241 find . -regex ".*\.c\|.*\.cpp\|.*\.h" -exec sed -i "s/__DATE__/${DATE}/g;s/__TIME__/${TIME}/g" {} +
   242 find . -regex ".*\.c\|.*\.cpp\|.*\.h" -exec sed -i "s/__DATE__/${DATE}/g;s/__TIME__/${TIME}/g" {} +
   242 #
   243 #
   243 #kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)
   244 kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)
   244 #if test "$kdehelperversion" != %{kde_helper_version}; then
   245 if test "$kdehelperversion" != %{kde_helper_version}; then
   245 #  echo fix kde helper version in the .spec file
   246   echo fix kde helper version in the .spec file
   246 #  exit 1
   247   exit 1
   247 #fi
   248 fi
   248 source %{SOURCE5}
   249 source %{SOURCE5}
   249 export MOZ_SOURCE_STAMP=$REV
   250 export MOZ_SOURCE_STAMP=$REV
   250 export SOURCE_REPO=$REPO
   251 export SOURCE_REPO=$REPO
   251 export MOZ_SOURCE_REPO=$REPO
   252 export MOZ_SOURCE_REPO=$REPO
   252 export MOZ_BUILD_DATE=%{releasedate}
   253 export MOZ_BUILD_DATE=%{releasedate}