MozillaFirefox/MozillaFirefox.spec
branchfirefox108
changeset 1182 cb6f01567cf8
parent 1181 ba646dddffef
child 1183 e69790650e3c
equal deleted inserted replaced
1181:ba646dddffef 1182:cb6f01567cf8
     1 #
     1 #
     2 # spec file for package MozillaFirefox
     2 # spec file
     3 #
     3 #
     4 # Copyright (c) 2022 SUSE LLC
     4 # Copyright (c) 2023 SUSE LLC
     5 # Copyright (c) 2006-2022 Wolfgang Rosenauer <wr@rosenauer.org>
     5 # Copyright (c) 2006-2022 Wolfgang Rosenauer <wr@rosenauer.org>
     6 #
     6 #
     7 # All modifications and additions to the file contributed by third parties
     7 # All modifications and additions to the file contributed by third parties
     8 # remain the property of their copyright owners, unless otherwise agreed
     8 # remain the property of their copyright owners, unless otherwise agreed
     9 # upon. The license for this file, and modifications and additions to the
     9 # upon. The license for this file, and modifications and additions to the
    26 # orig_version would be the upstream tar ball
    26 # orig_version would be the upstream tar ball
    27 # orig_version 70.0
    27 # orig_version 70.0
    28 # orig_suffix b3
    28 # orig_suffix b3
    29 # major 69
    29 # major 69
    30 # mainver %major.99
    30 # mainver %major.99
    31 %define major          107
    31 %define major          108
    32 %define mainver        %major.0.1
    32 %define mainver        %major.0.2
    33 %define orig_version   107.0.1
    33 %define orig_version   108.0.2
    34 %define orig_suffix    %{nil}
    34 %define orig_suffix    %{nil}
    35 %define update_channel release
    35 %define update_channel release
    36 %define branding       1
    36 %define branding       1
    37 %define devpkg         1
    37 %define devpkg         1
    38 
    38 
    97 BuildRequires:  gcc11-c++
    97 BuildRequires:  gcc11-c++
    98 %else
    98 %else
    99 BuildRequires:  gcc-c++
    99 BuildRequires:  gcc-c++
   100 %endif
   100 %endif
   101 %if 0%{?suse_version} < 1550 && 0%{?sle_version} < 150300
   101 %if 0%{?suse_version} < 1550 && 0%{?sle_version} < 150300
   102 BuildRequires:  cargo >= 1.61
   102 BuildRequires:  cargo >= 1.63
   103 BuildRequires:  rust >= 1.61
   103 BuildRequires:  rust >= 1.63
   104 %else
   104 %else
   105 # Newer sle/leap/tw use parallel versioned rust releases which have
   105 # Newer sle/leap/tw use parallel versioned rust releases which have
   106 # a different method for provides that we can use to request a
   106 # a different method for provides that we can use to request a
   107 # specific version
   107 # specific version
   108 # minimal requirement:
   108 # minimal requirement:
   109 BuildRequires:  rust+cargo >= 1.61
   109 BuildRequires:  rust+cargo >= 1.63
   110 # actually used upstream:
   110 # actually used upstream:
   111 BuildRequires:  cargo1.64
   111 BuildRequires:  cargo1.65
   112 BuildRequires:  rust1.64
   112 BuildRequires:  rust1.65
   113 %endif
   113 %endif
   114 %if 0%{useccache} != 0
   114 %if 0%{useccache} != 0
   115 BuildRequires:  ccache
   115 BuildRequires:  ccache
   116 %endif
   116 %endif
   117 BuildRequires:  libXcomposite-devel
   117 BuildRequires:  libXcomposite-devel
   118 BuildRequires:  libcurl-devel
   118 BuildRequires:  libcurl-devel
   119 BuildRequires:  libiw-devel
   119 BuildRequires:  libiw-devel
   120 BuildRequires:  libproxy-devel
   120 BuildRequires:  libproxy-devel
   121 BuildRequires:  makeinfo
   121 BuildRequires:  makeinfo
   122 BuildRequires:  mozilla-nspr-devel >= 4.35
   122 BuildRequires:  mozilla-nspr-devel >= 4.35
   123 BuildRequires:  mozilla-nss-devel >= 3.84
   123 BuildRequires:  mozilla-nss-devel >= 3.85
   124 BuildRequires:  nasm >= 2.14
   124 BuildRequires:  nasm >= 2.14
   125 BuildRequires:  nodejs >= 10.22.1
   125 BuildRequires:  nodejs >= 10.22.1
   126 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   126 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   127 BuildRequires:  python-libxml2
   127 BuildRequires:  python-libxml2
   128 BuildRequires:  python36
   128 BuildRequires:  python36
   129 %else
   129 %else
   130 BuildRequires:  python3 >= 3.5
   130 BuildRequires:  python3 >= 3.5
       
   131 BuildRequires:  python3-curses
   131 BuildRequires:  python3-devel
   132 BuildRequires:  python3-devel
   132 %endif
   133 %endif
   133 BuildRequires:  rust-cbindgen >= 0.24.3
   134 BuildRequires:  rust-cbindgen >= 0.24.3
   134 BuildRequires:  unzip
   135 BuildRequires:  unzip
   135 BuildRequires:  update-desktop-files
   136 BuildRequires:  update-desktop-files
   247 %endif
   248 %endif
   248 # libproxy's mozjs pacrunner crashes FF (bnc#759123)
   249 # libproxy's mozjs pacrunner crashes FF (bnc#759123)
   249 %if 0%{?suse_version} < 1220
   250 %if 0%{?suse_version} < 1220
   250 Obsoletes:      libproxy1-pacrunner-mozjs <= 0.4.7
   251 Obsoletes:      libproxy1-pacrunner-mozjs <= 0.4.7
   251 %endif
   252 %endif
   252 ExcludeArch:    armv6l armv6hl
   253 ExcludeArch:    armv6l armv6hl ppc ppc64 ppc64le
   253 
   254 
   254 %description
   255 %description
   255 Mozilla Firefox is a standalone web browser, designed for standards
   256 Mozilla Firefox is a standalone web browser, designed for standards
   256 compliance and performance.  Its functionality can be enhanced via a
   257 compliance and performance.  Its functionality can be enhanced via a
   257 plethora of extensions.
   258 plethora of extensions.
   370 export MOZ_SOURCE_REPO=\$RELEASE_REPO
   371 export MOZ_SOURCE_REPO=\$RELEASE_REPO
   371 export MOZ_BUILD_DATE=\$RELEASE_TIMESTAMP
   372 export MOZ_BUILD_DATE=\$RELEASE_TIMESTAMP
   372 export MOZILLA_OFFICIAL=1
   373 export MOZILLA_OFFICIAL=1
   373 export BUILD_OFFICIAL=1
   374 export BUILD_OFFICIAL=1
   374 export MOZ_TELEMETRY_REPORTING=1
   375 export MOZ_TELEMETRY_REPORTING=1
   375 export MACH_USE_SYSTEM_PYTHON=1
   376 export MACH_BUILD_PYTHON_NATIVE_PACKAGE_SOURCE=system
   376 export CFLAGS="%{optflags}"
   377 export CFLAGS="%{optflags}"
   377 %if 0%{?suse_version} < 1550 && 0%{?sle_version} <= 150400
   378 %if 0%{?suse_version} < 1550 && 0%{?sle_version} <= 150400
   378 export CC=gcc-11
   379 export CC=gcc-11
   379 %else
   380 %else
   380 %if 0%{?clang_build} == 0
   381 %if 0%{?clang_build} == 0