MozillaFirefox/MozillaFirefox.spec
branchfirefox77
changeset 1127 d5b284f833d5
parent 1126 6b7cd9ae087d
child 1128 0d95fa645411
equal deleted inserted replaced
1126:6b7cd9ae087d 1127:d5b284f833d5
    16 # Please submit bugfixes or comments via https://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via https://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major          76
    21 %define major          77
    22 %define mainver        %major.0.1
    22 %define mainver        %major.0
    23 %define orig_version   76.0.1
    23 %define orig_version   77.0
    24 %define orig_suffix    %{nil}
    24 %define orig_suffix    %{nil}
    25 %define update_channel release
    25 %define update_channel release
    26 %define branding       1
    26 %define branding       1
    27 %define devpkg         1
    27 %define devpkg         1
    28 
    28 
    29 # disable for FF73 for now as it fails for unknown reason
    29 # disable for FF73 for now as it fails for unknown reason
    30 %define do_profiling   0
    30 %define do_profiling   0
    31 
    31 
    32 # always build with GCC as SUSE Security Team requires that
    32 # upstream default is clang (to use gcc for large parts set to 0)
    33 %define clang_build 0
    33 %define clang_build 1
    34 
    34 
    35 # PIE, full relro
    35 # PIE, full relro
    36 %define build_hardened 1
    36 %define build_hardened 1
    37 
    37 
    38 %bcond_with only_print_mozconfig
    38 %bcond_with only_print_mozconfig
    82 BuildRequires:  libiw-devel
    82 BuildRequires:  libiw-devel
    83 BuildRequires:  libnotify-devel
    83 BuildRequires:  libnotify-devel
    84 BuildRequires:  libproxy-devel
    84 BuildRequires:  libproxy-devel
    85 BuildRequires:  makeinfo
    85 BuildRequires:  makeinfo
    86 BuildRequires:  mozilla-nspr-devel >= 4.25
    86 BuildRequires:  mozilla-nspr-devel >= 4.25
    87 BuildRequires:  mozilla-nss-devel >= 3.51.1
    87 BuildRequires:  mozilla-nss-devel >= 3.52.1
    88 BuildRequires:  nasm >= 2.14
    88 BuildRequires:  nasm >= 2.14
    89 BuildRequires:  nodejs10 >= 10.19.0
    89 BuildRequires:  nodejs10 >= 10.19.0
    90 BuildRequires:  python-devel
    90 BuildRequires:  python-devel
    91 BuildRequires:  python2-xml
    91 BuildRequires:  python2-xml
    92 BuildRequires:  python3 >= 3.5
    92 BuildRequires:  python3 >= 3.5
    93 BuildRequires:  rust >= 1.41
    93 BuildRequires:  rust >= 1.41
    94 BuildRequires:  rust-cbindgen >= 0.13.1
    94 BuildRequires:  rust-cbindgen >= 0.14.1
    95 BuildRequires:  startup-notification-devel
    95 BuildRequires:  startup-notification-devel
    96 BuildRequires:  unzip
    96 BuildRequires:  unzip
    97 BuildRequires:  update-desktop-files
    97 BuildRequires:  update-desktop-files
    98 BuildRequires:  xorg-x11-libXt-devel
    98 BuildRequires:  xorg-x11-libXt-devel
    99 %if 0%{?do_profiling}
    99 %if 0%{?do_profiling}