xulrunner/xulrunner.spec
branchesr17
changeset 583 e1753761c9fd
parent 582 185659cb030f
child 584 0541c6b43891
equal deleted inserted replaced
582:185659cb030f 583:e1753761c9fd
     1 #
       
     2 # spec file for package xulrunner
       
     3 #
       
     4 # Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
       
     5 #               2006-2012 Wolfgang Rosenauer
       
     6 #
       
     7 # All modifications and additions to the file contributed by third parties
       
     8 # remain the property of their copyright owners, unless otherwise agreed
       
     9 # upon. The license for this file, and modifications and additions to the
       
    10 # file, is the same license as for the pristine package itself (unless the
       
    11 # license for the pristine package is not an Open Source License, in which
       
    12 # case the license is the MIT License). An "Open Source License" is a
       
    13 # license that conforms to the Open Source Definition (Version 1.9)
       
    14 # published by the Open Source Initiative.
       
    15 
       
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
       
    17 #
       
    18 
       
    19 
       
    20 Name:           xulrunner
       
    21 BuildRequires:  Mesa-devel
       
    22 BuildRequires:  autoconf213
       
    23 BuildRequires:  dbus-1-glib-devel
       
    24 BuildRequires:  fdupes
       
    25 BuildRequires:  gcc-c++
       
    26 BuildRequires:  hunspell-devel
       
    27 BuildRequires:  libcurl-devel
       
    28 BuildRequires:  libgnomeui-devel
       
    29 BuildRequires:  libidl-devel
       
    30 BuildRequires:  libnotify-devel
       
    31 BuildRequires:  nss-shared-helper-devel
       
    32 BuildRequires:  pkg-config
       
    33 BuildRequires:  python
       
    34 BuildRequires:  startup-notification-devel
       
    35 BuildRequires:  unzip
       
    36 BuildRequires:  xorg-x11-libXt-devel
       
    37 BuildRequires:  yasm
       
    38 BuildRequires:  zip
       
    39 %if %suse_version > 1110
       
    40 BuildRequires:  libiw-devel
       
    41 BuildRequires:  libproxy-devel
       
    42 %else
       
    43 BuildRequires:  wireless-tools
       
    44 %endif
       
    45 BuildRequires:  mozilla-nspr-devel >= 4.9.2
       
    46 BuildRequires:  mozilla-nss-devel >= 3.13.6
       
    47 Version:        17.0
       
    48 Release:        0
       
    49 %define         releasedate 2012111600
       
    50 %define         version_internal 17.0
       
    51 %define         apiversion 17
       
    52 %define         uaweight 1700000
       
    53 Summary:        Mozilla Runtime Environment
       
    54 License:        MPL-2.0
       
    55 Group:          Productivity/Other
       
    56 Url:            http://www.mozilla.org/
       
    57 Provides:       gecko
       
    58 %ifarch %ix86
       
    59 Provides:       xulrunner-32bit = %{version}-%{release}
       
    60 %endif
       
    61 Source:         xulrunner-%{version}-source.tar.bz2
       
    62 Source1:        l10n-%{version}.tar.bz2
       
    63 Source2:        find-external-requires.sh
       
    64 Source3:        %{name}-rpmlintrc
       
    65 Source4:        xulrunner-openSUSE-prefs.js
       
    66 Source5:        add-plugins.sh.in
       
    67 Source6:        create-tar.sh
       
    68 Source7:        baselibs.conf
       
    69 Source8:        source-stamp.txt
       
    70 Source9:        compare-locales.tar.bz2
       
    71 Patch1:         toolkit-download-folder.patch
       
    72 Patch2:         mozilla-pkgconfig.patch
       
    73 Patch3:         mozilla-idldir.patch
       
    74 Patch4:         mozilla-nongnome-proxies.patch
       
    75 Patch5:         mozilla-prefer_plugin_pref.patch
       
    76 Patch6:         mozilla-language.patch
       
    77 Patch7:         mozilla-ntlm-full-path.patch
       
    78 Patch9:         mozilla-sle11.patch
       
    79 Patch14:        mozilla-ppc.patch
       
    80 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
       
    81 Requires:       mozilla-js = %{version}
       
    82 Requires(post):  update-alternatives coreutils
       
    83 Requires(preun): update-alternatives coreutils
       
    84 ### build configuration ###
       
    85 %define has_system_nspr  1
       
    86 %define has_system_nss   1
       
    87 %define has_system_cairo 0
       
    88 %define localize 0
       
    89 %ifarch ppc ppc64 s390 s390x ia64 %arm
       
    90 %define crashreporter    0
       
    91 %else
       
    92 %define crashreporter    1
       
    93 %endif
       
    94 ### configuration end ###
       
    95 %define _use_internal_dependency_generator 0
       
    96 %define __find_requires sh %{SOURCE2}
       
    97 %global provfind sh -c "grep -Ev 'mozsqlite3|dbusservice|unixprint' | %__find_provides"
       
    98 %global __find_provides %provfind
       
    99 %if %has_system_nspr
       
   100 Requires:       mozilla-nspr >= %(rpm -q --queryformat '%{VERSION}' mozilla-nspr)
       
   101 %endif
       
   102 %if %has_system_nss
       
   103 Requires:       mozilla-nss >= %(rpm -q --queryformat '%{VERSION}' mozilla-nss)
       
   104 %endif
       
   105 
       
   106 %description
       
   107 XULRunner is a single installable package that can be used to bootstrap
       
   108 multiple XUL+XPCOM applications that are as rich as Firefox and
       
   109 Thunderbird.
       
   110 
       
   111 
       
   112 %package -n mozilla-js
       
   113 Summary:        Mozilla JS engine
       
   114 Group:          Productivity/Other
       
   115 
       
   116 %description -n mozilla-js
       
   117 JavaScript is the Netscape-developed object scripting language used in millions
       
   118 of web pages and server applications worldwide. Netscape's JavaScript is a
       
   119 superset of the ECMA-262 Edition 3 (ECMAScript) standard scripting language,
       
   120 with only mild differences from the published standard.
       
   121 
       
   122 
       
   123 %package devel
       
   124 Summary:        XULRunner/Gecko SDK
       
   125 Group:          Development/Libraries/Other
       
   126 %if %has_system_nspr
       
   127 Requires:       mozilla-nspr-devel >= %(rpm -q --queryformat '%{VERSION}' mozilla-nspr-devel)
       
   128 %endif
       
   129 %if %has_system_nss
       
   130 Requires:       mozilla-nss-devel >= %(rpm -q --queryformat '%{VERSION}' mozilla-nss-devel)
       
   131 %endif
       
   132 Requires:       %{name} = %{version}
       
   133 
       
   134 %description devel
       
   135 Software Development Kit to embed XUL or Gecko into other applications.
       
   136 
       
   137 %if %localize
       
   138 
       
   139 %package translations-common
       
   140 Summary:        Common translations for XULRunner
       
   141 Group:          System/Localization
       
   142 Requires:       %{name} = %{version}
       
   143 Provides:       locale(%{name}:ar;ca;cs;da;de;en_GB;es_AR;es_CL;es_ES;fi;fr;hu;it;ja;ko;nb_NO;nl;pl;pt_BR;pt_PT;ru;sv_SE;zh_CN;zh_TW)
       
   144 Obsoletes:      %{name}-translations < %{version}-%{release}
       
   145 
       
   146 %description translations-common
       
   147 XULRunner is a single installable package that can be used to bootstrap
       
   148 multiple XUL+XPCOM applications that are as rich as Firefox and
       
   149 Thunderbird.
       
   150 
       
   151 This package contains the most common languages but en-US which is
       
   152 delivered in the main package.
       
   153 
       
   154 
       
   155 %package translations-other
       
   156 Summary:        Extra translations for XULRunner
       
   157 Group:          System/Localization
       
   158 Requires:       %{name} = %{version}
       
   159 Provides:       locale(%{name}:ach;af;ak;as;ast;be;bg;bn_BD;bn_IN;br;bs;csb;cy;el;en_ZA;eo;es_MX;et;eu;fa;ff;fy_NL;ga_IE;gd;gl;gu_IN;he;hi_IN;hr;hy_AM;id;is;kk;km;kn;ku;lg;lij;lt;lv;mai;mk;ml;mr;nn_NO;nso;or;pa_IN;rm;ro;si;sk;sl;son;sq;sr;ta;ta_LK;te;th;tr;uk;vi;zu)
       
   160 Obsoletes:      %{name}-translations < %{version}-%{release}
       
   161 
       
   162 %description translations-other
       
   163 XULRunner is a single installable package that can be used to bootstrap
       
   164 multiple XUL+XPCOM applications that are as rich as Firefox and
       
   165 Thunderbird.
       
   166 
       
   167 This package contains rarely used languages.
       
   168 %endif
       
   169 
       
   170 %if %crashreporter
       
   171 
       
   172 %package buildsymbols
       
   173 Summary:        Breakpad buildsymbols for %{name}
       
   174 Group:          Development/Debug
       
   175 
       
   176 %description buildsymbols
       
   177 This subpackage contains the Breakpad created and compatible debugging
       
   178 symbols meant for upload to Mozilla's crash collector database.
       
   179 %endif
       
   180 
       
   181 %prep
       
   182 %setup -n mozilla -q -b 1 -b 9
       
   183 %patch1 -p1
       
   184 %patch2 -p1
       
   185 %patch3 -p1
       
   186 %patch4 -p1
       
   187 %patch5 -p1
       
   188 %patch6 -p1
       
   189 %patch7 -p1
       
   190 %if %suse_version < 1120
       
   191 %patch9 -p1
       
   192 %endif
       
   193 %patch14 -p1
       
   194 
       
   195 %build
       
   196 # no need to add build time to binaries
       
   197 modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/%{name}.changes")"
       
   198 DATE="\"$(date -d "${modified}" "+%%b %%e %%Y")\""
       
   199 TIME="\"$(date -d "${modified}" "+%%R")\""
       
   200 find . -regex ".*\.c\|.*\.cpp\|.*\.h" -exec sed -i "s/__DATE__/${DATE}/g;s/__TIME__/${TIME}/g" {} +
       
   201 #
       
   202 MOZ_APP_DIR=%{_libdir}/xulrunner-%{version_internal}
       
   203 export MOZ_BUILD_DATE=%{releasedate}
       
   204 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
       
   205 %ifarch ppc64
       
   206 export CFLAGS="$CFLAGS -mminimal-toc"
       
   207 %endif
       
   208 export LDFLAGS=" -Wl,-rpath -Wl,${MOZ_APP_DIR}"
       
   209 %ifarch %arm
       
   210 # debug symbols require too much memory during build
       
   211 export CFLAGS="${CFLAGS/-g/}"
       
   212 LDFLAGS+="-Wl,--reduce-memory-overheads -Wl,--no-keep-memory"
       
   213 %endif
       
   214 export CXXFLAGS="$CFLAGS"
       
   215 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
       
   216 export MOZILLA_OFFICIAL=1
       
   217 export BUILD_OFFICIAL=1
       
   218 export MOZ_MILESTONE_RELEASE=1
       
   219 #
       
   220 cat << EOF > $MOZCONFIG
       
   221 mk_add_options MOZILLA_OFFICIAL=1
       
   222 mk_add_options BUILD_OFFICIAL=1
       
   223 mk_add_options MOZ_MILESTONE_RELEASE=1
       
   224 mk_add_options MOZ_MAKE_FLAGS=%{?jobs:-j%jobs}
       
   225 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../obj
       
   226 . \$topsrcdir/xulrunner/config/mozconfig
       
   227 ac_add_options --prefix=%{_prefix}
       
   228 ac_add_options --libdir=%{_libdir}
       
   229 ac_add_options --sysconfdir=%{_sysconfdir}
       
   230 ac_add_options --mandir=%{_mandir}
       
   231 ac_add_options --includedir=%{_includedir}
       
   232 ac_add_options --enable-optimize
       
   233 ac_add_options --enable-extensions=default
       
   234 #ac_add_options --with-system-jpeg # mozilla uses internal libjpeg-turbo now
       
   235 #ac_add_options --with-system-png  # no APNG support
       
   236 ac_add_options --with-system-zlib
       
   237 ac_add_options --with-l10n-base=$RPM_BUILD_DIR/l10n
       
   238 ac_add_options --disable-tests
       
   239 ac_add_options --disable-mochitest
       
   240 ac_add_options --disable-installer
       
   241 ac_add_options --disable-updater
       
   242 ac_add_options --disable-javaxpcom
       
   243 ac_add_options --enable-system-hunspell
       
   244 ac_add_options --enable-startup-notification
       
   245 ac_add_options --enable-shared-js
       
   246 ac_add_options --disable-webrtc   # does not build with system NSPR
       
   247 #ac_add_options --enable-debug
       
   248 EOF
       
   249 %if %suse_version > 1130
       
   250 cat << EOF >> $MOZCONFIG
       
   251 ac_add_options --disable-gnomevfs
       
   252 ac_add_options --enable-gio
       
   253 EOF
       
   254 %endif
       
   255 %if %has_system_nspr
       
   256 cat << EOF >> $MOZCONFIG
       
   257 ac_add_options --with-system-nspr
       
   258 EOF
       
   259 %endif
       
   260 %if %has_system_nss
       
   261 cat << EOF >> $MOZCONFIG
       
   262 ac_add_options --with-system-nss
       
   263 EOF
       
   264 %endif
       
   265 %if %has_system_cairo
       
   266 cat << EOF >> $MOZCONFIG
       
   267 ac_add_options --enable-system-cairo
       
   268 EOF
       
   269 %endif
       
   270 %if %suse_version > 1110
       
   271 cat << EOF >> $MOZCONFIG
       
   272 ac_add_options --enable-libproxy
       
   273 EOF
       
   274 %endif
       
   275 %if ! %crashreporter
       
   276 cat << EOF >> $MOZCONFIG
       
   277 ac_add_options --disable-crashreporter
       
   278 EOF
       
   279 %endif
       
   280 # S/390
       
   281 %ifarch s390 s390x
       
   282 cat << EOF >> $MOZCONFIG
       
   283 ac_add_options --disable-jemalloc
       
   284 EOF
       
   285 %endif
       
   286 # ARM
       
   287 %ifarch %arm
       
   288 cat << EOF >> $MOZCONFIG
       
   289 %ifarch armv7l armv7hl
       
   290 ac_add_options --with-arch=armv7-a
       
   291 ac_add_options --with-float-abi=hard
       
   292 ac_add_options --with-fpu=vfpv3-d16
       
   293 ac_add_options --with-thumb=yes
       
   294 ac_add_options --disable-debug
       
   295 %endif
       
   296 %ifarch armv5tel
       
   297 ac_add_options --with-arch=armv5te
       
   298 ac_add_options --with-float-abi=soft
       
   299 ac_add_options --with-thumb=no
       
   300 %endif
       
   301 EOF
       
   302 %endif
       
   303 make -f client.mk build
       
   304 
       
   305 %install
       
   306 cd ../obj
       
   307 # preferences (to package in omni.jar)
       
   308 cp %{SOURCE4} dist/bin/defaults/pref/all-openSUSE.js
       
   309 %makeinstall STRIP=/bin/true
       
   310 # xpt.py is not executable
       
   311 chmod a+x $RPM_BUILD_ROOT%{_libdir}/xulrunner-devel-%{version_internal}/sdk/bin/*.py
       
   312 # remove some executable permissions
       
   313 find $RPM_BUILD_ROOT%{_includedir}/xulrunner-%{version_internal} \
       
   314      -type f -perm -111 -exec chmod a-x {} \;
       
   315 find $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/ \
       
   316      -name "*.js" -o -name "*.xpm" -o -name "*.png" | xargs chmod a-x
       
   317 # remove mkdir.done files from installed base
       
   318 find $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal} -name ".mkdir.done" | xargs rm
       
   319 mkdir -p $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/extensions
       
   320 # fixing SDK dynamic libs (symlink instead of copy)
       
   321 rm $RPM_BUILD_ROOT%{_libdir}/xulrunner-devel-%{version_internal}/sdk/lib/*.so
       
   322 ln -sf ../../../xulrunner-%{version_internal}/libmozjs.so \
       
   323        $RPM_BUILD_ROOT%{_libdir}/xulrunner-devel-%{version_internal}/sdk/lib/
       
   324 ln -sf ../../../xulrunner-%{version_internal}/libxpcom.so \
       
   325        $RPM_BUILD_ROOT%{_libdir}/xulrunner-devel-%{version_internal}/sdk/lib/
       
   326 ln -sf ../../../xulrunner-%{version_internal}/libxul.so \
       
   327        $RPM_BUILD_ROOT%{_libdir}/xulrunner-devel-%{version_internal}/sdk/lib/
       
   328 # include basic buildenv for xulapps to use
       
   329 mkdir -p $RPM_BUILD_ROOT%{_datadir}/xulrunner-%{version_internal}
       
   330 pushd ..
       
   331 # this list has been compiled by trial and error for prism
       
   332 tar --exclude=*.cpp --exclude=*.mm \
       
   333    -cvjf $RPM_BUILD_ROOT%{_datadir}/xulrunner-%{version_internal}/mozilla-src.tar.bz2 \
       
   334     mozilla/configure.in mozilla/Makefile.in mozilla/client.py mozilla/allmakefiles.sh \
       
   335     mozilla/config mozilla/client.mk mozilla/aclocal.m4 mozilla/build mozilla/js/src/* \
       
   336     mozilla/testing mozilla/toolkit/mozapps/installer mozilla/probes mozilla/memory \
       
   337     mozilla/toolkit/xre mozilla/nsprpub/config mozilla/tools mozilla/xpcom/build
       
   338 popd
       
   339 # install add-plugins.sh
       
   340 sed "s:%%PROGDIR:%{_libdir}/xulrunner-%{version_internal}:g" \
       
   341   %{SOURCE5} > $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/add-plugins.sh
       
   342 chmod 755 $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/add-plugins.sh
       
   343 # ghosts
       
   344 touch $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/global.reginfo
       
   345 # install additional locales
       
   346 %if %localize
       
   347 rm -f %{_tmppath}/translations.*
       
   348 touch %{_tmppath}/translations.{common,other}
       
   349 for locale in $(awk '{ print $1; }' ../mozilla/browser/locales/shipped-locales); do
       
   350   case $locale in
       
   351    ja-JP-mac|en-US)
       
   352       ;;
       
   353    *)
       
   354       pushd $RPM_BUILD_DIR/compare-locales
       
   355       PYTHONPATH=lib \
       
   356         scripts/compare-locales -m ../l10n-merged/$locale \
       
   357 	../mozilla/toolkit/locales/l10n.ini ../l10n $locale
       
   358       popd
       
   359       LOCALE_MERGEDIR=$RPM_BUILD_DIR/l10n-merged/$locale \
       
   360       make -C toolkit/locales langpack-$locale
       
   361       cp dist/xpi-stage/locale-$locale \
       
   362          $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/extensions/langpack-$locale@firefox.mozilla.org
       
   363       # remove prefs and profile defaults from langpack
       
   364       rm -rf $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/extensions/langpack-$locale@firefox.mozilla.org/defaults
       
   365       # check against the fixed common list and sort into the right filelist
       
   366       _matched=0
       
   367       for _match in ar ca cs da de en-GB es-AR es-CL es-ES fi fr hu it ja ko nb-NO nl pl pt-BR pt-PT ru sv-SE zh-CN zh-TW; do
       
   368         [ "$_match" = "$locale" ] && _matched=1
       
   369       done
       
   370       [ $_matched -eq 1 ] && _l10ntarget=common || _l10ntarget=other
       
   371       echo %{_libdir}/xulrunner-%{version_internal}/extensions/langpack-$locale@firefox.mozilla.org \ \
       
   372          >> %{_tmppath}/translations.$_l10ntarget
       
   373   esac
       
   374 done
       
   375 %endif
       
   376 # API symlink
       
   377 ln -sf xulrunner-%{version_internal} $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{apiversion}
       
   378 # compat links
       
   379 %if 0%{?ga_version:1}
       
   380 touch $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{ga_version}
       
   381 %endif
       
   382 # excludes
       
   383 %if %suse_version < 1120
       
   384 rm -f $RPM_BUILD_ROOT%{_bindir}/xulrunner
       
   385 %endif
       
   386 rm -f $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/updater
       
   387 rm -f $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/update.locale
       
   388 rm -f $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/LICENSE
       
   389 rm -f $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/README.txt
       
   390 rm -f $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/dictionaries/en-US*
       
   391 rm -f $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/nspr-config
       
   392 rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/mozilla-plugin.pc
       
   393 # fdupes
       
   394 %fdupes $RPM_BUILD_ROOT%{_includedir}/xulrunner-%{version_internal}/
       
   395 %fdupes $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/
       
   396 # create breakpad debugsymbols
       
   397 %if %crashreporter
       
   398 SYMBOLS_NAME="xulrunner-%{version}-%{release}.%{_arch}-%{suse_version}-symbols"
       
   399 make buildsymbols \
       
   400   SYMBOL_INDEX_NAME="$SYMBOLS_NAME.txt" \
       
   401   SYMBOL_FULL_ARCHIVE_BASENAME="$SYMBOLS_NAME-full" \
       
   402   SYMBOL_ARCHIVE_BASENAME="$SYMBOLS_NAME"
       
   403 if [ -e dist/*symbols.zip ]; then
       
   404   mkdir -p $RPM_BUILD_ROOT%{_datadir}/mozilla/
       
   405   cp dist/*symbols.zip $RPM_BUILD_ROOT%{_datadir}/mozilla/
       
   406 fi
       
   407 %endif
       
   408 
       
   409 %clean
       
   410 rm -rf $RPM_BUILD_ROOT
       
   411 %if %localize
       
   412 rm -rf %{_tmppath}/translations.*
       
   413 %endif
       
   414 
       
   415 %post
       
   416 /usr/sbin/update-alternatives --install %{_bindir}/xulrunner \
       
   417   xulrunner %{_libdir}/xulrunner-%{apiversion}/xulrunner %{uaweight} || :
       
   418 %{_libdir}/xulrunner-%{apiversion}/add-plugins.sh > /dev/null 2>&1
       
   419 exit 0
       
   420 
       
   421 %posttrans
       
   422 # needed for updates which transition directory to symlink
       
   423 %if 0%{?ga_version:1}
       
   424 test -d %{_libdir}/xulrunner-%{ga_version} && rm -rf %{_libdir}/xulrunner-%{ga_version}
       
   425 ln -sf xulrunner-%{version_internal} %{_libdir}/xulrunner-%{ga_version}
       
   426 %endif
       
   427 [ -e %{_libdir}/xulrunner-%{version_internal}/add-plugins.sh ] && \
       
   428   %{_libdir}/xulrunner-%{version_internal}/add-plugins.sh > /dev/null 2>&1
       
   429 exit 0
       
   430 
       
   431 %preun
       
   432 if [ "$1" = "0" ]; then # deinstallation
       
   433   # that's not quite nice since old versions should be removed on update as well
       
   434   # but that's problematic for updates w/o raising the version number
       
   435   /usr/sbin/update-alternatives --remove xulrunner %{_libdir}/xulrunner-%{apiversion}/xulrunner
       
   436 fi
       
   437 rm -f %{_libdir}/xulrunner-%{version_internal}/dictionaries/*
       
   438 exit 0
       
   439 
       
   440 %triggerin -- myspell-dictionary
       
   441 %{_libdir}/xulrunner-%{version_internal}/add-plugins.sh > /dev/null 2>&1
       
   442 exit 0
       
   443 
       
   444 %triggerpostun -- myspell-dictionary
       
   445 %{_libdir}/xulrunner-%{version_internal}/add-plugins.sh > /dev/null 2>&1
       
   446 exit 0
       
   447 
       
   448 %files
       
   449 %defattr(-,root,root)
       
   450 %dir %{_libdir}/xulrunner-%{version_internal}/
       
   451 %dir %{_libdir}/xulrunner-%{version_internal}/chrome/
       
   452 %dir %{_libdir}/xulrunner-%{version_internal}/dictionaries/
       
   453 %dir %{_libdir}/xulrunner-%{version_internal}/extensions/
       
   454 %{_libdir}/xulrunner-%{version_internal}/chrome/icons/
       
   455 %{_libdir}/xulrunner-%{version_internal}/components/
       
   456 %{_libdir}/xulrunner-%{version_internal}/plugins/
       
   457 %{_libdir}/xulrunner-%{version_internal}/*.so
       
   458 %exclude %{_libdir}/xulrunner-%{version_internal}/libmozjs.so
       
   459 %{_libdir}/xulrunner-%{version_internal}/add-plugins.sh
       
   460 %{_libdir}/xulrunner-%{version_internal}/chrome.manifest
       
   461 %{_libdir}/xulrunner-%{version_internal}/dependentlibs.list
       
   462 %{_libdir}/xulrunner-%{version_internal}/mozilla-xremote-client
       
   463 %{_libdir}/xulrunner-%{version_internal}/plugin-container
       
   464 %{_libdir}/xulrunner-%{version_internal}/xulrunner
       
   465 %{_libdir}/xulrunner-%{version_internal}/xulrunner-stub
       
   466 %{_libdir}/xulrunner-%{version_internal}/platform.ini
       
   467 %{_libdir}/xulrunner-%{version_internal}/omni.ja
       
   468 %{_libdir}/xulrunner-%{version_internal}/README.xulrunner
       
   469 # crashreporter files
       
   470 %if %crashreporter
       
   471 %{_libdir}/xulrunner-%{version_internal}/crashreporter
       
   472 %{_libdir}/xulrunner-%{version_internal}/crashreporter.ini
       
   473 %{_libdir}/xulrunner-%{version_internal}/Throbber-small.gif
       
   474 %endif
       
   475 # ghosts
       
   476 %ghost %{_libdir}/xulrunner-%{version_internal}/global.reginfo
       
   477 %if %suse_version >= 1120
       
   478 %ghost %{_bindir}/xulrunner
       
   479 %endif
       
   480 # API symlink (already in mozilla-js)
       
   481 #%{_libdir}/xulrunner-%{apiversion}
       
   482 # compat symlinks
       
   483 %if 0%{?ga_version:1}
       
   484 %ghost %{_libdir}/xulrunner-%{ga_version}
       
   485 %endif
       
   486 
       
   487 %files -n mozilla-js
       
   488 %defattr(-,root,root)
       
   489 %dir %{_libdir}/xulrunner-%{version_internal}/
       
   490 %{_libdir}/xulrunner-%{apiversion}
       
   491 %{_libdir}/xulrunner-%{version_internal}/libmozjs.so
       
   492 
       
   493 %files devel
       
   494 %defattr(-,root,root)
       
   495 %{_libdir}/xulrunner-devel-%{version_internal}/
       
   496 # FIXME symlink dynamic libs below sdk/lib
       
   497 %attr(644,root,root) %{_libdir}/pkgconfig/*
       
   498 %{_includedir}/xulrunner-%{version_internal}/
       
   499 %{_datadir}/xulrunner-%{version_internal}/
       
   500 
       
   501 %if %localize
       
   502 
       
   503 %files translations-common -f %{_tmppath}/translations.common
       
   504 %defattr(-,root,root)
       
   505 %dir %{_libdir}/xulrunner-%{version_internal}/
       
   506 %dir %{_libdir}/xulrunner-%{version_internal}/chrome/
       
   507 
       
   508 %files translations-other -f %{_tmppath}/translations.other
       
   509 %defattr(-,root,root)
       
   510 %dir %{_libdir}/xulrunner-%{version_internal}/
       
   511 %dir %{_libdir}/xulrunner-%{version_internal}/chrome/
       
   512 %endif
       
   513 
       
   514 %if %crashreporter
       
   515 
       
   516 %files buildsymbols
       
   517 %defattr(-,root,root)
       
   518 %{_datadir}/mozilla/
       
   519 %endif
       
   520 
       
   521 %changelog