MozillaFirefox/MozillaFirefox.spec
changeset 708 f15494a6dc10
parent 707 bfa2e0576454
child 710 5341dc98d26c
equal deleted inserted replaced
707:bfa2e0576454 708:f15494a6dc10
   316 ac_add_options --disable-tests
   316 ac_add_options --disable-tests
   317 ac_add_options --disable-debug
   317 ac_add_options --disable-debug
   318 ac_add_options --enable-startup-notification
   318 ac_add_options --enable-startup-notification
   319 #ac_add_options --enable-chrome-format=jar
   319 #ac_add_options --enable-chrome-format=jar
   320 ac_add_options --enable-update-channel=%{update_channel}
   320 ac_add_options --enable-update-channel=%{update_channel}
   321 EOF
       
   322 %if %suse_version > 1130
   321 %if %suse_version > 1130
   323 ac_add_options --disable-gnomevfs
   322 ac_add_options --disable-gnomevfs
   324 ac_add_options --enable-gio
   323 ac_add_options --enable-gio
   325 %endif
   324 %endif
   326 %if %suse_version < 1220
   325 %if %suse_version < 1220
   335 %if ! %crashreporter
   334 %if ! %crashreporter
   336 ac_add_options --disable-crashreporter
   335 ac_add_options --disable-crashreporter
   337 %endif
   336 %endif
   338 # Disable neon for arm as it does not build correctly
   337 # Disable neon for arm as it does not build correctly
   339 %ifarch %arm
   338 %ifarch %arm
   340 cat << EOF >> $MOZCONFIG
       
   341 ac_add_options --disable-neon
   339 ac_add_options --disable-neon
   342 EOF
       
   343 %endif
   340 %endif
   344 %ifnarch %ix86 x86_64
   341 %ifnarch %ix86 x86_64
   345 ac_add_options --disable-webrtc
   342 ac_add_options --disable-webrtc
   346 %endif
   343 %endif
       
   344 EOF
   347 make -f client.mk build
   345 make -f client.mk build
   348 
   346 
   349 %install
   347 %install
   350 cd $RPM_BUILD_DIR/obj
   348 cd $RPM_BUILD_DIR/obj
   351 source %{SOURCE5}
   349 source %{SOURCE5}