xulrunner/xulrunner.spec
changeset 325 f5966ab369fb
child 334 1256d8842872
equal deleted inserted replaced
316:a5e121de2e2f 325:f5966ab369fb
       
     1 #
       
     2 # spec file for package xulrunner
       
     3 #
       
     4 # Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
       
     5 #               2006-2011 Wolfgang Rosenauer
       
     6 #
       
     7 # All modifications and additions to the file contributed by third parties
       
     8 # remain the property of their copyright owners, unless otherwise agreed
       
     9 # upon. The license for this file, and modifications and additions to the
       
    10 # file, is the same license as for the pristine package itself (unless the
       
    11 # license for the pristine package is not an Open Source License, in which
       
    12 # case the license is the MIT License). An "Open Source License" is a
       
    13 # license that conforms to the Open Source Definition (Version 1.9)
       
    14 # published by the Open Source Initiative.
       
    15 
       
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
       
    17 #
       
    18 
       
    19 # norootforbuild
       
    20 
       
    21 
       
    22 Name:           xulrunner
       
    23 BuildRequires:  Mesa-devel autoconf213 dbus-1-glib-devel fdupes gcc-c++ hunspell-devel libcurl-devel libgnomeui-devel libidl-devel libnotify-devel python startup-notification-devel unzip pkg-config yasm nss-shared-helper-devel zip
       
    24 %if %suse_version > 1110
       
    25 BuildRequires:  libiw-devel
       
    26 BuildRequires:  libproxy-devel
       
    27 %else
       
    28 BuildRequires:  wireless-tools
       
    29 %endif
       
    30 BuildRequires:  mozilla-nspr-devel >= 4.8.8
       
    31 BuildRequires:  mozilla-nss-devel >= 3.12.10
       
    32 License:        MPLv1.1 or GPLv2+ or LGPLv2+
       
    33 Version:        6.99
       
    34 Release:        1
       
    35 %define         releasedate 2011091300
       
    36 %define         version_internal 7.0b5
       
    37 %define         apiversion 7
       
    38 %define         uaweight 700000
       
    39 Summary:        Mozilla Runtime Environment
       
    40 Url:            http://www.mozilla.org/
       
    41 Group:          Productivity/Other
       
    42 Provides:       gecko
       
    43 %ifarch %ix86
       
    44 Provides:       xulrunner-32bit = %{version}-%{release}
       
    45 %endif
       
    46 Source:         xulrunner-%{version}-source.tar.bz2
       
    47 Source1:        l10n-%{version}.tar.bz2
       
    48 Source2:        find-external-requires.sh
       
    49 Source3:        %{name}-rpmlintrc
       
    50 Source4:        xulrunner-openSUSE-prefs.js
       
    51 Source5:        add-plugins.sh.in
       
    52 Source6:        create-tar.sh
       
    53 Source7:        baselibs.conf
       
    54 Source9:        compare-locales.tar.bz2
       
    55 Patch1:         toolkit-download-folder.patch
       
    56 Patch2:         mozilla-pkgconfig.patch
       
    57 Patch3:         idldir.patch
       
    58 Patch4:         mozilla-nongnome-proxies.patch
       
    59 Patch5:         mozilla-prefer_plugin_pref.patch
       
    60 Patch8:         mozilla-cairo-lcd.patch
       
    61 Patch9:         mozilla-language.patch
       
    62 Patch10:        mozilla-cairo-return.patch
       
    63 Patch11:        mozilla-ntlm-full-path.patch
       
    64 Patch12:        mozilla-dump_syms-static.patch
       
    65 Patch13:        mozilla-sle11.patch
       
    66 Patch14:        mozilla-linux3.patch
       
    67 Patch15:        mozilla-curl.patch
       
    68 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
       
    69 Requires:       mozilla-js = %{version}
       
    70 Requires(post):  update-alternatives coreutils
       
    71 Requires(preun): update-alternatives coreutils
       
    72 ### build configuration ###
       
    73 %define has_system_nspr  1
       
    74 %define has_system_nss   1
       
    75 %define has_system_cairo 0
       
    76 %define localize 0
       
    77 %ifarch ppc ppc64 s390 s390x ia64
       
    78 %define crashreporter    0
       
    79 %define plugincontainer  0
       
    80 %else
       
    81 %define crashreporter    1
       
    82 %define plugincontainer  1
       
    83 %endif
       
    84 ### configuration end ###
       
    85 %define _use_internal_dependency_generator 0
       
    86 %define __find_requires sh %{SOURCE2}
       
    87 %global provfind sh -c "grep -Ev 'mozsqlite3|dbusservice|unixprint' | %__find_provides"
       
    88 %global __find_provides %provfind
       
    89 %if %has_system_nspr
       
    90 Requires:       mozilla-nspr >= %(rpm -q --queryformat '%{VERSION}' mozilla-nspr)
       
    91 %endif
       
    92 %if %has_system_nss
       
    93 Requires:       mozilla-nss >= %(rpm -q --queryformat '%{VERSION}' mozilla-nss)
       
    94 %endif
       
    95 
       
    96 %description
       
    97 XULRunner is a single installable package that can be used to bootstrap
       
    98 multiple XUL+XPCOM applications that are as rich as Firefox and
       
    99 Thunderbird.
       
   100 
       
   101 
       
   102 %package -n mozilla-js
       
   103 License:        MPLv1.1 or GPLv2+ or LGPLv2+
       
   104 Summary:        Mozilla JS engine
       
   105 Group:          Productivity/Other
       
   106 
       
   107 %description -n mozilla-js
       
   108 JavaScript is the Netscape-developed object scripting language used in millions
       
   109 of web pages and server applications worldwide. Netscape's JavaScript is a
       
   110 superset of the ECMA-262 Edition 3 (ECMAScript) standard scripting language,
       
   111 with only mild differences from the published standard.
       
   112 
       
   113 
       
   114 %package devel
       
   115 License:        MPLv1.1 or GPLv2+ or LGPLv2+
       
   116 Summary:        XULRunner/Gecko SDK
       
   117 Group:          Development/Libraries/Other
       
   118 %if %has_system_nspr
       
   119 Requires:       mozilla-nspr-devel >= %(rpm -q --queryformat '%{VERSION}' mozilla-nspr-devel)
       
   120 %endif
       
   121 %if %has_system_nss
       
   122 Requires:       mozilla-nss-devel >= %(rpm -q --queryformat '%{VERSION}' mozilla-nss-devel)
       
   123 %endif
       
   124 Requires:       %{name} = %{version}
       
   125 
       
   126 %description devel
       
   127 Software Development Kit to embed XUL or Gecko into other applications.
       
   128 
       
   129 %if %localize
       
   130 %package translations-common
       
   131 License:        MPLv1.1 or GPLv2+ or LGPLv2+
       
   132 Summary:        Common translations for XULRunner
       
   133 Group:          System/Localization
       
   134 Requires:       %{name} = %{version}
       
   135 Provides:       locale(%{name}:ar;ca;cs;da;de;en_GB;es_AR;es_CL;es_ES;fi;fr;hu;it;ja;ko;nb_NO;nl;pl;pt_BR;pt_PT;ru;sv_SE;zh_CN;zh_TW)
       
   136 Obsoletes:      %{name}-translations < %{version}-%{release}
       
   137 
       
   138 %description translations-common
       
   139 XULRunner is a single installable package that can be used to bootstrap
       
   140 multiple XUL+XPCOM applications that are as rich as Firefox and
       
   141 Thunderbird.
       
   142 
       
   143 This package contains the most common languages but en-US which is
       
   144 delivered in the main package.
       
   145 
       
   146 
       
   147 %package translations-other
       
   148 License:        MPLv1.1 or GPLv2+ or LGPLv2+
       
   149 Summary:        Extra translations for XULRunner
       
   150 Group:          System/Localization
       
   151 Requires:       %{name} = %{version}
       
   152 Provides:       locale(%{name}:af;ak;ast;be;bg;bn_BD;br;bs;cy;el;en_ZA;eo;es_MX;et;eu;fa;fy_NL;ga_IE;gd;gl;gu_IN;he;hi_IN;hr;hy_AM;id;is;kk;kn;ku;lg;lt;lv;mai;mk;ml;mr;nn_NO;nso;or;pa_IN;rm;ro;si;sk;sl;son;sq;sr;ta;ta_LK;te;th;tr;uk;zu)
       
   153 Obsoletes:      %{name}-translations < %{version}-%{release}
       
   154 
       
   155 %description translations-other
       
   156 XULRunner is a single installable package that can be used to bootstrap
       
   157 multiple XUL+XPCOM applications that are as rich as Firefox and
       
   158 Thunderbird.
       
   159 
       
   160 This package contains rarely used languages.
       
   161 %endif
       
   162 
       
   163 
       
   164 %if %crashreporter
       
   165 %package buildsymbols
       
   166 License:        MPLv1.1 or GPLv2+ or LGPLv2+
       
   167 Summary:        Breakpad buildsymbols for %{name}
       
   168 Group:          Development/Debug
       
   169 
       
   170 %description buildsymbols
       
   171 This subpackage contains the Breakpad created and compatible debugging
       
   172 symbols meant for upload to Mozilla's crash collector database.
       
   173 %endif
       
   174 
       
   175 %prep
       
   176 %setup -n mozilla -q -b 1 -b 9
       
   177 %patch1 -p1
       
   178 %patch2 -p1
       
   179 %patch3 -p1
       
   180 %patch4 -p1
       
   181 %patch5 -p1
       
   182 %patch8 -p1
       
   183 %patch9 -p1
       
   184 %patch10 -p1
       
   185 %patch11 -p1
       
   186 %patch12 -p1
       
   187 %if %suse_version < 1120
       
   188 %patch13 -p1
       
   189 %endif
       
   190 %patch14 -p1
       
   191 %patch15 -p1
       
   192 
       
   193 
       
   194 %build
       
   195 # no need to add build time to binaries
       
   196 modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/%{name}.changes")"
       
   197 DATE="\"$(date -d "${modified}" "+%%b %%e %%Y")\""
       
   198 TIME="\"$(date -d "${modified}" "+%%R")\""
       
   199 find . -regex ".*\.c\|.*\.cpp\|.*\.h" -exec sed -i "s/__DATE__/${DATE}/g;s/__TIME__/${TIME}/g" {} +
       
   200 #
       
   201 MOZ_APP_DIR=%{_libdir}/xulrunner-%{version_internal}
       
   202 export MOZ_BUILD_DATE=%{releasedate}
       
   203 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
       
   204 %ifarch ppc64
       
   205 export CFLAGS="$CFLAGS -mminimal-toc"
       
   206 %endif
       
   207 export CXXFLAGS="$CFLAGS"
       
   208 export LDFLAGS="-Wl,-rpath -Wl,${MOZ_APP_DIR}"
       
   209 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
       
   210 export MOZILLA_OFFICIAL=1
       
   211 export BUILD_OFFICIAL=1
       
   212 export MOZ_MILESTONE_RELEASE=1
       
   213 #
       
   214 cat << EOF > $MOZCONFIG
       
   215 mk_add_options MOZILLA_OFFICIAL=1
       
   216 mk_add_options BUILD_OFFICIAL=1
       
   217 mk_add_options MOZ_MILESTONE_RELEASE=1
       
   218 mk_add_options MOZ_MAKE_FLAGS=%{?jobs:-j%jobs}
       
   219 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../obj
       
   220 . \$topsrcdir/xulrunner/config/mozconfig
       
   221 ac_add_options --prefix=%{_prefix}
       
   222 ac_add_options --libdir=%{_libdir}
       
   223 ac_add_options --sysconfdir=%{_sysconfdir}
       
   224 ac_add_options --mandir=%{_mandir}
       
   225 ac_add_options --includedir=%{_includedir}
       
   226 ac_add_options --enable-optimize
       
   227 ac_add_options --enable-extensions=default
       
   228 #ac_add_options --with-system-jpeg # mozilla uses internal libjpeg-turbo now
       
   229 #ac_add_options --with-system-png  # no APNG support
       
   230 ac_add_options --with-system-zlib
       
   231 ac_add_options --with-l10n-base=$RPM_BUILD_DIR/l10n
       
   232 ac_add_options --disable-tests
       
   233 ac_add_options --disable-mochitest
       
   234 ac_add_options --disable-installer
       
   235 ac_add_options --disable-updater
       
   236 ac_add_options --disable-javaxpcom
       
   237 ac_add_options --enable-system-hunspell
       
   238 ac_add_options --enable-startup-notification
       
   239 ac_add_options --enable-shared-js
       
   240 #ac_add_options --enable-debug
       
   241 EOF
       
   242 %if %suse_version > 1130
       
   243 cat << EOF >> $MOZCONFIG
       
   244 ac_add_options --disable-gnomevfs
       
   245 ac_add_options --enable-gio
       
   246 EOF
       
   247 %endif
       
   248 %if %has_system_nspr
       
   249 cat << EOF >> $MOZCONFIG
       
   250 ac_add_options --with-system-nspr
       
   251 EOF
       
   252 %endif
       
   253 %if %has_system_nss
       
   254 cat << EOF >> $MOZCONFIG
       
   255 ac_add_options --with-system-nss
       
   256 EOF
       
   257 %endif
       
   258 %if %has_system_cairo
       
   259 cat << EOF >> $MOZCONFIG
       
   260 ac_add_options --enable-system-cairo
       
   261 EOF
       
   262 %endif
       
   263 %if %suse_version > 1110
       
   264 cat << EOF >> $MOZCONFIG
       
   265 ac_add_options --enable-libproxy
       
   266 EOF
       
   267 %endif
       
   268 %if ! %crashreporter
       
   269 cat << EOF >> $MOZCONFIG
       
   270 ac_add_options --disable-crashreporter
       
   271 EOF
       
   272 %endif
       
   273 %if ! %plugincontainer
       
   274 cat << EOF >> $MOZCONFIG
       
   275 # Chromium IPC is not ported to Power,S/390 and Itanium (currently just x86,x86_64 and arm)
       
   276 ac_add_options --disable-ipc
       
   277 EOF
       
   278 %endif
       
   279 make -f client.mk build
       
   280 
       
   281 %install
       
   282 cd ../obj
       
   283 # preferences (to package in omni.jar)
       
   284 cp %{SOURCE4} dist/bin/defaults/pref/all-openSUSE.js
       
   285 %makeinstall STRIP=/bin/true
       
   286 # remove some executable permissions
       
   287 find $RPM_BUILD_ROOT%{_includedir}/xulrunner-%{version_internal} \
       
   288      -type f -perm -111 -exec chmod a-x {} \;
       
   289 find $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/ \
       
   290      -name "*.js" -o -name "*.xpm" -o -name "*.png" | xargs chmod a-x
       
   291 mkdir -p $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/extensions
       
   292 # fixing SDK dynamic libs (symlink instead of copy)
       
   293 rm $RPM_BUILD_ROOT%{_libdir}/xulrunner-devel-%{version_internal}/sdk/lib/*.so
       
   294 ln -sf ../../../xulrunner-%{version_internal}/libmozjs.so \
       
   295        $RPM_BUILD_ROOT%{_libdir}/xulrunner-devel-%{version_internal}/sdk/lib/
       
   296 ln -sf ../../../xulrunner-%{version_internal}/libxpcom.so \
       
   297        $RPM_BUILD_ROOT%{_libdir}/xulrunner-devel-%{version_internal}/sdk/lib/
       
   298 ln -sf ../../../xulrunner-%{version_internal}/libxul.so \
       
   299        $RPM_BUILD_ROOT%{_libdir}/xulrunner-devel-%{version_internal}/sdk/lib/
       
   300 # include basic buildenv for xulapps to use
       
   301 mkdir -p $RPM_BUILD_ROOT%{_datadir}/xulrunner-%{version_internal}
       
   302 pushd ..
       
   303 # this list has been compiled by trial and error for prism
       
   304 tar --exclude=*.cpp --exclude=*.mm \
       
   305    -cvjf $RPM_BUILD_ROOT%{_datadir}/xulrunner-%{version_internal}/mozilla-src.tar.bz2 \
       
   306     mozilla/configure.in mozilla/Makefile.in mozilla/client.py mozilla/allmakefiles.sh \
       
   307     mozilla/config mozilla/client.mk mozilla/aclocal.m4 mozilla/build mozilla/js/src/* \
       
   308     mozilla/testing mozilla/toolkit/mozapps/installer mozilla/probes mozilla/memory \
       
   309     mozilla/toolkit/xre mozilla/nsprpub/config mozilla/tools mozilla/xpcom/build
       
   310 popd
       
   311 # install add-plugins.sh
       
   312 sed "s:%%PROGDIR:%{_libdir}/xulrunner-%{version_internal}:g" \
       
   313   %{SOURCE5} > $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/add-plugins.sh
       
   314 chmod 755 $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/add-plugins.sh
       
   315 # ghosts
       
   316 touch $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/global.reginfo
       
   317 # install additional locales
       
   318 %if %localize
       
   319 rm -f %{_tmppath}/translations.*
       
   320 touch %{_tmppath}/translations.{common,other}
       
   321 for locale in $(awk '{ print $1; }' ../mozilla/browser/locales/shipped-locales); do
       
   322   case $locale in
       
   323    ja-JP-mac|en-US)
       
   324       ;;
       
   325    *)
       
   326       pushd $RPM_BUILD_DIR/compare-locales
       
   327       PYTHONPATH=lib \
       
   328         scripts/compare-locales -m ../l10n-merged/$locale \
       
   329 	../mozilla/toolkit/locales/l10n.ini ../l10n $locale
       
   330       popd
       
   331       LOCALE_MERGEDIR=$RPM_BUILD_DIR/l10n-merged/$locale \
       
   332       make -C toolkit/locales langpack-$locale
       
   333       cp dist/xpi-stage/locale-$locale \
       
   334          $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/extensions/langpack-$locale@firefox.mozilla.org
       
   335       # remove prefs and profile defaults from langpack
       
   336       rm -rf $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/extensions/langpack-$locale@firefox.mozilla.org/defaults
       
   337       # check against the fixed common list and sort into the right filelist
       
   338       _matched=0
       
   339       for _match in ar ca cs da de en-GB es-AR es-CL es-ES fi fr hu it ja ko nb-NO nl pl pt-BR pt-PT ru sv-SE zh-CN zh-TW; do
       
   340         [ "$_match" = "$locale" ] && _matched=1
       
   341       done
       
   342       [ $_matched -eq 1 ] && _l10ntarget=common || _l10ntarget=other
       
   343       echo %{_libdir}/xulrunner-%{version_internal}/extensions/langpack-$locale@firefox.mozilla.org \ \
       
   344          >> %{_tmppath}/translations.$_l10ntarget
       
   345   esac
       
   346 done
       
   347 %endif
       
   348 # API symlink
       
   349 ln -sf xulrunner-%{version_internal} $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{apiversion}
       
   350 # compat links
       
   351 %if 0%{?ga_version:1}
       
   352 touch $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{ga_version}
       
   353 %endif
       
   354 # excludes
       
   355 %if %suse_version < 1120
       
   356 rm -f $RPM_BUILD_ROOT%{_bindir}/xulrunner
       
   357 %endif
       
   358 rm -f $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/updater
       
   359 rm -f $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/update.locale
       
   360 rm -f $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/LICENSE
       
   361 rm -f $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/README.txt
       
   362 rm -f $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/dictionaries/en-US*
       
   363 rm -f $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/nspr-config
       
   364 rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/mozilla-plugin.pc
       
   365 # fdupes
       
   366 %fdupes $RPM_BUILD_ROOT%{_includedir}/xulrunner-%{version_internal}/
       
   367 %fdupes $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/
       
   368 # create breakpad debugsymbols
       
   369 %if %crashreporter
       
   370 SYMBOLS_NAME="xulrunner-%{version}-%{release}.%{_arch}-%{suse_version}-symbols"
       
   371 make buildsymbols \
       
   372   SYMBOL_INDEX_NAME="$SYMBOLS_NAME.txt" \
       
   373   SYMBOL_FULL_ARCHIVE_BASENAME="$SYMBOLS_NAME-full" \
       
   374   SYMBOL_ARCHIVE_BASENAME="$SYMBOLS_NAME"
       
   375 if [ -e dist/*symbols.zip ]; then
       
   376   mkdir -p $RPM_BUILD_ROOT%{_datadir}/mozilla/
       
   377   cp dist/*symbols.zip $RPM_BUILD_ROOT%{_datadir}/mozilla/
       
   378 fi
       
   379 %endif
       
   380 
       
   381 %clean
       
   382 rm -rf $RPM_BUILD_ROOT
       
   383 %if %localize
       
   384 rm -rf %{_tmppath}/translations.*
       
   385 %endif
       
   386 
       
   387 %post
       
   388 /usr/sbin/update-alternatives --install %{_bindir}/xulrunner \
       
   389   xulrunner %{_libdir}/xulrunner-%{apiversion}/xulrunner %{uaweight} || :
       
   390 %{_libdir}/xulrunner-%{apiversion}/add-plugins.sh > /dev/null 2>&1
       
   391 exit 0
       
   392 
       
   393 %posttrans
       
   394 # needed for updates which transition directory to symlink
       
   395 %if 0%{?ga_version:1}
       
   396 test -d %{_libdir}/xulrunner-%{ga_version} && rm -rf %{_libdir}/xulrunner-%{ga_version}
       
   397 ln -sf xulrunner-%{version_internal} %{_libdir}/xulrunner-%{ga_version}
       
   398 %endif
       
   399 [ -e %{_libdir}/xulrunner-%{version_internal}/add-plugins.sh ] && \
       
   400   %{_libdir}/xulrunner-%{version_internal}/add-plugins.sh > /dev/null 2>&1
       
   401 exit 0
       
   402 
       
   403 %preun
       
   404 if [ "$1" = "0" ]; then # deinstallation
       
   405   # that's not quite nice since old versions should be removed on update as well
       
   406   # but that's problematic for updates w/o raising the version number
       
   407   /usr/sbin/update-alternatives --remove xulrunner %{_libdir}/xulrunner-%{apiversion}/xulrunner
       
   408 fi
       
   409 rm -f %{_libdir}/xulrunner-%{version_internal}/dictionaries/*
       
   410 exit 0
       
   411 
       
   412 %triggerin -- myspell-dictionary
       
   413 %{_libdir}/xulrunner-%{version_internal}/add-plugins.sh > /dev/null 2>&1
       
   414 exit 0
       
   415 
       
   416 %triggerpostun -- myspell-dictionary
       
   417 %{_libdir}/xulrunner-%{version_internal}/add-plugins.sh > /dev/null 2>&1
       
   418 exit 0
       
   419 
       
   420 %files
       
   421 %defattr(-,root,root)
       
   422 %dir %{_libdir}/xulrunner-%{version_internal}/
       
   423 %dir %{_libdir}/xulrunner-%{version_internal}/chrome/
       
   424 %dir %{_libdir}/xulrunner-%{version_internal}/dictionaries/
       
   425 %dir %{_libdir}/xulrunner-%{version_internal}/extensions/
       
   426 %{_libdir}/xulrunner-%{version_internal}/chrome/icons/
       
   427 %{_libdir}/xulrunner-%{version_internal}/components/
       
   428 %{_libdir}/xulrunner-%{version_internal}/hyphenation/
       
   429 %{_libdir}/xulrunner-%{version_internal}/icons/
       
   430 %{_libdir}/xulrunner-%{version_internal}/plugins/
       
   431 %{_libdir}/xulrunner-%{version_internal}/*.so
       
   432 %exclude %{_libdir}/xulrunner-%{version_internal}/libmozjs.so
       
   433 %{_libdir}/xulrunner-%{version_internal}/add-plugins.sh
       
   434 %{_libdir}/xulrunner-%{version_internal}/chrome.manifest
       
   435 %{_libdir}/xulrunner-%{version_internal}/dependentlibs.list
       
   436 %{_libdir}/xulrunner-%{version_internal}/mozilla-xremote-client
       
   437 %if %plugincontainer
       
   438 %{_libdir}/xulrunner-%{version_internal}/plugin-container
       
   439 %endif
       
   440 %{_libdir}/xulrunner-%{version_internal}/run-mozilla.sh
       
   441 %{_libdir}/xulrunner-%{version_internal}/xulrunner
       
   442 %{_libdir}/xulrunner-%{version_internal}/xulrunner-bin
       
   443 %{_libdir}/xulrunner-%{version_internal}/xulrunner-stub
       
   444 %{_libdir}/xulrunner-%{version_internal}/platform.ini
       
   445 %{_libdir}/xulrunner-%{version_internal}/omni.jar
       
   446 # crashreporter files
       
   447 %if %crashreporter
       
   448 %{_libdir}/xulrunner-%{version_internal}/crashreporter
       
   449 %{_libdir}/xulrunner-%{version_internal}/crashreporter.ini
       
   450 %{_libdir}/xulrunner-%{version_internal}/Throbber-small.gif
       
   451 %endif
       
   452 # ghosts
       
   453 %ghost %{_libdir}/xulrunner-%{version_internal}/global.reginfo
       
   454 %if %suse_version >= 1120
       
   455 %ghost %{_bindir}/xulrunner
       
   456 %endif
       
   457 # API symlink
       
   458 %{_libdir}/xulrunner-%{apiversion}
       
   459 # compat symlinks
       
   460 %if 0%{?ga_version:1}
       
   461 %ghost %{_libdir}/xulrunner-%{ga_version}
       
   462 %endif
       
   463 
       
   464 %files -n mozilla-js
       
   465 %defattr(-,root,root)
       
   466 %dir %{_libdir}/xulrunner-%{version_internal}/
       
   467 %{_libdir}/xulrunner-%{apiversion}
       
   468 %{_libdir}/xulrunner-%{version_internal}/libmozjs.so
       
   469 
       
   470 %files devel
       
   471 %defattr(-,root,root)
       
   472 %{_libdir}/xulrunner-%{version_internal}/xpcshell
       
   473 %{_libdir}/xulrunner-%{version_internal}/xpidl
       
   474 %{_libdir}/xulrunner-devel-%{version_internal}/
       
   475 # FIXME symlink dynamic libs below sdk/lib
       
   476 %attr(644,root,root) %{_libdir}/pkgconfig/*
       
   477 %{_includedir}/xulrunner-%{version_internal}/
       
   478 %{_datadir}/xulrunner-%{version_internal}/
       
   479 
       
   480 %if %localize
       
   481 %files translations-common -f %{_tmppath}/translations.common
       
   482 %defattr(-,root,root)
       
   483 %dir %{_libdir}/xulrunner-%{version_internal}/
       
   484 %dir %{_libdir}/xulrunner-%{version_internal}/chrome/
       
   485 
       
   486 %files translations-other -f %{_tmppath}/translations.other
       
   487 %defattr(-,root,root)
       
   488 %dir %{_libdir}/xulrunner-%{version_internal}/
       
   489 %dir %{_libdir}/xulrunner-%{version_internal}/chrome/
       
   490 %endif
       
   491 
       
   492 %if %crashreporter
       
   493 %files buildsymbols
       
   494 %defattr(-,root,root)
       
   495 %{_datadir}/mozilla/
       
   496 %endif
       
   497 
       
   498 %changelog