MozillaFirefox/MozillaFirefox.spec
branchfirefox33
changeset 801 f5f6f5547c2b
parent 797 3b2d52457c91
child 802 6c8dd9468bcc
equal deleted inserted replaced
797:3b2d52457c91 801:f5f6f5547c2b
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major 33
    21 %define major 33
    22 %define mainver %major.1
    22 %define mainver %major.1
    23 %define update_channel release
    23 %define update_channel release
    24 %define releasedate 2014103000
    24 %define releasedate 2014110600
    25 
    25 
    26 # general build definitions
    26 # general build definitions
    27 %define firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
    27 %define firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
    28 %define _use_internal_dependency_generator 0
    28 %define _use_internal_dependency_generator 0
    29 %define __find_requires sh %{SOURCE4}
    29 %define __find_requires sh %{SOURCE4}
   298 %ifarch %ix86
   298 %ifarch %ix86
   299 export CFLAGS="${CFLAGS} -Os"
   299 export CFLAGS="${CFLAGS} -Os"
   300 %endif
   300 %endif
   301 %ifarch %arm
   301 %ifarch %arm
   302 export CFLAGS="${CFLAGS/-g / }"
   302 export CFLAGS="${CFLAGS/-g / }"
       
   303 # Limit RAM usage during link
       
   304 +export LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
   303 %endif
   305 %endif
   304 %ifarch ppc64 ppc64le
   306 %ifarch ppc64 ppc64le
   305 export CFLAGS="$CFLAGS -mminimal-toc"
   307 export CFLAGS="$CFLAGS -mminimal-toc"
   306 %endif
   308 %endif
   307 export CXXFLAGS="$CFLAGS"
   309 export CXXFLAGS="$CFLAGS"
   317 ac_add_options --sysconfdir=%{_sysconfdir}
   319 ac_add_options --sysconfdir=%{_sysconfdir}
   318 ac_add_options --mandir=%{_mandir}
   320 ac_add_options --mandir=%{_mandir}
   319 ac_add_options --includedir=%{_includedir}
   321 ac_add_options --includedir=%{_includedir}
   320 ac_add_options --enable-release
   322 ac_add_options --enable-release
   321 ac_add_options --enable-stdcxx-compat
   323 ac_add_options --enable-stdcxx-compat
   322 %ifarch %ix86
   324 %ifarch %ix86 %arm
   323 %if 0%{?suse_version} > 1230
   325 %if 0%{?suse_version} > 1230
   324 ac_add_options --disable-optimize
   326 ac_add_options --disable-optimize
   325 %endif
   327 %endif
   326 %endif
   328 %endif
   327 %ifnarch ppc ppc64 ppc64le
   329 %ifnarch ppc ppc64 ppc64le aarch64
   328 ac_add_options --enable-elf-hack
   330 ac_add_options --enable-elf-hack
   329 %endif
   331 %endif
   330 ac_add_options --with-system-nspr
   332 ac_add_options --with-system-nspr
   331 ac_add_options --with-system-nss
   333 ac_add_options --with-system-nss
   332 %if %{localize}
   334 %if %{localize}
   367 %endif
   369 %endif
   368 %ifnarch %ix86 x86_64
   370 %ifnarch %ix86 x86_64
   369 ac_add_options --disable-webrtc
   371 ac_add_options --disable-webrtc
   370 %endif
   372 %endif
   371 # try to use OpenGL-ES on ARM
   373 # try to use OpenGL-ES on ARM
   372 %ifarch %arm
   374 %ifarch %arm aarch64
   373 ac_add_options --with-gl-provider=EGL
   375 ac_add_options --with-gl-provider=EGL
   374 %endif
   376 %endif
   375 EOF
   377 EOF
   376 make -f client.mk build
   378 make -f client.mk build
   377 
   379