MozillaFirefox/MozillaFirefox.spec
changeset 1134 01a4849e2ed3
parent 1133 0a44f639e5ee
child 1135 082b9d2dfd7d
--- a/MozillaFirefox/MozillaFirefox.spec	Sat Jun 13 10:01:48 2020 +0200
+++ b/MozillaFirefox/MozillaFirefox.spec	Wed Jun 17 09:49:29 2020 +0200
@@ -21,7 +21,7 @@
 %define major          77
 %define mainver        %major.99
 %define orig_version   78.0
-%define orig_suffix    b6
+%define orig_suffix    b7
 %define update_channel beta
 %define branding       1
 %define devpkg         1
@@ -61,6 +61,12 @@
 %else
 %define crashreporter 0
 %endif
+# pipewire is too old on Leap 15.1
+%if 0%{?suse_version} == 1500 && 0%{?sle_version} <= 150100
+%bcond_with pipewire3
+%else
+%bcond_without pipewire3
+%endif
 
 Name:           %{pkgname}
 BuildRequires:  Mesa-devel
@@ -91,7 +97,6 @@
 BuildRequires:  python3 >= 3.5
 BuildRequires:  rust >= 1.41
 BuildRequires:  rust-cbindgen >= 0.14.1
-BuildRequires:  startup-notification-devel
 BuildRequires:  unzip
 BuildRequires:  update-desktop-files
 BuildRequires:  xorg-x11-libXt-devel
@@ -113,6 +118,9 @@
 BuildRequires:  pkgconfig(gtk+-unix-print-3.0)
 BuildRequires:  pkgconfig(libffi)
 BuildRequires:  pkgconfig(libpulse)
+%if %{with pipewire3}
+BuildRequires:  pkgconfig(libpipewire-0.3)
+%endif
 # libavcodec is required for H.264 support but the
 # openSUSE version is currently not able to play H.264
 # therefore the Packman version is required
@@ -179,6 +187,7 @@
 Patch20:        mozilla-fix-top-level-asm.patch
 Patch21:        mozilla-bmo1504834-part4.patch
 Patch22:        mozilla-bmo849632.patch
+Patch23:        mozilla-pipewire-0-3.patch
 # Firefox/browser
 Patch101:       firefox-kde.patch
 Patch102:       firefox-branded-icons.patch
@@ -311,6 +320,9 @@
 %patch20 -p1
 %patch21 -p1
 %patch22 -p1
+%if %{with pipewire3}
+%patch23 -p1
+%endif
 # Firefox
 %patch101 -p1
 %patch102 -p1