MozillaFirefox/MozillaFirefox.spec
branchfirefox64
changeset 1083 2f7023025374
parent 1082 821cfbe8efcc
child 1084 b0b3c507e253
--- a/MozillaFirefox/MozillaFirefox.spec	Wed Dec 12 12:15:16 2018 +0100
+++ b/MozillaFirefox/MozillaFirefox.spec	Thu Dec 13 16:31:34 2018 +0100
@@ -31,9 +31,16 @@
 %if 0%{?suse_version} > 1320
 %define clang_build 1
 %endif
+# Except on aarch64 due to bmo#1513605
+# and on %%arm due to large ld memory requirements
+%ifarch %arm aarch64
+%define clang_build 0
+%endif
 
 # PIE, full relro (x86_64 for now)
+%ifnarch %arm aarch64
 %define build_hardened 1
+%endif
 
 # Firefox only supports i686
 %ifarch %ix86
@@ -71,6 +78,7 @@
 %else
 BuildRequires:  gcc-c++
 %endif
+BuildRequires:  cargo >= 1.29
 BuildRequires:  libXcomposite-devel
 BuildRequires:  libcurl-devel
 BuildRequires:  libidl-devel
@@ -85,7 +93,6 @@
 BuildRequires:  python2-xml
 BuildRequires:  python3 >= 3.5
 BuildRequires:  rust >= 1.29
-BuildRequires:  cargo >= 1.29
 BuildRequires:  rust-cbindgen >= 0.6.4
 BuildRequires:  startup-notification-devel
 BuildRequires:  unzip
@@ -303,6 +310,11 @@
 export MOZ_TELEMETRY_REPORTING=1
 %if 0%{?suse_version} <= 1320
 export CC=gcc-7
+%else
+%if 0%{?clang_build} == 0
+export CC=gcc
+export CXX=g++
+%endif
 %endif
 export CFLAGS="%{optflags} -fno-strict-aliasing"
 # boo#986541: add -fno-delete-null-pointer-checks for gcc6
@@ -321,8 +333,10 @@
 %endif
 %endif
 %ifarch ppc64 ppc64le
+%if 0%{?clang_build} == 0
 export CFLAGS="$CFLAGS -mminimal-toc"
 %endif
+%endif
 export CXXFLAGS="$CFLAGS"
 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
 %limit_build -m 1500