MozillaFirefox/MozillaFirefox.spec
branchfirefox103
changeset 1177 4bb6d80fcc64
parent 1175 4c6576f9cf04
child 1178 e27c6e9c5c63
--- a/MozillaFirefox/MozillaFirefox.spec	Tue Jul 26 14:45:20 2022 +0200
+++ b/MozillaFirefox/MozillaFirefox.spec	Sun Aug 21 12:40:43 2022 +0200
@@ -28,9 +28,9 @@
 # orig_suffix b3
 # major 69
 # mainver %major.99
-%define major          102
-%define mainver        %major.0.1
-%define orig_version   102.0.1
+%define major          103
+%define mainver        %major.0.2
+%define orig_version   103.0.2
 %define orig_suffix    %{nil}
 %define update_channel release
 %define branding       1
@@ -106,8 +106,8 @@
 # minimal requirement:
 BuildRequires:  rust+cargo >= 1.59
 # actually used upstream:
-BuildRequires:  cargo1.60
-BuildRequires:  rust1.60
+BuildRequires:  cargo1.61
+BuildRequires:  rust1.61
 %endif
 %if 0%{useccache} != 0
 BuildRequires:  ccache
@@ -118,7 +118,7 @@
 BuildRequires:  libproxy-devel
 BuildRequires:  makeinfo
 BuildRequires:  mozilla-nspr-devel >= 4.34
-BuildRequires:  mozilla-nss-devel >= 3.79
+BuildRequires:  mozilla-nss-devel >= 3.80
 BuildRequires:  nasm >= 2.14
 BuildRequires:  nodejs >= 10.22.1
 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
@@ -128,7 +128,7 @@
 BuildRequires:  python3 >= 3.5
 BuildRequires:  python3-devel
 %endif
-BuildRequires:  rust-cbindgen >= 0.23.0
+BuildRequires:  rust-cbindgen >= 0.24.3
 BuildRequires:  unzip
 BuildRequires:  update-desktop-files
 BuildRequires:  xorg-x11-libXt-devel
@@ -224,6 +224,7 @@
 Patch23:        mozilla-bmo531915.patch
 Patch25:        one_swizzle_to_rule_them_all.patch
 Patch26:        svg-rendering.patch
+Patch27:        mozilla-glibc236.patch
 # Firefox/browser
 Patch101:       firefox-kde.patch
 Patch102:       firefox-branded-icons.patch
@@ -399,6 +400,10 @@
 # Done with env-variables.
 source ./.obsenv.sh
 
+%ifarch aarch64 %arm ppc64 ppc64le
+%limit_build -m 2000
+%endif
+
 # Generating mozconfig
 cat << EOF > $MOZCONFIG
 mk_add_options MOZILLA_OFFICIAL=1
@@ -425,7 +430,7 @@
 ac_add_options --disable-install-strip
 # building with elf-hack started to fail everywhere with FF73
 #%if 0%{?suse_version} > 1549
-%ifnarch aarch64 ppc64 ppc64le s390x
+%ifarch %arm %ix86 x86_64
 ac_add_options --disable-elf-hack
 %endif
 #%endif
@@ -491,9 +496,6 @@
 cat ./.obsenv.sh
 cat $MOZCONFIG
 %else
-%ifarch aarch64 %arm ppc64 ppc64le
-%limit_build -m 2000
-%endif
 
 %if 0%{useccache} != 0
 ccache -s