MozillaFirefox/MozillaFirefox.spec
branchfirefox88
changeset 1157 57fc0524b50c
parent 1156 c3d884659acf
child 1158 00846b9a35cd
--- a/MozillaFirefox/MozillaFirefox.spec	Sat Mar 27 21:45:50 2021 +0100
+++ b/MozillaFirefox/MozillaFirefox.spec	Sat May 29 22:52:13 2021 +0200
@@ -32,9 +32,9 @@
 # orig_suffix b3
 # major 69
 # mainver %major.99
-%define major          87
-%define mainver        %major.0
-%define orig_version   87.0
+%define major          88
+%define mainver        %major.0.1
+%define orig_version   88.0.1
 %define orig_suffix    %{nil}
 %define update_channel release
 %define branding       1
@@ -85,11 +85,13 @@
 %else
 %define crashreporter 0
 %endif
-%if 0%{?suse_version} < 1550 && 0%{?sle_version} <= 150100
-# pipewire is too old on Leap <15.1
+%define with_pipewire0_3  1
+%define wayland_supported 1
+%if 0%{?sle_version} > 0 && 0%{?sle_version} < 150200
+# pipewire is too old on Leap <=15.1
 %define with_pipewire0_3 0
-%else
-%define with_pipewire0_3 1
+# Wayland is too old on Leap <=15.1 as well
+%define wayland_supported 0
 %endif
 
 Name:           %{pkgname}
@@ -115,10 +117,10 @@
 BuildRequires:  libiw-devel
 BuildRequires:  libproxy-devel
 BuildRequires:  makeinfo
-BuildRequires:  mozilla-nspr-devel >= 4.29
-BuildRequires:  mozilla-nss-devel >= 3.62
+BuildRequires:  mozilla-nspr-devel >= 4.30
+BuildRequires:  mozilla-nss-devel >= 3.63.1
 BuildRequires:  nasm >= 2.14
-BuildRequires:  nodejs10 >= 10.22.1
+BuildRequires:  nodejs >= 10.22.1
 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
 BuildRequires:  python-libxml2
 BuildRequires:  python36
@@ -448,10 +450,10 @@
 ac_add_options --libdir=%{_libdir}
 ac_add_options --includedir=%{_includedir}
 ac_add_options --enable-release
-%if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
+%if 0%{wayland_supported}
+ac_add_options --enable-default-toolkit=cairo-gtk3-wayland
+%else
 ac_add_options --enable-default-toolkit=cairo-gtk3
-%else
-ac_add_options --enable-default-toolkit=cairo-gtk3-wayland
 %endif
 # bmo#1441155 - Disable the generation of Rust debug symbols on Linux32
 %ifarch %ix86 %arm
@@ -628,6 +630,7 @@
 sed "s:%%PREFIX:%{_prefix}:g
 s:%%PROGDIR:%{progdir}:g
 s:%%APPNAME:%{progname}:g
+s:%%WAYLAND_SUPPORTED:%{wayland_supported}:g
 s:%%PROFILE:.mozilla/firefox:g" \
   %{SOURCE3} > %{buildroot}%{progdir}/%{progname}.sh
 chmod 755 %{buildroot}%{progdir}/%{progname}.sh
@@ -684,8 +687,8 @@
 mkdir -p %{buildroot}%{_bindir}
 install -m 755 %SOURCE12 %{buildroot}%{_bindir}
 # inspired by mandriva
-mkdir -p %{buildroot}%{_sysconfdir}/rpm
-cat <<'FIN' >%{buildroot}%{_sysconfdir}/rpm/macros.%{progname}
+mkdir -p %{buildroot}%{_rpmmacrodir}
+cat <<'FIN' >%{buildroot}%{_rpmmacrodir}/macros.%{progname}
 # Macros from %{name} package
 %%firefox_major              %{major}
 %%firefox_version            %{version}
@@ -778,7 +781,7 @@
 %files devel
 %defattr(-,root,root)
 %{_bindir}/mozilla-get-app-id
-%config %{_sysconfdir}/rpm/macros.%{progname}
+%{_rpmmacrodir}/macros.%{progname}
 %endif
 
 %if %localize