MozillaFirefox/MozillaFirefox.spec
branchfirefox64
changeset 1084 b0b3c507e253
parent 1083 2f7023025374
child 1085 87f893cf45b9
--- a/MozillaFirefox/MozillaFirefox.spec	Thu Dec 13 16:31:34 2018 +0100
+++ b/MozillaFirefox/MozillaFirefox.spec	Sat Jan 26 22:42:57 2019 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package MozillaFirefox
 #
-# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
 #               2006-2018 Wolfgang Rosenauer
 #
 # All modifications and additions to the file contributed by third parties
@@ -19,28 +19,19 @@
 
 # changed with every update
 %define major          64
-%define mainver        %major.0
-%define orig_version   64.0
+%define mainver        %major.0.2
+%define orig_version   64.0.2
 %define orig_suffix    %{nil}
 %define update_channel release
 %define branding       1
-%define releasedate    20181206201918
+%define releasedate    20190108160530
 %define source_prefix  firefox-%{orig_version}
 
-# use clang (upstream default since 64.0)
-%if 0%{?suse_version} > 1320
-%define clang_build 1
-%endif
-# Except on aarch64 due to bmo#1513605
-# and on %%arm due to large ld memory requirements
-%ifarch %arm aarch64
+# always build with GCC as SUSE Security Team requires that
 %define clang_build 0
-%endif
 
-# PIE, full relro (x86_64 for now)
-%ifnarch %arm aarch64
+# PIE, full relro
 %define build_hardened 1
-%endif
 
 # Firefox only supports i686
 %ifarch %ix86
@@ -316,21 +307,12 @@
 export CXX=g++
 %endif
 %endif
-export CFLAGS="%{optflags} -fno-strict-aliasing"
-# boo#986541: add -fno-delete-null-pointer-checks for gcc6
-%if 0%{?clang_build} == 0
-%if 0%{?suse_version} > 1320
-export CFLAGS="$CFLAGS -fno-delete-null-pointer-checks"
-%endif
-%endif
 %ifarch %arm %ix86
 # Limit RAM usage during link
 export LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
 %endif
 %if 0%{?build_hardened}
-%ifarch x86_64
-export LDFLAGS="${LDFLAGS} -Wl,-z,relro,-z,now"
-%endif
+export LDFLAGS="${LDFLAGS} -fPIC -Wl,-z,relro,-z,now"
 %endif
 %ifarch ppc64 ppc64le
 %if 0%{?clang_build} == 0
@@ -354,18 +336,11 @@
 %if 0%{?suse_version} >= 1550
 ac_add_options --disable-gconf
 %endif
-%if 0%{?build_hardened}
-%if 0%{?clang_build} == 0
-ac_add_options --enable-pie
-%endif
-%endif
-# gcc7 (boo#104105)
-%if 0%{?suse_version} > 1320
-ac_add_options --enable-optimize="-g -O2"
-%endif
 # bmo#1441155 - Disable the generation of Rust debug symbols on Linux32
 %ifarch %ix86 %arm
 ac_add_options --disable-debug-symbols
+%else
+ac_add_options --enable-debug-symbols
 %endif
 %if 0%{?suse_version} > 1549
 %ifnarch aarch64 ppc64 ppc64le