MozillaFirefox/MozillaFirefox.spec
branchfirefox66
changeset 1089 eca1c1f2fe50
parent 1087 5fab52cd743d
child 1092 5d7b22f6b177
--- a/MozillaFirefox/MozillaFirefox.spec	Sun Mar 17 09:57:22 2019 +0100
+++ b/MozillaFirefox/MozillaFirefox.spec	Tue Mar 19 09:48:05 2019 +0100
@@ -18,13 +18,13 @@
 
 
 # changed with every update
-%define major          65
-%define mainver        %major.0.1
-%define orig_version   65.0.1
+%define major          66
+%define mainver        %major.0
+%define orig_version   66.0
 %define orig_suffix    %{nil}
 %define update_channel release
 %define branding       1
-%define releasedate    20190211233335
+%define releasedate    20190314174725
 %define source_prefix  firefox-%{orig_version}
 
 # always build with GCC as SUSE Security Team requires that
@@ -69,7 +69,7 @@
 %else
 BuildRequires:  gcc-c++
 %endif
-BuildRequires:  cargo >= 1.30
+BuildRequires:  cargo >= 1.31
 BuildRequires:  libXcomposite-devel
 BuildRequires:  libcurl-devel
 BuildRequires:  libidl-devel
@@ -78,13 +78,14 @@
 BuildRequires:  libproxy-devel
 BuildRequires:  makeinfo
 BuildRequires:  mozilla-nspr-devel >= 4.20
-BuildRequires:  mozilla-nss-devel >= 3.41
+BuildRequires:  mozilla-nss-devel >= 3.42.1
+BuildRequires:  nasm >= 2.13
 BuildRequires:  nodejs >= 8.11
 BuildRequires:  python-devel
 BuildRequires:  python2-xml
 BuildRequires:  python3 >= 3.5
-BuildRequires:  rust >= 1.30
-BuildRequires:  rust-cbindgen >= 0.6.7
+BuildRequires:  rust >= 1.31
+BuildRequires:  rust-cbindgen >= 0.6.8
 BuildRequires:  startup-notification-devel
 BuildRequires:  unzip
 BuildRequires:  update-desktop-files
@@ -160,7 +161,6 @@
 Patch3:         mozilla-ntlm-full-path.patch
 Patch4:         mozilla-openaes-decl.patch
 Patch7:         mozilla-aarch64-startup-crash.patch
-Patch8:         mozilla-bmo256180.patch
 Patch9:         mozilla-bmo1463035.patch
 Patch10:        mozilla-cubeb-noreturn.patch
 # Firefox/browser
@@ -267,7 +267,6 @@
 %patch3 -p1
 %patch4 -p1
 %patch7 -p1
-%patch8 -p1
 %patch9 -p1
 %patch10 -p1
 # Firefox
@@ -359,7 +358,8 @@
 #ac_add_options --enable-chrome-format=jar
 ac_add_options --enable-update-channel=%{update_channel}
 ac_add_options --with-mozilla-api-keyfile=%{SOURCE18}
-ac_add_options --with-google-api-keyfile=%{SOURCE19}
+ac_add_options --with-google-location-service-api-keyfile=%{SOURCE19}
+ac_add_options --with-google-safebrowsing-api-keyfile=%{SOURCE19}
 ac_add_options --with-unsigned-addon-scopes=app
 %if %branding
 ac_add_options --enable-official-branding