- Correct plugin directory for aarch64 (boo#1061207). The wrapper firefox56
authorStefan Br?ns <stefan.bruens@rwth-aachen.de>
Sun, 01 Oct 2017 23:16:23 +0200
branchfirefox56
changeset 997 ca8a6ac7fbf6
parent 996 84d25951c2db
child 998 6c6109948e35
- Correct plugin directory for aarch64 (boo#1061207). The wrapper
script was not detecting aarch64 as a 64 bit architecture, thus
used /usr/lib/browser-plugins/.
MozillaFirefox/MozillaFirefox.changes
MozillaFirefox/mozilla.sh.in
--- a/MozillaFirefox/MozillaFirefox.changes	Sun Oct 01 23:13:44 2017 +0200
+++ b/MozillaFirefox/MozillaFirefox.changes	Sun Oct 01 23:16:23 2017 +0200
@@ -1,4 +1,11 @@
 -------------------------------------------------------------------
+Sun Oct  1 18:25:16 UTC 2017 - stefan.bruens@rwth-aachen.de
+
+- Correct plugin directory for aarch64 (boo#1061207). The wrapper
+  script was not detecting aarch64 as a 64 bit architecture, thus
+  used /usr/lib/browser-plugins/.
+
+-------------------------------------------------------------------
 Sat Sep 30 20:10:50 UTC 2017 - zaitor@opensuse.org
 
 - Drop libgnomeui-devel, and replace it with pkgconfig(gconf-2.0),
--- a/MozillaFirefox/mozilla.sh.in	Sun Oct 01 23:13:44 2017 +0200
+++ b/MozillaFirefox/mozilla.sh.in	Sun Oct 01 23:16:23 2017 +0200
@@ -72,7 +72,7 @@
 
 mozilla_lib=`file $MOZ_PROGRAM`
 LIB=lib
-echo $mozilla_lib | grep -q -E 'ELF.64-bit.*(x86-64|S/390|PowerPC)' && LIB=lib64
+echo $mozilla_lib | grep -q -E 'ELF.64-bit.*(x86-64|S/390|PowerPC|ARM aarch64)' && LIB=lib64
 
 BROWSER_PLUGIN_DIR=/usr/$LIB/browser-plugins
 if [ ! -d $BROWSER_PLUGIN_DIR ]; then