xulrunner/xulrunner.spec
branchfirefox24
changeset 670 0b1f7ee785d3
parent 595 31f273919032
child 678 d0329e10d68c
child 793 a08cc1ab27af
child 876 e893bdc9bf06
child 879 3b986c9dbc5f
equal deleted inserted replaced
669:4b65b5cfd428 670:0b1f7ee785d3
     1 #
     1 #
     2 # spec file for package xulrunner
     2 # spec file for package xulrunner
     3 #
     3 #
     4 # Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
     4 # Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
     5 #               2006-2012 Wolfgang Rosenauer
     5 #               2006-2013 Wolfgang Rosenauer
     6 #
     6 #
     7 # All modifications and additions to the file contributed by third parties
     7 # All modifications and additions to the file contributed by third parties
     8 # remain the property of their copyright owners, unless otherwise agreed
     8 # remain the property of their copyright owners, unless otherwise agreed
     9 # upon. The license for this file, and modifications and additions to the
     9 # upon. The license for this file, and modifications and additions to the
    10 # file, is the same license as for the pristine package itself (unless the
    10 # file, is the same license as for the pristine package itself (unless the
    14 # published by the Open Source Initiative.
    14 # published by the Open Source Initiative.
    15 
    15 
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
       
    19 %if %suse_version > 1220
       
    20 %define gstreamer_ver 0.10
       
    21 %else
       
    22 %define gstreamer_ver 0.10
       
    23 %endif
    19 
    24 
    20 Name:           xulrunner
    25 Name:           xulrunner
    21 BuildRequires:  Mesa-devel
    26 BuildRequires:  Mesa-devel
    22 BuildRequires:  autoconf213
    27 BuildRequires:  autoconf213
    23 BuildRequires:  dbus-1-glib-devel
    28 BuildRequires:  dbus-1-glib-devel
    40 BuildRequires:  libiw-devel
    45 BuildRequires:  libiw-devel
    41 BuildRequires:  libproxy-devel
    46 BuildRequires:  libproxy-devel
    42 %else
    47 %else
    43 BuildRequires:  wireless-tools
    48 BuildRequires:  wireless-tools
    44 %endif
    49 %endif
    45 BuildRequires:  mozilla-nspr-devel >= 4.9.2
    50 BuildRequires:  mozilla-nspr-devel >= 4.10
    46 BuildRequires:  mozilla-nss-devel >= 3.14
    51 BuildRequires:  mozilla-nss-devel >= 3.15.1
    47 Version:        17.99
    52 %if %suse_version > 1210
       
    53 BuildRequires:  pkgconfig(gstreamer-%gstreamer_ver)
       
    54 BuildRequires:  pkgconfig(gstreamer-app-%gstreamer_ver)
       
    55 BuildRequires:  pkgconfig(gstreamer-plugins-base-%gstreamer_ver)
       
    56 %endif
       
    57 Version:        24.0
    48 Release:        0
    58 Release:        0
    49 %define         releasedate 2012112800
    59 %define         releasedate 2013091000
    50 %define         version_internal 18.0
    60 %define         version_internal 24.0
    51 %define         apiversion 18
    61 %define         apiversion 24
    52 %define         uaweight 1800000
    62 %define         uaweight 2400000
    53 Summary:        Mozilla Runtime Environment
    63 Summary:        Mozilla Runtime Environment
    54 License:        MPL-2.0
    64 License:        MPL-2.0
    55 Group:          Productivity/Other
    65 Group:          Productivity/Other
    56 Url:            http://www.mozilla.org/
    66 Url:            http://www.mozilla.org/
    57 Provides:       gecko
    67 Provides:       gecko
    74 Patch4:         mozilla-nongnome-proxies.patch
    84 Patch4:         mozilla-nongnome-proxies.patch
    75 Patch5:         mozilla-prefer_plugin_pref.patch
    85 Patch5:         mozilla-prefer_plugin_pref.patch
    76 Patch6:         mozilla-language.patch
    86 Patch6:         mozilla-language.patch
    77 Patch7:         mozilla-ntlm-full-path.patch
    87 Patch7:         mozilla-ntlm-full-path.patch
    78 Patch9:         mozilla-sle11.patch
    88 Patch9:         mozilla-sle11.patch
    79 Patch14:        mozilla-ppc.patch
    89 Patch10:        mozilla-ppc.patch
       
    90 Patch11:        mozilla-libproxy-compat.patch
    80 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
    91 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
    81 Requires:       mozilla-js = %{version}
    92 Requires:       mozilla-js = %{version}
    82 Requires(post):  update-alternatives coreutils
    93 Requires(post):  update-alternatives coreutils
    83 Requires(preun): update-alternatives coreutils
    94 Requires(preun): update-alternatives coreutils
       
    95 Provides:       xulrunner-esr = %{version}
       
    96 Obsoletes:      xulrunner-esr < 24.0
    84 ### build configuration ###
    97 ### build configuration ###
    85 %define has_system_nspr  1
    98 %define has_system_nspr  1
    86 %define has_system_nss   1
    99 %define has_system_nss   1
    87 %define has_system_cairo 0
   100 %define has_system_cairo 0
    88 %define localize 0
   101 %define localize 1
    89 %ifarch ppc ppc64 s390 s390x ia64 %arm
   102 %ifarch ppc ppc64 s390 s390x ia64 %arm
    90 %define crashreporter    0
   103 %define crashreporter    0
    91 %else
   104 %else
    92 %define crashreporter    1
   105 %define crashreporter    1
    93 %endif
   106 %endif
   138 
   151 
   139 %package translations-common
   152 %package translations-common
   140 Summary:        Common translations for XULRunner
   153 Summary:        Common translations for XULRunner
   141 Group:          System/Localization
   154 Group:          System/Localization
   142 Requires:       %{name} = %{version}
   155 Requires:       %{name} = %{version}
   143 Provides:       locale(%{name}:ar;ca;cs;da;de;en_GB;es_AR;es_CL;es_ES;fi;fr;hu;it;ja;ko;nb_NO;nl;pl;pt_BR;pt_PT;ru;sv_SE;zh_CN;zh_TW)
   156 Provides:       locale(%{name}:ar;ca;cs;da;de;el;en_GB;es_AR;es_CL;es_ES;fi;fr;hu;it;ja;ko;nb_NO;nl;pl;pt_BR;pt_PT;ru;sv_SE;zh_CN;zh_TW)
   144 Obsoletes:      %{name}-translations < %{version}-%{release}
   157 Obsoletes:      %{name}-translations < %{version}-%{release}
   145 
   158 
   146 %description translations-common
   159 %description translations-common
   147 XULRunner is a single installable package that can be used to bootstrap
   160 XULRunner is a single installable package that can be used to bootstrap
   148 multiple XUL+XPCOM applications that are as rich as Firefox and
   161 multiple XUL+XPCOM applications that are as rich as Firefox and
   154 
   167 
   155 %package translations-other
   168 %package translations-other
   156 Summary:        Extra translations for XULRunner
   169 Summary:        Extra translations for XULRunner
   157 Group:          System/Localization
   170 Group:          System/Localization
   158 Requires:       %{name} = %{version}
   171 Requires:       %{name} = %{version}
   159 Provides:       locale(%{name}:ach;af;ak;as;ast;be;bg;bn_BD;bn_IN;br;bs;csb;cy;el;en_ZA;eo;es_MX;et;eu;fa;ff;fy_NL;ga_IE;gd;gl;gu_IN;he;hi_IN;hr;hy_AM;id;is;kk;km;kn;ku;lg;lij;lt;lv;mai;mk;ml;mr;nn_NO;nso;or;pa_IN;rm;ro;si;sk;sl;son;sq;sr;ta;ta_LK;te;th;tr;uk;vi;zu)
   172 Provides:       locale(%{name}:ach;af;ak;as;ast;be;bg;bn_BD;bn_IN;br;bs;csb;cy;en_ZA;eo;es_MX;et;eu;fa;ff;fy_NL;ga_IE;gd;gl;gu_IN;he;hi_IN;hr;hy_AM;id;is;kk;km;kn;ku;lg;lij;lt;lv;mai;mk;ml;mr;nn_NO;nso;or;pa_IN;rm;ro;si;sk;sl;son;sq;sr;ta;ta_LK;te;th;tr;uk;vi;zu)
   160 Obsoletes:      %{name}-translations < %{version}-%{release}
   173 Obsoletes:      %{name}-translations < %{version}-%{release}
   161 
   174 
   162 %description translations-other
   175 %description translations-other
   163 XULRunner is a single installable package that can be used to bootstrap
   176 XULRunner is a single installable package that can be used to bootstrap
   164 multiple XUL+XPCOM applications that are as rich as Firefox and
   177 multiple XUL+XPCOM applications that are as rich as Firefox and
   188 %patch6 -p1
   201 %patch6 -p1
   189 %patch7 -p1
   202 %patch7 -p1
   190 %if %suse_version < 1120
   203 %if %suse_version < 1120
   191 %patch9 -p1
   204 %patch9 -p1
   192 %endif
   205 %endif
   193 %patch14 -p1
   206 %patch10 -p1
       
   207 %patch11 -p1
   194 
   208 
   195 %build
   209 %build
   196 # no need to add build time to binaries
   210 # no need to add build time to binaries
   197 modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/%{name}.changes")"
   211 modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/%{name}.changes")"
   198 DATE="\"$(date -d "${modified}" "+%%b %%e %%Y")\""
   212 DATE="\"$(date -d "${modified}" "+%%b %%e %%Y")\""
   241 ac_add_options --disable-updater
   255 ac_add_options --disable-updater
   242 ac_add_options --disable-javaxpcom
   256 ac_add_options --disable-javaxpcom
   243 ac_add_options --enable-system-hunspell
   257 ac_add_options --enable-system-hunspell
   244 ac_add_options --enable-startup-notification
   258 ac_add_options --enable-startup-notification
   245 ac_add_options --enable-shared-js
   259 ac_add_options --enable-shared-js
   246 ac_add_options --disable-webrtc   # does not build with system NSPR
       
   247 #ac_add_options --enable-debug
   260 #ac_add_options --enable-debug
   248 EOF
   261 EOF
   249 %if %suse_version > 1130
   262 %if %suse_version > 1130
   250 cat << EOF >> $MOZCONFIG
   263 cat << EOF >> $MOZCONFIG
   251 ac_add_options --disable-gnomevfs
   264 ac_add_options --disable-gnomevfs
   252 ac_add_options --enable-gio
   265 ac_add_options --enable-gio
   253 EOF
   266 EOF
   254 %endif
   267 %endif
       
   268 %if %suse_version < 1220
       
   269 cat << EOF >> $MOZCONFIG
       
   270 ac_add_options --disable-gstreamer
       
   271 EOF
       
   272 %endif
   255 %if %has_system_nspr
   273 %if %has_system_nspr
   256 cat << EOF >> $MOZCONFIG
   274 cat << EOF >> $MOZCONFIG
   257 ac_add_options --with-system-nspr
   275 ac_add_options --with-system-nspr
   258 EOF
   276 EOF
   259 %endif
   277 %endif
   273 EOF
   291 EOF
   274 %endif
   292 %endif
   275 %if ! %crashreporter
   293 %if ! %crashreporter
   276 cat << EOF >> $MOZCONFIG
   294 cat << EOF >> $MOZCONFIG
   277 ac_add_options --disable-crashreporter
   295 ac_add_options --disable-crashreporter
   278 EOF
       
   279 %endif
       
   280 # S/390
       
   281 %ifarch s390 s390x
       
   282 cat << EOF >> $MOZCONFIG
       
   283 ac_add_options --disable-jemalloc
       
   284 EOF
   296 EOF
   285 %endif
   297 %endif
   286 # ARM
   298 # ARM
   287 %ifarch %arm
   299 %ifarch %arm
   288 cat << EOF >> $MOZCONFIG
   300 cat << EOF >> $MOZCONFIG
   289 %ifarch armv7l armv7hl
   301 ac_add_options --disable-neon
   290 ac_add_options --with-arch=armv7-a
   302 EOF
   291 ac_add_options --with-float-abi=hard
   303 %endif
   292 ac_add_options --with-fpu=vfpv3-d16
   304 %ifnarch %ix86 x86_64
   293 ac_add_options --with-thumb=yes
   305 cat << EOF >> $MOZCONFIG
   294 ac_add_options --disable-debug
   306 ac_add_options --disable-webrtc
   295 %endif
       
   296 %ifarch armv5tel
       
   297 ac_add_options --with-arch=armv5te
       
   298 ac_add_options --with-float-abi=soft
       
   299 ac_add_options --with-thumb=no
       
   300 %endif
       
   301 EOF
   307 EOF
   302 %endif
   308 %endif
   303 make -f client.mk build
   309 make -f client.mk build
   304 
   310 
   305 %install
   311 %install
   313 find $RPM_BUILD_ROOT%{_includedir}/xulrunner-%{version_internal} \
   319 find $RPM_BUILD_ROOT%{_includedir}/xulrunner-%{version_internal} \
   314      -type f -perm -111 -exec chmod a-x {} \;
   320      -type f -perm -111 -exec chmod a-x {} \;
   315 find $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/ \
   321 find $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/ \
   316      -name "*.js" -o -name "*.xpm" -o -name "*.png" | xargs chmod a-x
   322      -name "*.js" -o -name "*.xpm" -o -name "*.png" | xargs chmod a-x
   317 # remove mkdir.done files from installed base
   323 # remove mkdir.done files from installed base
   318 find $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal} -name ".mkdir.done" | xargs rm
   324 #find $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal} -name ".mkdir.done" | xargs rm
   319 mkdir -p $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/extensions
   325 mkdir -p $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/extensions
   320 # fixing SDK dynamic libs (symlink instead of copy)
   326 # fixing SDK dynamic libs (symlink instead of copy)
   321 rm $RPM_BUILD_ROOT%{_libdir}/xulrunner-devel-%{version_internal}/sdk/lib/*.so
   327 rm $RPM_BUILD_ROOT%{_libdir}/xulrunner-devel-%{version_internal}/sdk/lib/*.so
   322 ln -sf ../../../xulrunner-%{version_internal}/libmozjs.so \
   328 ln -sf ../../../xulrunner-%{version_internal}/libmozjs.so \
   323        $RPM_BUILD_ROOT%{_libdir}/xulrunner-devel-%{version_internal}/sdk/lib/
       
   324 ln -sf ../../../xulrunner-%{version_internal}/libxpcom.so \
       
   325        $RPM_BUILD_ROOT%{_libdir}/xulrunner-devel-%{version_internal}/sdk/lib/
   329        $RPM_BUILD_ROOT%{_libdir}/xulrunner-devel-%{version_internal}/sdk/lib/
   326 ln -sf ../../../xulrunner-%{version_internal}/libxul.so \
   330 ln -sf ../../../xulrunner-%{version_internal}/libxul.so \
   327        $RPM_BUILD_ROOT%{_libdir}/xulrunner-devel-%{version_internal}/sdk/lib/
   331        $RPM_BUILD_ROOT%{_libdir}/xulrunner-devel-%{version_internal}/sdk/lib/
   328 # include basic buildenv for xulapps to use
   332 # include basic buildenv for xulapps to use
   329 mkdir -p $RPM_BUILD_ROOT%{_datadir}/xulrunner-%{version_internal}
   333 mkdir -p $RPM_BUILD_ROOT%{_datadir}/xulrunner-%{version_internal}
   330 pushd ..
   334 pushd ..
   331 # this list has been compiled by trial and error for prism
   335 # this list has been compiled by trial and error for prism
   332 tar --exclude=*.cpp --exclude=*.mm \
   336 tar --exclude=*.cpp --exclude=*.mm \
   333    -cvjf $RPM_BUILD_ROOT%{_datadir}/xulrunner-%{version_internal}/mozilla-src.tar.bz2 \
   337    -cvjf $RPM_BUILD_ROOT%{_datadir}/xulrunner-%{version_internal}/mozilla-src.tar.bz2 \
   334     mozilla/configure.in mozilla/Makefile.in mozilla/client.py mozilla/allmakefiles.sh \
   338     mozilla/configure.in mozilla/Makefile.in mozilla/client.py \
   335     mozilla/config mozilla/client.mk mozilla/aclocal.m4 mozilla/build mozilla/js/src/* \
   339     mozilla/config mozilla/client.mk mozilla/aclocal.m4 mozilla/build mozilla/js/src/* \
   336     mozilla/testing mozilla/toolkit/mozapps/installer mozilla/probes mozilla/memory \
   340     mozilla/testing mozilla/toolkit/mozapps/installer mozilla/probes mozilla/memory \
   337     mozilla/toolkit/xre mozilla/nsprpub/config mozilla/tools mozilla/xpcom/build
   341     mozilla/toolkit/xre mozilla/nsprpub/config mozilla/tools mozilla/xpcom/build
   338 popd
   342 popd
   339 # install add-plugins.sh
   343 # install add-plugins.sh
   362          $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/extensions/langpack-$locale@firefox.mozilla.org
   366          $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/extensions/langpack-$locale@firefox.mozilla.org
   363       # remove prefs and profile defaults from langpack
   367       # remove prefs and profile defaults from langpack
   364       rm -rf $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/extensions/langpack-$locale@firefox.mozilla.org/defaults
   368       rm -rf $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/extensions/langpack-$locale@firefox.mozilla.org/defaults
   365       # check against the fixed common list and sort into the right filelist
   369       # check against the fixed common list and sort into the right filelist
   366       _matched=0
   370       _matched=0
   367       for _match in ar ca cs da de en-GB es-AR es-CL es-ES fi fr hu it ja ko nb-NO nl pl pt-BR pt-PT ru sv-SE zh-CN zh-TW; do
   371       for _match in ar ca cs da de el en-GB es-AR es-CL es-ES fi fr hu it ja ko nb-NO nl pl pt-BR pt-PT ru sv-SE zh-CN zh-TW; do
   368         [ "$_match" = "$locale" ] && _matched=1
   372         [ "$_match" = "$locale" ] && _matched=1
   369       done
   373       done
   370       [ $_matched -eq 1 ] && _l10ntarget=common || _l10ntarget=other
   374       [ $_matched -eq 1 ] && _l10ntarget=common || _l10ntarget=other
   371       echo %{_libdir}/xulrunner-%{version_internal}/extensions/langpack-$locale@firefox.mozilla.org \ \
   375       echo %{_libdir}/xulrunner-%{version_internal}/extensions/langpack-$locale@firefox.mozilla.org \ \
   372          >> %{_tmppath}/translations.$_l10ntarget
   376          >> %{_tmppath}/translations.$_l10ntarget
   451 %dir %{_libdir}/xulrunner-%{version_internal}/chrome/
   455 %dir %{_libdir}/xulrunner-%{version_internal}/chrome/
   452 %dir %{_libdir}/xulrunner-%{version_internal}/dictionaries/
   456 %dir %{_libdir}/xulrunner-%{version_internal}/dictionaries/
   453 %dir %{_libdir}/xulrunner-%{version_internal}/extensions/
   457 %dir %{_libdir}/xulrunner-%{version_internal}/extensions/
   454 %{_libdir}/xulrunner-%{version_internal}/chrome/icons/
   458 %{_libdir}/xulrunner-%{version_internal}/chrome/icons/
   455 %{_libdir}/xulrunner-%{version_internal}/components/
   459 %{_libdir}/xulrunner-%{version_internal}/components/
   456 %{_libdir}/xulrunner-%{version_internal}/plugins/
       
   457 %{_libdir}/xulrunner-%{version_internal}/*.so
   460 %{_libdir}/xulrunner-%{version_internal}/*.so
   458 %exclude %{_libdir}/xulrunner-%{version_internal}/libmozjs.so
   461 %exclude %{_libdir}/xulrunner-%{version_internal}/libmozjs.so
   459 %{_libdir}/xulrunner-%{version_internal}/add-plugins.sh
   462 %{_libdir}/xulrunner-%{version_internal}/add-plugins.sh
   460 %{_libdir}/xulrunner-%{version_internal}/chrome.manifest
   463 %{_libdir}/xulrunner-%{version_internal}/chrome.manifest
   461 %{_libdir}/xulrunner-%{version_internal}/dependentlibs.list
   464 %{_libdir}/xulrunner-%{version_internal}/dependentlibs.list
   491 %{_libdir}/xulrunner-%{version_internal}/libmozjs.so
   494 %{_libdir}/xulrunner-%{version_internal}/libmozjs.so
   492 
   495 
   493 %files devel
   496 %files devel
   494 %defattr(-,root,root)
   497 %defattr(-,root,root)
   495 %{_libdir}/xulrunner-devel-%{version_internal}/
   498 %{_libdir}/xulrunner-devel-%{version_internal}/
       
   499 %{_libdir}/xulrunner-%{version_internal}/js-gdb.py
   496 # FIXME symlink dynamic libs below sdk/lib
   500 # FIXME symlink dynamic libs below sdk/lib
   497 %attr(644,root,root) %{_libdir}/pkgconfig/*
   501 %attr(644,root,root) %{_libdir}/pkgconfig/*
   498 %{_includedir}/xulrunner-%{version_internal}/
   502 %{_includedir}/xulrunner-%{version_internal}/
   499 %{_datadir}/xulrunner-%{version_internal}/
   503 %{_datadir}/xulrunner-%{version_internal}/
   500 
   504