MozillaFirefox/MozillaFirefox.spec
changeset 836 12530a091878
parent 831 ac54f3b3e13c
child 837 a1f740acf68e
equal deleted inserted replaced
831:ac54f3b3e13c 836:12530a091878
     1 #
     1 #
     2 # spec file for package MozillaFirefox
     2 # spec file for package MozillaFirefox
     3 #
     3 #
     4 # Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
     4 # Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
     5 #               2006-2015 Wolfgang Rosenauer
     5 #               2006-2015 Wolfgang Rosenauer
     6 #
     6 #
     7 # All modifications and additions to the file contributed by third parties
     7 # All modifications and additions to the file contributed by third parties
     8 # remain the property of their copyright owners, unless otherwise agreed
     8 # remain the property of their copyright owners, unless otherwise agreed
     9 # upon. The license for this file, and modifications and additions to the
     9 # upon. The license for this file, and modifications and additions to the
    14 # published by the Open Source Initiative.
    14 # published by the Open Source Initiative.
    15 
    15 
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
       
    19 
    19 # changed with every update
    20 # changed with every update
    20 %define major 35
    21 %define major 36
    21 %define mainver %major.99
    22 %define mainver %major.99
    22 %define update_channel beta
    23 %define update_channel beta
    23 %define releasedate 2015021800
    24 %define releasedate 2015022800
    24 
    25 
    25 # general build definitions
    26 # general build definitions
    26 %if "%{update_channel}" != "aurora"
    27 %if "%{update_channel}" != "aurora"
    27 %define progname firefox
    28 %define progname firefox
    28 %define pkgname  MozillaFirefox
    29 %define pkgname  MozillaFirefox
    69 BuildRequires:  fdupes
    70 BuildRequires:  fdupes
    70 BuildRequires:  gcc-c++
    71 BuildRequires:  gcc-c++
    71 BuildRequires:  libcurl-devel
    72 BuildRequires:  libcurl-devel
    72 BuildRequires:  libgnomeui-devel
    73 BuildRequires:  libgnomeui-devel
    73 BuildRequires:  libidl-devel
    74 BuildRequires:  libidl-devel
       
    75 BuildRequires:  libiw-devel
    74 BuildRequires:  libnotify-devel
    76 BuildRequires:  libnotify-devel
       
    77 BuildRequires:  libproxy-devel
    75 BuildRequires:  makeinfo
    78 BuildRequires:  makeinfo
       
    79 BuildRequires:  mozilla-nspr-devel >= 4.10.8
       
    80 BuildRequires:  mozilla-nss-devel >= 3.17.4
       
    81 BuildRequires:  nss-shared-helper-devel
    76 BuildRequires:  python-devel
    82 BuildRequires:  python-devel
    77 BuildRequires:  startup-notification-devel
    83 BuildRequires:  startup-notification-devel
    78 BuildRequires:  unzip
    84 BuildRequires:  unzip
    79 BuildRequires:  update-desktop-files
    85 BuildRequires:  update-desktop-files
    80 BuildRequires:  xorg-x11-libXt-devel
    86 BuildRequires:  xorg-x11-libXt-devel
    81 BuildRequires:  yasm
    87 BuildRequires:  yasm
    82 BuildRequires:  zip
    88 BuildRequires:  zip
    83 BuildRequires:  libiw-devel
       
    84 BuildRequires:  libproxy-devel
       
    85 BuildRequires:  mozilla-nspr-devel >= 4.10.7
       
    86 BuildRequires:  mozilla-nss-devel >= 3.17.4
       
    87 BuildRequires:  nss-shared-helper-devel
       
    88 BuildRequires:  pkgconfig(libpulse)
       
    89 BuildRequires:  pkgconfig(gstreamer-%gstreamer_ver)
    89 BuildRequires:  pkgconfig(gstreamer-%gstreamer_ver)
    90 BuildRequires:  pkgconfig(gstreamer-app-%gstreamer_ver)
    90 BuildRequires:  pkgconfig(gstreamer-app-%gstreamer_ver)
    91 BuildRequires:  pkgconfig(gstreamer-plugins-base-%gstreamer_ver)
    91 BuildRequires:  pkgconfig(gstreamer-plugins-base-%gstreamer_ver)
       
    92 BuildRequires:  pkgconfig(libpulse)
    92 %if 0%{?gstreamer} == 1
    93 %if 0%{?gstreamer} == 1
    93 Requires:       libgstreamer-1_0-0
    94 Requires:       libgstreamer-1_0-0
    94 Recommends:     gstreamer-fluendo-mp3
    95 Recommends:     gstreamer-fluendo-mp3
    95 Recommends:     gstreamer-plugins-libav
    96 Recommends:     gstreamer-plugins-libav
    96 %else
    97 %else
   195 of %{appname}.
   196 of %{appname}.
   196 
   197 
   197 %package translations-other
   198 %package translations-other
   198 Summary:        Extra translations for %{appname}
   199 Summary:        Extra translations for %{appname}
   199 Group:          System/Localization
   200 Group:          System/Localization
   200 Provides:       locale(%{name}:ach;af;ak;as;ast;be;bg;bn_BD;bn_IN;br;bs;csb;cy;en_ZA;eo;es_MX;et;eu;fa;ff;fy_NL;ga_IE;gd;gl;gu_IN;he;hi_IN;hr;hy_AM;id;is;kk;km;kn;ku;lg;lij;lt;lv;mai;mk;ml;mr;nn_NO;nso;or;pa_IN;rm;ro;si;sk;sl;son;sq;sr;ta;ta_LK;te;th;tr;uk;vi;zu)
   201 Provides:       locale(%{name}:ach;af;ak;as;ast;be;bg;bn_BD;bn_IN;br;bs;csb;cy;en_ZA;eo;es_MX;et;eu;fa;ff;fy_NL;ga_IE;gd;gl;gu_IN;he;hi_IN;hr;hy_AM;id;is;kk;km;kn;ku;lg;lij;lt;lv;mai;mk;ml;mr;nn_NO;nso;or;pa_IN;rm;ro;si;sk;sl;son;sq;sr;ta;ta_LK;te;th;tr;uk;uz;vi;zu)
   201 Requires:       %{name} = %{version}
   202 Requires:       %{name} = %{version}
   202 Obsoletes:      %{name}-translations < %{version}-%{release}
   203 Obsoletes:      %{name}-translations < %{version}-%{release}
   203 
   204 
   204 %description translations-other
   205 %description translations-other
   205 This package contains rarely used languages for the user interface
   206 This package contains rarely used languages for the user interface