MozillaFirefox/MozillaFirefox.spec
changeset 1002 138bb1a89f97
parent 998 6c6109948e35
child 1003 b1170eeb30b1
equal deleted inserted replaced
994:9fc447b00040 1002:138bb1a89f97
    14 # published by the Open Source Initiative.
    14 # published by the Open Source Initiative.
    15 
    15 
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
       
    19 
    19 # changed with every update
    20 # changed with every update
    20 %define major 55
    21 %define major 56
    21 %define mainver %major.99
    22 %define mainver %major.99
    22 %define update_channel beta
    23 %define update_channel beta
    23 %define branding 1
    24 %define branding 1
    24 %define releasedate 20170914000000
    25 %define releasedate 20170926190823
    25 
    26 
    26 # PIE, full relro (x86_64 for now)
    27 # PIE, full relro (x86_64 for now)
    27 %define build_hardened 1
    28 %define build_hardened 1
    28 
    29 
    29 # Firefox only supports i686
    30 # Firefox only supports i686
    30 %ifarch %ix86
    31 %ifarch %ix86
    31 ExclusiveArch: i586 i686
    32 ExclusiveArch:  i586 i686
    32 BuildArch:     i686
    33 BuildArch:      i686
    33 %{expand:%%global optflags %(echo "%optflags"|sed -e s/i586/i686/) -march=i686 -mtune=generic}
    34 %{expand:%%global optflags %(echo "%optflags"|sed -e s/i586/i686/) -march=i686 -mtune=generic}
    34 %endif
    35 %endif
    35 
    36 
    36 # general build definitions
    37 # general build definitions
    37 %define progname firefox
    38 %define progname firefox
    52 %define crashreporter 0
    53 %define crashreporter 0
    53 %endif
    54 %endif
    54 
    55 
    55 Name:           %{pkgname}
    56 Name:           %{pkgname}
    56 BuildRequires:  Mesa-devel
    57 BuildRequires:  Mesa-devel
       
    58 BuildRequires:  alsa-devel
    57 BuildRequires:  autoconf213
    59 BuildRequires:  autoconf213
    58 BuildRequires:  dbus-1-glib-devel
    60 BuildRequires:  dbus-1-glib-devel
    59 BuildRequires:  fdupes
    61 BuildRequires:  fdupes
    60 %if 0%{?suse_version} <= 1320
    62 %if 0%{?suse_version} <= 1320
    61 BuildRequires:  gcc5-c++
    63 BuildRequires:  gcc5-c++
    62 %else
    64 %else
    63 BuildRequires:  gcc-c++
    65 BuildRequires:  gcc-c++
    64 %endif
    66 %endif
       
    67 BuildRequires:  cargo
    65 BuildRequires:  libXcomposite-devel
    68 BuildRequires:  libXcomposite-devel
    66 BuildRequires:  libcurl-devel
    69 BuildRequires:  libcurl-devel
    67 BuildRequires:  libgnomeui-devel
       
    68 BuildRequires:  libidl-devel
    70 BuildRequires:  libidl-devel
    69 BuildRequires:  libiw-devel
    71 BuildRequires:  libiw-devel
    70 BuildRequires:  libnotify-devel
    72 BuildRequires:  libnotify-devel
    71 BuildRequires:  libproxy-devel
    73 BuildRequires:  libproxy-devel
    72 BuildRequires:  makeinfo
    74 BuildRequires:  makeinfo
    73 BuildRequires:  mozilla-nspr-devel >= 4.16
    75 BuildRequires:  mozilla-nspr-devel >= 4.16
    74 BuildRequires:  mozilla-nss-devel >= 3.32.1
    76 BuildRequires:  mozilla-nss-devel >= 3.32.1
    75 BuildRequires:  python-devel
    77 BuildRequires:  python-devel
       
    78 BuildRequires:  rust >= 1.15.1
       
    79 BuildRequires:  rust-std
    76 BuildRequires:  startup-notification-devel
    80 BuildRequires:  startup-notification-devel
    77 BuildRequires:  unzip
    81 BuildRequires:  unzip
    78 BuildRequires:  update-desktop-files
    82 BuildRequires:  update-desktop-files
    79 BuildRequires:  xorg-x11-libXt-devel
    83 BuildRequires:  xorg-x11-libXt-devel
    80 BuildRequires:  yasm
    84 BuildRequires:  yasm
    81 BuildRequires:  zip
    85 BuildRequires:  zip
       
    86 BuildRequires:  pkgconfig(gconf-2.0)
       
    87 BuildRequires:  pkgconfig(gdk-x11-2.0)
       
    88 BuildRequires:  pkgconfig(glib-2.0) >= 2.22
       
    89 BuildRequires:  pkgconfig(gobject-2.0)
       
    90 BuildRequires:  pkgconfig(gtk+-2.0) >= 2.18.0
       
    91 BuildRequires:  pkgconfig(gtk+-3.0) >= 3.4.0
       
    92 BuildRequires:  pkgconfig(gtk+-unix-print-2.0)
       
    93 BuildRequires:  pkgconfig(gtk+-unix-print-3.0)
       
    94 BuildRequires:  pkgconfig(libffi)
    82 BuildRequires:  pkgconfig(libpulse)
    95 BuildRequires:  pkgconfig(libpulse)
    83 BuildRequires:  pkgconfig(libffi)
    96 %if 0%{?suse_version} > 1320
    84 BuildRequires:  pkgconfig(glib-2.0)
    97 BuildRequires:  llvm-clang-devel >= 3.9.0
    85 BuildRequires:  pkgconfig(gobject-2.0)
    98 %endif
    86 BuildRequires:  pkgconfig(gtk+-3.0) >= 3.4.0
       
    87 BuildRequires:  pkgconfig(gtk+-unix-print-3.0)
       
    88 BuildRequires:  cargo
       
    89 BuildRequires:  rust >= 1.15.1
       
    90 BuildRequires:  rust-std
       
    91 #BuildRequires:  llvm-clang-devel >= 3.9.0
       
    92 # libavcodec is required for H.264 support but the
    99 # libavcodec is required for H.264 support but the
    93 # openSUSE version is currently not able to play H.264
   100 # openSUSE version is currently not able to play H.264
    94 # therefore the Packman version is required
   101 # therefore the Packman version is required
    95 # minimum version of libavcodec is 53
   102 # minimum version of libavcodec is 53
    96 Recommends:     libavcodec-full >= 0.10.16
   103 Recommends:     libavcodec-full >= 0.10.16
   348 ac_add_options --enable-startup-notification
   355 ac_add_options --enable-startup-notification
   349 #ac_add_options --enable-chrome-format=jar
   356 #ac_add_options --enable-chrome-format=jar
   350 ac_add_options --enable-update-channel=%{update_channel}
   357 ac_add_options --enable-update-channel=%{update_channel}
   351 ac_add_options --with-mozilla-api-keyfile=%{SOURCE18}
   358 ac_add_options --with-mozilla-api-keyfile=%{SOURCE18}
   352 ac_add_options --with-google-api-keyfile=%{SOURCE19}
   359 ac_add_options --with-google-api-keyfile=%{SOURCE19}
       
   360 %if 0%{?suse_version} > 1320
   353 ac_add_options --disable-stylo
   361 ac_add_options --disable-stylo
       
   362 %endif
   354 %if %branding
   363 %if %branding
   355 ac_add_options --enable-official-branding
   364 ac_add_options --enable-official-branding
   356 %endif
   365 %endif
   357 ac_add_options --enable-libproxy
   366 ac_add_options --enable-libproxy
   358 %if ! %crashreporter
   367 %if ! %crashreporter