MozillaFirefox/MozillaFirefox.spec
changeset 898 1d01621f9535
parent 895 b0e57b478b1b
child 899 44a28160de40
equal deleted inserted replaced
889:de3a92aed259 898:1d01621f9535
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major 42
    21 %define major 43
    22 %define mainver %major.99
    22 %define mainver %major.99
    23 %define update_channel beta
    23 %define update_channel beta
    24 %define releasedate 2015120300
    24 %define releasedate 2015123000
    25 
    25 
    26 # general build definitions
    26 # general build definitions
    27 %if "%{update_channel}" != "aurora"
    27 %if "%{update_channel}" != "aurora"
    28 %define progname firefox
    28 %define progname firefox
    29 %define pkgname  MozillaFirefox
    29 %define pkgname  MozillaFirefox
    67 BuildRequires:  Mesa-devel
    67 BuildRequires:  Mesa-devel
    68 BuildRequires:  autoconf213
    68 BuildRequires:  autoconf213
    69 BuildRequires:  dbus-1-glib-devel
    69 BuildRequires:  dbus-1-glib-devel
    70 BuildRequires:  fdupes
    70 BuildRequires:  fdupes
    71 BuildRequires:  gcc-c++
    71 BuildRequires:  gcc-c++
       
    72 BuildRequires:  libXcomposite-devel
    72 BuildRequires:  libcurl-devel
    73 BuildRequires:  libcurl-devel
    73 BuildRequires:  libgnomeui-devel
    74 BuildRequires:  libgnomeui-devel
    74 BuildRequires:  libidl-devel
    75 BuildRequires:  libidl-devel
    75 BuildRequires:  libiw-devel
    76 BuildRequires:  libiw-devel
    76 BuildRequires:  libnotify-devel
    77 BuildRequires:  libnotify-devel
    77 BuildRequires:  libproxy-devel
    78 BuildRequires:  libproxy-devel
    78 BuildRequires:  makeinfo
    79 BuildRequires:  makeinfo
    79 BuildRequires:  mozilla-nspr-devel >= 4.10.10
    80 BuildRequires:  mozilla-nspr-devel >= 4.11
    80 BuildRequires:  mozilla-nss-devel >= 3.19.4
    81 BuildRequires:  mozilla-nss-devel >= 3.21
    81 BuildRequires:  nss-shared-helper-devel
    82 BuildRequires:  nss-shared-helper-devel
    82 BuildRequires:  python-devel
    83 BuildRequires:  python-devel
    83 BuildRequires:  startup-notification-devel
    84 BuildRequires:  startup-notification-devel
    84 BuildRequires:  unzip
    85 BuildRequires:  unzip
    85 BuildRequires:  update-desktop-files
    86 BuildRequires:  update-desktop-files
    88 BuildRequires:  zip
    89 BuildRequires:  zip
    89 BuildRequires:  pkgconfig(gstreamer-%gstreamer_ver)
    90 BuildRequires:  pkgconfig(gstreamer-%gstreamer_ver)
    90 BuildRequires:  pkgconfig(gstreamer-app-%gstreamer_ver)
    91 BuildRequires:  pkgconfig(gstreamer-app-%gstreamer_ver)
    91 BuildRequires:  pkgconfig(gstreamer-plugins-base-%gstreamer_ver)
    92 BuildRequires:  pkgconfig(gstreamer-plugins-base-%gstreamer_ver)
    92 BuildRequires:  pkgconfig(libpulse)
    93 BuildRequires:  pkgconfig(libpulse)
       
    94 # libavcodec is already used if available for H.264 but
       
    95 # explicitely loaded by FF. For proper H.264 support the
       
    96 # openSUSE delivered version is not sufficient but currently
       
    97 # prevents even the use of the GStreamer method
       
    98 # https://bugzilla.mozilla.org/show_bug.cgi?id=1234157
       
    99 # to get H.264 working correctly libavcodec from packman
       
   100 # is required. As of today the following recommends will
       
   101 # pull in libavcodec52 from packman since it's the only
       
   102 # package providing libavcodec but it's not loaded from
       
   103 # Firefox as the minimal version is 53
       
   104 #Recommends:     libavcodec
    93 %if 0%{?gstreamer} == 1
   105 %if 0%{?gstreamer} == 1
    94 Requires:       libgstreamer-1_0-0
   106 Requires:       libgstreamer-1_0-0
    95 Recommends:     gstreamer-fluendo-mp3
   107 Recommends:     gstreamer-fluendo-mp3
    96 Recommends:     gstreamer-plugins-libav
   108 Recommends:     gstreamer-plugins-libav
    97 %else
   109 %else
   145 Patch6:         mozilla-ntlm-full-path.patch
   157 Patch6:         mozilla-ntlm-full-path.patch
   146 Patch7:         mozilla-repo.patch
   158 Patch7:         mozilla-repo.patch
   147 Patch8:         mozilla-openaes-decl.patch
   159 Patch8:         mozilla-openaes-decl.patch
   148 Patch10:        mozilla-no-stdcxx-check.patch
   160 Patch10:        mozilla-no-stdcxx-check.patch
   149 Patch11:        mozilla-libproxy.patch
   161 Patch11:        mozilla-libproxy.patch
       
   162 Patch12:        mozilla-bmo1233434.patch
   150 # Firefox/browser
   163 # Firefox/browser
   151 Patch101:       firefox-kde.patch
   164 Patch101:       firefox-kde.patch
   152 Patch102:       firefox-no-default-ualocale.patch
   165 Patch102:       firefox-no-default-ualocale.patch
   153 Patch103:       firefox-branded-icons.patch
   166 Patch103:       firefox-branded-icons.patch
   154 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   167 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   254 %patch6 -p1
   267 %patch6 -p1
   255 %patch7 -p1
   268 %patch7 -p1
   256 %patch8 -p1
   269 %patch8 -p1
   257 %patch10 -p1
   270 %patch10 -p1
   258 %patch11 -p1
   271 %patch11 -p1
       
   272 %patch12 -p1
   259 # Firefox
   273 # Firefox
   260 %patch101 -p1
   274 %patch101 -p1
   261 %patch102 -p1
   275 %patch102 -p1
   262 %patch103 -p1
   276 %patch103 -p1
   263 
   277 
   306 ac_add_options --libdir=%{_libdir}
   320 ac_add_options --libdir=%{_libdir}
   307 ac_add_options --sysconfdir=%{_sysconfdir}
   321 ac_add_options --sysconfdir=%{_sysconfdir}
   308 ac_add_options --mandir=%{_mandir}
   322 ac_add_options --mandir=%{_mandir}
   309 ac_add_options --includedir=%{_includedir}
   323 ac_add_options --includedir=%{_includedir}
   310 ac_add_options --enable-release
   324 ac_add_options --enable-release
       
   325 %if 0%{?suse_version} > 1320
       
   326 #ac_add_options --enable-default-toolkit=cairo-gtk3
       
   327 %endif
   311 %ifarch %ix86 %arm
   328 %ifarch %ix86 %arm
   312 %if 0%{?suse_version} > 1230
   329 %if 0%{?suse_version} > 1230
   313 ac_add_options --disable-optimize
   330 ac_add_options --disable-optimize
   314 %endif
   331 %endif
   315 %endif
   332 %endif
   554 %dir %{progdir}/distribution/
   571 %dir %{progdir}/distribution/
   555 %{progdir}/distribution/extensions/
   572 %{progdir}/distribution/extensions/
   556 %{progdir}/components/
   573 %{progdir}/components/
   557 %{progdir}/defaults/
   574 %{progdir}/defaults/
   558 %{progdir}/dictionaries/
   575 %{progdir}/dictionaries/
       
   576 %if 0%{?suse_version} > 1320
       
   577 #%dir %{progdir}/gtk2
       
   578 %{progdir}/gtk2/libmozgtk.so
       
   579 %endif
   559 %{progdir}/webapprt/
   580 %{progdir}/webapprt/
   560 %{progdir}/gmp-clearkey/
   581 %{progdir}/gmp-clearkey/
   561 %attr(755,root,root) %{progdir}/%{progname}.sh
   582 %attr(755,root,root) %{progdir}/%{progname}.sh
   562 %{progdir}/firefox
   583 %{progdir}/firefox
   563 %{progdir}/firefox-bin
   584 %{progdir}/firefox-bin