xulrunner/xulrunner.spec
branchfirefox31
changeset 814 354545f01596
parent 799 a2fc8620fb23
child 815 2a8cd51644d2
equal deleted inserted replaced
812:bb30bb6a8754 814:354545f01596
    23 %define shared_js 0
    23 %define shared_js 0
    24 %define has_system_nspr  1
    24 %define has_system_nspr  1
    25 %define has_system_nss   1
    25 %define has_system_nss   1
    26 %define has_system_cairo 0
    26 %define has_system_cairo 0
    27 %define localize         0
    27 %define localize         0
    28 %ifarch ppc ppc64 s390 s390x ia64 %arm
    28 %ifarch aarch64 ppc ppc64 ppc64le s390 s390x ia64 %arm
    29 %define crashreporter    0
    29 %define crashreporter    0
    30 %else
    30 %else
    31 %define crashreporter    0
    31 %define crashreporter    0
    32 %endif
    32 %endif
    33 %if %suse_version > 1210
    33 %if %suse_version > 1210
   119 Patch16:        mozilla-idldir.patch
   119 Patch16:        mozilla-idldir.patch
   120 # Gecko/Toolkit AArch64 Porting
   120 # Gecko/Toolkit AArch64 Porting
   121 Patch30:        mozilla-aarch64-bmo-810631.patch
   121 Patch30:        mozilla-aarch64-bmo-810631.patch
   122 
   122 
   123 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   123 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
       
   124 %if 0%{?shared_js} == 1
   124 Requires:       mozilla-js = %{version}
   125 Requires:       mozilla-js = %{version}
       
   126 %endif
   125 Requires(post):  update-alternatives coreutils
   127 Requires(post):  update-alternatives coreutils
   126 Requires(preun): update-alternatives coreutils
   128 Requires(preun): update-alternatives coreutils
   127 Provides:       xulrunner-esr = %{version}
   129 Provides:       xulrunner-esr = %{version}
   128 Obsoletes:      xulrunner-esr < 24.0
   130 Obsoletes:      xulrunner-esr < 24.0
   129 %define _use_internal_dependency_generator 0
   131 %define _use_internal_dependency_generator 0
   216 %patch1 -p1
   218 %patch1 -p1
   217 %patch2 -p1
   219 %patch2 -p1
   218 %patch3 -p1
   220 %patch3 -p1
   219 %patch6 -p1
   221 %patch6 -p1
   220 %patch7 -p1
   222 %patch7 -p1
       
   223 %patch8 -p1
       
   224 %patch9 -p1
   221 %if %suse_version < 1120
   225 %if %suse_version < 1120
   222 %patch9 -p1
       
   223 %endif
       
   224 %patch10 -p1
   226 %patch10 -p1
       
   227 %endif
   225 %patch11 -p1
   228 %patch11 -p1
   226 %patch12 -p1
   229 %patch12 -p1
   227 %patch13 -p1
   230 %patch13 -p1
   228 %patch14 -p1
   231 %patch14 -p1
   229 %patch15 -p1
   232 %patch15 -p1
   236 DATE="\"$(date -d "${modified}" "+%%b %%e %%Y")\""
   239 DATE="\"$(date -d "${modified}" "+%%b %%e %%Y")\""
   237 TIME="\"$(date -d "${modified}" "+%%R")\""
   240 TIME="\"$(date -d "${modified}" "+%%R")\""
   238 find . -regex ".*\.c\|.*\.cpp\|.*\.h" -exec sed -i "s/__DATE__/${DATE}/g;s/__TIME__/${TIME}/g" {} +
   241 find . -regex ".*\.c\|.*\.cpp\|.*\.h" -exec sed -i "s/__DATE__/${DATE}/g;s/__TIME__/${TIME}/g" {} +
   239 #
   242 #
   240 MOZ_APP_DIR=%{_libdir}/xulrunner-%{version_internal}
   243 MOZ_APP_DIR=%{_libdir}/xulrunner-%{version_internal}
       
   244 source %{SOURCE8}
   241 export MOZ_BUILD_DATE=%{releasedate}
   245 export MOZ_BUILD_DATE=%{releasedate}
       
   246 export MOZ_SOURCE_STAMP=$REV
       
   247 export SOURCE_REPO=$REPO
       
   248 export source_repo=$REPO
       
   249 export MOZ_SOURCE_REPO=$REPO
       
   250 export MOZILLA_OFFICIAL=1
       
   251 export BUILD_OFFICIAL=1
   242 export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
   252 export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
   243 %ifarch %ix86
   253 %ifarch %ix86
   244 export CFLAGS="${CFLAGS} -Os"
   254 export CFLAGS="${CFLAGS} -Os"
   245 %endif
   255 %endif
   246 %ifarch ppc64
   256 %ifarch ppc64
   252 export CFLAGS="${CFLAGS/-g/}"
   262 export CFLAGS="${CFLAGS/-g/}"
   253 LDFLAGS+="-Wl,--reduce-memory-overheads -Wl,--no-keep-memory"
   263 LDFLAGS+="-Wl,--reduce-memory-overheads -Wl,--no-keep-memory"
   254 %endif
   264 %endif
   255 export CXXFLAGS="$CFLAGS"
   265 export CXXFLAGS="$CFLAGS"
   256 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   266 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   257 export MOZILLA_OFFICIAL=1
       
   258 export BUILD_OFFICIAL=1
       
   259 export MOZ_MILESTONE_RELEASE=1
   267 export MOZ_MILESTONE_RELEASE=1
   260 #
   268 #
   261 cat << EOF > $MOZCONFIG
   269 cat << EOF > $MOZCONFIG
   262 mk_add_options MOZILLA_OFFICIAL=1
   270 mk_add_options MOZILLA_OFFICIAL=1
   263 mk_add_options BUILD_OFFICIAL=1
   271 mk_add_options BUILD_OFFICIAL=1
   325 %ifarch %arm
   333 %ifarch %arm
   326 ac_add_options --disable-neon
   334 ac_add_options --disable-neon
   327 %endif
   335 %endif
   328 %ifnarch %ix86 x86_64
   336 %ifnarch %ix86 x86_64
   329 ac_add_options --disable-webrtc
   337 ac_add_options --disable-webrtc
       
   338 %endif
       
   339 # try to use OpenGL-ES on ARM
       
   340 %ifarch %arm
       
   341 ac_add_options --with-gl-provider=EGL
   330 %endif
   342 %endif
   331 EOF
   343 EOF
   332 make -f client.mk build
   344 make -f client.mk build
   333 
   345 
   334 %install
   346 %install
   490 %ghost %{_libdir}/xulrunner-%{version_internal}/global.reginfo
   502 %ghost %{_libdir}/xulrunner-%{version_internal}/global.reginfo
   491 %if %suse_version >= 1120
   503 %if %suse_version >= 1120
   492 %ghost %{_bindir}/xulrunner
   504 %ghost %{_bindir}/xulrunner
   493 %endif
   505 %endif
   494 # API symlink (already in mozilla-js)
   506 # API symlink (already in mozilla-js)
   495 #%{_libdir}/xulrunner-%{apiversion}
   507 %if 0%{?shared_js} == 0
       
   508 %{_libdir}/xulrunner-%{apiversion}
       
   509 %endif
   496 # compat symlinks
   510 # compat symlinks
   497 %if 0%{?ga_version:1}
   511 %if 0%{?ga_version:1}
   498 %ghost %{_libdir}/xulrunner-%{ga_version}
   512 %ghost %{_libdir}/xulrunner-%{ga_version}
   499 %endif
   513 %endif
   500 
   514 
   514 %attr(644,root,root) %{_libdir}/pkgconfig/*
   528 %attr(644,root,root) %{_libdir}/pkgconfig/*
   515 %{_includedir}/xulrunner-%{version_internal}/
   529 %{_includedir}/xulrunner-%{version_internal}/
   516 %{_datadir}/xulrunner-%{version_internal}/
   530 %{_datadir}/xulrunner-%{version_internal}/
   517 
   531 
   518 %if %localize
   532 %if %localize
   519 
       
   520 %files translations-common -f %{_tmppath}/translations.common
   533 %files translations-common -f %{_tmppath}/translations.common
   521 %defattr(-,root,root)
   534 %defattr(-,root,root)
   522 %dir %{_libdir}/xulrunner-%{version_internal}/
   535 %dir %{_libdir}/xulrunner-%{version_internal}/
   523 %dir %{_libdir}/xulrunner-%{version_internal}/chrome/
   536 %dir %{_libdir}/xulrunner-%{version_internal}/chrome/
   524 
   537 
   527 %dir %{_libdir}/xulrunner-%{version_internal}/
   540 %dir %{_libdir}/xulrunner-%{version_internal}/
   528 %dir %{_libdir}/xulrunner-%{version_internal}/chrome/
   541 %dir %{_libdir}/xulrunner-%{version_internal}/chrome/
   529 %endif
   542 %endif
   530 
   543 
   531 %if %crashreporter
   544 %if %crashreporter
   532 
       
   533 %files buildsymbols
   545 %files buildsymbols
   534 %defattr(-,root,root)
   546 %defattr(-,root,root)
   535 %{_datadir}/mozilla/
   547 %{_datadir}/mozilla/
   536 %endif
   548 %endif
   537 
   549