MozillaFirefox/MozillaFirefox.spec
changeset 1066 3f18b0f2a868
parent 1065 33c6119b5cc5
child 1067 735b140fb042
equal deleted inserted replaced
1060:5ce9d1f6be41 1066:3f18b0f2a868
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major          60
    21 %define major          61
    22 %define mainver        %major.99
    22 %define mainver        %major.99
    23 %define orig_version   61.0
    23 %define orig_version   62.0
    24 %define orig_suffix    b14
    24 %define orig_suffix    b19
    25 %define update_channel beta
    25 %define update_channel beta
    26 %define branding       1
    26 %define branding       1
    27 %define releasedate    20180614135649
    27 %define releasedate    20180820172315
    28 %define source_prefix  firefox-%{orig_version}
    28 %define source_prefix  firefox-%{orig_version}
    29 
    29 
    30 # PIE, full relro (x86_64 for now)
    30 # PIE, full relro (x86_64 for now)
    31 %define build_hardened 1
    31 %define build_hardened 1
    32 
    32 
    73 BuildRequires:  libiw-devel
    73 BuildRequires:  libiw-devel
    74 BuildRequires:  libnotify-devel
    74 BuildRequires:  libnotify-devel
    75 BuildRequires:  libproxy-devel
    75 BuildRequires:  libproxy-devel
    76 BuildRequires:  makeinfo
    76 BuildRequires:  makeinfo
    77 BuildRequires:  mozilla-nspr-devel >= 4.19
    77 BuildRequires:  mozilla-nspr-devel >= 4.19
    78 BuildRequires:  mozilla-nss-devel >= 3.37.3
    78 BuildRequires:  mozilla-nss-devel >= 3.38
    79 BuildRequires:  python-devel
    79 BuildRequires:  python-devel
    80 BuildRequires:  python2-xml
    80 BuildRequires:  python2-xml
       
    81 BuildRequires:  python3 >= 3.5
    81 BuildRequires:  rust >= 1.24
    82 BuildRequires:  rust >= 1.24
    82 BuildRequires:  rust-std
    83 BuildRequires:  rust-std
    83 BuildRequires:  startup-notification-devel
    84 BuildRequires:  startup-notification-devel
    84 BuildRequires:  unzip
    85 BuildRequires:  unzip
    85 BuildRequires:  update-desktop-files
    86 BuildRequires:  update-desktop-files
   156 Patch4:         mozilla-openaes-decl.patch
   157 Patch4:         mozilla-openaes-decl.patch
   157 Patch5:         mozilla-no-stdcxx-check.patch
   158 Patch5:         mozilla-no-stdcxx-check.patch
   158 Patch6:         mozilla-reduce-files-per-UnifiedBindings.patch
   159 Patch6:         mozilla-reduce-files-per-UnifiedBindings.patch
   159 Patch7:         mozilla-aarch64-startup-crash.patch
   160 Patch7:         mozilla-aarch64-startup-crash.patch
   160 Patch8:         mozilla-bmo256180.patch
   161 Patch8:         mozilla-bmo256180.patch
   161 Patch9:         mozilla-enable-csd.patch
   162 Patch9:         mozilla-no-return.patch
   162 Patch10:        mozilla-no-return.patch
   163 Patch10:        mozilla-bmo1464766.patch
   163 Patch11:        mozilla-bmo1464766.patch
       
   164 # Firefox/browser
   164 # Firefox/browser
   165 Patch101:       firefox-kde.patch
   165 Patch101:       firefox-kde.patch
   166 Patch102:       firefox-branded-icons.patch
   166 Patch102:       firefox-branded-icons.patch
   167 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   167 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   168 Requires(post):   coreutils shared-mime-info desktop-file-utils
   168 Requires(post):   coreutils shared-mime-info desktop-file-utils
   268 %ifarch %ix86
   268 %ifarch %ix86
   269 %patch6 -p1
   269 %patch6 -p1
   270 %endif
   270 %endif
   271 %patch7 -p1
   271 %patch7 -p1
   272 %patch8 -p1
   272 %patch8 -p1
   273 #%patch9 -p1
   273 %patch9 -p1
   274 %patch10 -p1
   274 %patch10 -p1
   275 %patch11 -p1
       
   276 # Firefox
   275 # Firefox
   277 %patch101 -p1
   276 %patch101 -p1
   278 %patch102 -p1
   277 %patch102 -p1
   279 
   278 
   280 %build
   279 %build