MozillaFirefox/MozillaFirefox.spec
branchfirefox72
changeset 1119 4c5d44d40a03
parent 1118 27c3f029180a
child 1120 6168af2507a2
equal deleted inserted replaced
1118:27c3f029180a 1119:4c5d44d40a03
     1 #
     1 #
     2 # spec file for package MozillaFirefox
     2 # spec file for package MozillaFirefox
     3 #
     3 #
     4 # Copyright (c) 2019 SUSE LLC
     4 # Copyright (c) 2020 SUSE LLC
     5 #               2006-2019 Wolfgang Rosenauer <wr@rosenauer.org>
     5 #               2006-2019 Wolfgang Rosenauer <wr@rosenauer.org>
     6 #
     6 #
     7 # All modifications and additions to the file contributed by third parties
     7 # All modifications and additions to the file contributed by third parties
     8 # remain the property of their copyright owners, unless otherwise agreed
     8 # remain the property of their copyright owners, unless otherwise agreed
     9 # upon. The license for this file, and modifications and additions to the
     9 # upon. The license for this file, and modifications and additions to the
    16 # Please submit bugfixes or comments via https://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via https://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major          71
    21 %define major          72
    22 %define mainver        %major.0
    22 %define mainver        %major.0.1
    23 %define orig_version   71.0
    23 %define orig_version   72.0.1
    24 %define orig_suffix    %{nil}
    24 %define orig_suffix    %{nil}
    25 %define update_channel release
    25 %define update_channel release
    26 %define branding       1
    26 %define branding       1
    27 %define devpkg         1
    27 %define devpkg         1
    28 
    28 
    78 BuildRequires:  libidl-devel
    78 BuildRequires:  libidl-devel
    79 BuildRequires:  libiw-devel
    79 BuildRequires:  libiw-devel
    80 BuildRequires:  libnotify-devel
    80 BuildRequires:  libnotify-devel
    81 BuildRequires:  libproxy-devel
    81 BuildRequires:  libproxy-devel
    82 BuildRequires:  makeinfo
    82 BuildRequires:  makeinfo
    83 BuildRequires:  mozilla-nspr-devel >= 4.23
    83 BuildRequires:  mozilla-nspr-devel >= 4.24
    84 BuildRequires:  mozilla-nss-devel >= 3.47.1
    84 BuildRequires:  mozilla-nss-devel >= 3.48
    85 BuildRequires:  nasm >= 2.13
    85 BuildRequires:  nasm >= 2.13
    86 BuildRequires:  nodejs8 >= 8.11
    86 BuildRequires:  nodejs8 >= 8.11
    87 BuildRequires:  python-devel
    87 BuildRequires:  python-devel
    88 BuildRequires:  python2-xml
    88 BuildRequires:  python2-xml
    89 BuildRequires:  python3 >= 3.5
    89 BuildRequires:  python3 >= 3.5
   148 Source8:        firefox-mimeinfo.xml
   148 Source8:        firefox-mimeinfo.xml
   149 Source9:        firefox.js
   149 Source9:        firefox.js
   150 Source11:       firefox.1
   150 Source11:       firefox.1
   151 Source12:       mozilla-get-app-id
   151 Source12:       mozilla-get-app-id
   152 Source13:       spellcheck.js
   152 Source13:       spellcheck.js
   153 Source14:       https://github.com/openSUSE/firefox-scripts/raw/d414e38/create-tar.sh
   153 Source14:       https://github.com/openSUSE/firefox-scripts/raw/8a54002/create-tar.sh
   154 Source15:       firefox-appdata.xml
   154 Source15:       firefox-appdata.xml
   155 Source16:       %{name}.changes
   155 Source16:       %{name}.changes
   156 # Set up API keys, see http://www.chromium.org/developers/how-tos/api-keys
   156 # Set up API keys, see http://www.chromium.org/developers/how-tos/api-keys
   157 # Note: these are for the openSUSE Firefox builds ONLY. For your own distribution,
   157 # Note: these are for the openSUSE Firefox builds ONLY. For your own distribution,
   158 # please get your own set of keys.
   158 # please get your own set of keys.
   601 # Macros from %{name} package
   601 # Macros from %{name} package
   602 %%firefox_major              %{major}
   602 %%firefox_major              %{major}
   603 %%firefox_version            %{version}
   603 %%firefox_version            %{version}
   604 %%firefox_mainver            %{mainver}
   604 %%firefox_mainver            %{mainver}
   605 %%firefox_mozillapath        %%{_libdir}/%{progname}
   605 %%firefox_mozillapath        %%{_libdir}/%{progname}
   606 %%firefox_pluginsdir         %%{_libdir}/browser-plugins
   606 %%firefox_pluginsdir         %%{_libdir}/mozilla/plugins
   607 %%firefox_appid              \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
   607 %%firefox_appid              \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
   608 %%firefox_extdir             %%(if [ "%%_target_cpu" = "noarch" ]; then echo %%{_datadir}/mozilla/extensions/%%{firefox_appid}; else echo %%{_libdir}/mozilla/extensions/%%{firefox_appid}; fi)
   608 %%firefox_extdir             %%(if [ "%%_target_cpu" = "noarch" ]; then echo %%{_datadir}/mozilla/extensions/%%{firefox_appid}; else echo %%{_libdir}/mozilla/extensions/%%{firefox_appid}; fi)
   609 
   609 
   610 %%firefox_ext_install() \
   610 %%firefox_ext_install() \
   611    extdir="%%{buildroot}%%{firefox_extdir}/`mozilla-get-app-id '%%1'`" \
   611    extdir="%%{buildroot}%%{firefox_extdir}/`mozilla-get-app-id '%%1'`" \